If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

[Captain Rogers] Game launches into a black screen and is not playable

RESOLVED FIXED

Status

Tech Evangelism
Preinstalled B2G Apps
P1
normal
RESOLVED FIXED
3 years ago
3 years ago

People

(Reporter: thomas elin, Assigned: Andrzej Mazur)

Tracking

(Blocks: 1 bug)

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

3 years ago
Game currently launches into a black screen and is not playable. 

Reproduced on 1.4 (Buri)
Reproduced on 2.0 (Flame/Reference Phone)
(Reporter)

Updated

3 years ago
Assignee: nobody → andrzej.mazur
(Reporter)

Updated

3 years ago
Flags: needinfo?(andrzej.mazur)

Updated

3 years ago
Status: NEW → ASSIGNED
(Assignee)

Comment 1

3 years ago
I was able to test all my games on a device with Firefox OS 2.x installed and the issue is with Captain Rogers alone, all the other games are working fine. Plus the game launched inside the browser is playable, so it must be something with the manifest file and/or app permissions.

I'll install Firefox OS v2 on my Flame and will debug the problem.
Flags: needinfo?(andrzej.mazur)

Comment 2

3 years ago
Thank you, Andrzej, for the prompt reply. We look forward to hearing your findings!

Comment 3

3 years ago
Should be resolved shortly. Andrzej states: "I'm at the conference right now, but when I get back I'll get my hands on my Flame device, install Firefox OS v2 and see what's the problem. It shouldn't take much as it have to be something with the permissions, not the game itself."

Comment 4

3 years ago
Console logs: typeError: document.webL10n is undefined game.min.js:247.  Are you using
https://github.com/fabi1cazenave/webL10n/blob/master/l10n.js  I did not see this js file in the debugger but this may just be the symptom of something else failing before webL10n is created
(Assignee)

Comment 5

3 years ago
Thanks for the help Jason, the game was updated in the Marketplace and should work correctly now.

Michael, can you test and confirm it?
Flags: needinfo?(mellis)

Comment 6

3 years ago
Tested Captain Rogers today on Buri and Flame devices.  Everything worked great and played well, thanks Guys! 

Only question now is: How am I going to get any work done today?

Closing Bug - Issue resolved.
Status: ASSIGNED → RESOLVED
Last Resolved: 3 years ago
Flags: needinfo?(mellis)
Resolution: --- → FIXED

Comment 7

3 years ago
I updated the new version, and it is ok now.
Thanks for your help.
You need to log in before you can comment on or make changes to this bug.