[2.1][l10n][Calendar] Bengali-IN: The text length of "Thursday" is causing the number to appear on the bottom

VERIFIED FIXED

Status

Mozilla Localizations
bn-IN / Bengali (India)
VERIFIED FIXED
3 years ago
3 years ago

People

(Reporter: Petes, Assigned: biraj)

Tracking

({regression})

unspecified
ARM
Gonk (Firefox OS)
regression

Firefox Tracking Flags

(blocking-b2g:2.1+, b2g-v2.0 unaffected, b2g-v2.1 fixed, b2g-v2.2 verified)

Details

(Whiteboard: [NPOTB] LocRun2.1-2)

Attachments

(5 attachments)

(Reporter)

Description

3 years ago
Created attachment 8508997 [details]
2014-10-21-15-46-27.png

Description:
The text length of "Wednesday" is causing the number to appear on the bottom

Repro Steps:
1) Update a Flame to BuildID: 20141021001201.
2) Set the device language as বাংলা (ভারত).
3) Go to Calendar 
4) Tap Week


Actual:
Number appears on the bottom of the day 

Expected:
Number appears to the right/next to the day 


Flame 2.1 

Device: Flame 2.1 (319mb)(Kitkat Base)(Full Flash)
BuildID: 20141021001201
Gaia: e458f5804c0851eb4e93c9eb143fe044988cecda
Gecko: ee86921a986f
Gonk: 05aa7b98d3f891b334031dc710d48d0d6b82ec1d
Version: 34.0 (2.1)
Firmware: V180
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0

Repro Frequency: 100%
Link to failed test case: https://moztrap.mozilla.org/manage/case/14731/
See attached screenshot
(Reporter)

Comment 1

3 years ago
This issue does not reproduce on the Flame 2.0 (319mb)(Kitkat Base)(Full Flash), text length is causing the number to appear on the bottom.

Flame 2.0

Device: Flame 2.0 (319mb)(Kitkat Base)(Full Flash)
BuildID: 20141021000201
Gaia: 63b56a7a7453726b9e12ad1afe02c68c83c5aeca
Gecko: 40584eecdc75
Gonk: 05aa7b98d3f891b334031dc710d48d0d6b82ec1d
Version: 32.0 (2.0)
Firmware: V180
User Agent: Mozilla/5.0 (Mobile; rv:32.0) Gecko/32.0 Firefox/32.0
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(dharris)
(Reporter)

Updated

3 years ago
Summary: [2.1][l10n][Settings] Bengali-IN: The text length of "Wednesday" is causing the number to appear on the bottom → [2.1][l10n][Calendar] Bengali-IN: The text length of "Wednesday" is causing the number to appear on the bottom
[Blocking Requested - why for this release]:
This is a shipping locale, and a regression. This looks pretty bad.

ni UX to see if they can help?
blocking-b2g: --- → 2.1?
status-b2g-v2.0: --- → unaffected
Flags: needinfo?(firefoxos-ux-bugzilla)
Keywords: regression
(Assignee)

Comment 3

3 years ago
Hey all,

i hope the problem arised in "Thursday" section. If length is the then I can short "Thursday" translated sting. 

Let me know please
Flags: needinfo?(lebedel.delphine)
Pete: can you please confirm what Biraj is saying? thanks
Flags: needinfo?(psiphantong)
Flags: needinfo?(lebedel.delphine)
Flags: needinfo?(firefoxos-ux-bugzilla)
Regression = 2.1+
blocking-b2g: 2.1? → 2.1+
(Reporter)

Comment 6

3 years ago
Hi Biraj,

This issue still occurs on the latest build. The "Thursday" section length is causing the number to appear on the bottom
Flags: needinfo?(psiphantong)
Summary: [2.1][l10n][Calendar] Bengali-IN: The text length of "Wednesday" is causing the number to appear on the bottom → [2.1][l10n][Calendar] Bengali-IN: The text length of "Thursday" is causing the number to appear on the bottom
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(dharris)
(Assignee)

Comment 7

3 years ago
I have updated the "Thursday" string. Let me know the problem is still there or not.
Flags: needinfo?(psiphantong)
(Reporter)

Comment 8

3 years ago
Hi Biraj, this issue does not occur on the Flame 2.2, however if the date is double digits, the number does not display. Attached a screenshot.

Flame 2.2

Eronmental Variables:
Device: Flame Master
Build ID: 20141027040237
Gaia: e91d99e4d96954f06383c00bb9d79598a697e310
Gecko: 8230834302c9
Version: 36.0a1 (Master)
Firmware Version: v188
User Agent: Mozilla/5.0 (Mobile; rv:36.0) Gecko/36.0 Firefox/36.0

-------------------------------------------------------------------------------------------------------

This issue still reproduce on the latest Flame 2.1, number appears on the bottom of the day 

Flame 2.1 

Device: Flame 2.1 (319mb)(Kitkat Base)(Full Flash)
BuildID: 20141027001201
Gaia: c97463d61f45513a2123b19610386ddbfc916819
Gecko: 4f8c0c021128
Gonk: 6e51d9216901d39d192d9e6dd86a5e15b0641a89
Version: 34.0 (2.1)
Firmware: V188
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0
Flags: needinfo?(psiphantong)
(Reporter)

Comment 9

3 years ago
Created attachment 8512045 [details]
2014-10-27-12-42-16.png
(Assignee)

Comment 10

3 years ago
I have updated just two days back . So we have to wait till next commit for getting updates.
(Assignee)

Comment 11

3 years ago
I hope now it will work fine in both Flame 2.1 and 2.2
Flags: needinfo?(psiphantong)
(Reporter)

Comment 12

3 years ago
The same issue occurs on the latest Flame 2.2, if the date is double digits, the number does not display

Flame 2.2

Environmental Variables:
Device: Flame 2.2 Master (319mb)(Kitkat Base)(Full Flash)
BuildID: 20141030040201
Gaia: 0dfc1996eb583c8b507a82bf6b8319624bba23ea
Gecko: 80e18ff7c7b2
Gonk: 48835395daa6a49b281db62c50805bd6ca24077e
Version: 36.0a1 (2.2 Master)
Firmware: V188
User Agent: Mozilla/5.0 (Mobile; rv:36.0) Gecko/36.0 Firefox/36.0

--------------------------------------------------------------------------------------------------------------

This issue still reproduce on the latest Flame 2.1, number appears on the bottom of the day 

Flame 2.1 

Device: Flame 2.1 (319mb)(Kitkat Base)(Full Flash)
BuildID: 20141029001202
Gaia: eb0aab0f13c78c7ac378ad860e865c4b6eaf669f
Gecko: 318019f80a8e
Gonk: 48835395daa6a49b281db62c50805bd6ca24077e
Version: 34.0 (2.1)
Firmware: V188
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0
Flags: needinfo?(psiphantong)
:biraj, looks like you are helping from the l10n side so passing this on to youas we need all blockers assigned. Feel free to reassign if needed.
Assignee: nobody → brnet00
(Assignee)

Comment 14

3 years ago
Hi pete.

Could you please check once more with latest nightly? Please upload the screenshot.
(Reporter)

Comment 15

3 years ago
Hi Biraj, this issue does not occur on the Flame 2.2, the date is display correctly. Attached a screenshot.

Flame 2.2

Device: Flame 2.2(319mb)(KitKat)(Shallow Flash)
Build ID: 20141104040207
Gaia: 3c50520982560ccba301474d1ac43706138fc851
Gecko: 54d05732f29b
Version: 36.0a1 (2.2)
Firmware Version: v188-1
User Agent: Mozilla/5.0 (Mobile; rv:36.0) Gecko/36.0 Firefox/36.0

-------------------------------------------------------------------------------------------------------

This issue still reproduce on the latest Flame 2.1, number appears on the bottom of the day 

Flame 2.1 

Device: Flame 2.1 (319mb)(KitKat)(Shallow Flash)
BuildID: 20141104001202
Gaia: 8b0cf889ae0d48a9eb7ecdcb9b67590de45cc5e5
Gecko: 388b03efe92d
Gonk: 48835395daa6a49b281db62c50805bd6ca24077e
Version: 34.0 (2.1)
Firmware: V188-1
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0
(Reporter)

Comment 16

3 years ago
Created attachment 8516861 [details]
2014-11-04-13-50-30.png
(Assignee)

Comment 17

3 years ago
Thanks pate. Now I am closing this bug.
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → FIXED
(Assignee)

Updated

3 years ago
status-b2g-v2.2: --- → fixed
(Assignee)

Updated

3 years ago
Status: RESOLVED → VERIFIED
Whiteboard: LocRun2.1-2 → [NPOTB] LocRun2.1-2
status-b2g-v2.1: affected → fixed

Comment 18

3 years ago
According comment 15.This problem is verified not to happen on Flame2.2
status-b2g-v2.2: fixed → verified

Comment 19

3 years ago
Hi Mike,This problem still exists on Flame 2.1,Please refer to video and logcat.
Flame 2.1 build version:
ia-Rev        64db236bea9a0510567ab7ced2f2b4688737123c
Gecko-Rev       https://hg.mozilla.org/releases/mozilla-b2g34_v2_1/rev/273f24a1d1fe
Build-ID        20150111001202
Version         34.0
Reproduce rate  5/5
Happen time     10:08
Flags: needinfo?(mlien)

Comment 20

3 years ago
Created attachment 8547285 [details]
logcat.txt

Comment 21

3 years ago
Created attachment 8547306 [details]
VIDEO0225_Compress.MP4

Comment 22

3 years ago
Hi Biraj, v2.1 still has this problem. Could you help to check with it, thanks.
Flags: needinfo?(mlien) → needinfo?(brnet00)
(Assignee)

Comment 23

3 years ago
Hi Mike,

I am cheking this. But in the mean time can you help me to find the locate the string?

I guess this is the problem http://transvision.mozfr.org/?sourcelocale=en-US&locale=bn-IN&repo=gaia_2_1&search_type=entities&recherche=shared/date/date.properties:weekday-4-short 

also please upload the same screenshot of flame 2.2 . So I hope I can find the string very easily.
Flags: needinfo?(brnet00)
(Assignee)

Comment 24

3 years ago
Hey Mike,

I have again updated the string for flame 2.1. Could you please check again and let me know?

Thanks!
Status: VERIFIED → REOPENED
Flags: needinfo?(mlien)
Resolution: FIXED → ---

Comment 25

3 years ago
verified and fixed with today's v2.1 gaia/gecko
Gaia-Rev        6957ac8a322234ec99c8abb7cc18dc6a2e0176db
Gecko-Rev       https://hg.mozilla.org/releases/mozilla-b2g34_v2_1/rev/6600eba54256
Build-ID        20150113161204
Version         34.0
Device-Name     flame
FW-Release      4.4.2
FW-Incremental  eng.cltbld.20150113.192836
FW-Date         Tue Jan 13 19:28:47 EST 2015
Bootloader      L1TC100118D0
Flags: needinfo?(mlien)
(Assignee)

Comment 26

3 years ago
Awesome! Perfect
Status: REOPENED → RESOLVED
Last Resolved: 3 years ago3 years ago
Resolution: --- → FIXED
(Assignee)

Updated

3 years ago
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.