Closed Bug 1086988 Opened 5 years ago Closed 5 years ago

[2.1][l10n][Usage] Multiple locales: If byte count reaches 3 digits it overlaps the source text next to it

Categories

(Firefox OS Graveyard :: Gaia::Cost Control, defect)

ARM
Gonk (Firefox OS)
defect
Not set

Tracking

(blocking-b2g:2.1+, b2g-v2.0 unaffected, b2g-v2.1 verified, b2g-v2.2 verified)

VERIFIED FIXED
2.1 S8 (7Nov)
blocking-b2g 2.1+
Tracking Status
b2g-v2.0 --- unaffected
b2g-v2.1 --- verified
b2g-v2.2 --- verified

People

(Reporter: rmead, Assigned: paco)

References

Details

(Keywords: regression, Whiteboard: LocRun2.1-2)

Attachments

(3 files, 1 obsolete file)

Attached image 2014-10-21-14-34-08.png
Description:
After setting up the 'Usage' app, if the byte count in the rows below the graph reach 3 digits, the text overlaps the description text(ex:Mobile usage, Wi-Fi usage) next to it.
   
Prereq:
Have a valid SIM card inserted in the device and set language to Basque.

Repro Steps:
1) Update a Flame device to BuildID: 20141021001201
2) Tap the 'Usage' app and go through set up process
3) Tap rocket bar and go to google.
4) Try access a website then check usage app.
5) if you usage is less than 100kb, access another website.
6) Repeat step 5 until you are greater then 100kb but less than 1mb
7) Open 'Usage' app and observe usage rows
  
Actual:
The Byte count overlaps into the source usage text field.
  
Expected: 
The Byte count does not overlap into the source usage text field.
  

Flame 2.1(319mb)(Full Flash)

Environmental Variables:
Device: Flame 2.1
BuildID: 20141021001201
Gaia: e458f5804c0851eb4e93c9eb143fe044988cecda
Gecko: ee86921a986f
Gonk: 05aa7b98d3f891b334031dc710d48d0d6b82ec1d
Version: 34.0 (2.1)
Firmware: V188
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0

  
Repro frequency: 100%
Link to failed test case: https://moztrap.mozilla.org/manage/case/14717/
See attached: screenshot
This issue does NOT occur on Flame 2.0(319mb)

When in the usage app, once the byte count reaches 3 digits before the decimal, the byte count and usage source text do not overlap.

Flame 2.0

Environmental Variables:
Device: Flame 2.0 (319mb)(Kitkat Base)(Full Flash)
Build ID: 20141021000201
Gaia: 63b56a7a7453726b9e12ad1afe02c68c83c5aeca
Gecko: 40584eecdc75
Version: 32.0 (2.0)
Firmware Version: v188
User Agent: Mozilla/5.0 (Mobile; rv:32.0) Gecko/32.0 Firefox/32.0
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(dharris)
Regression, flagging UX
Component: eu / Basque → Gaia::Cost Control
Flags: needinfo?(firefoxos-ux-bugzilla)
Keywords: regression
Product: Mozilla Localizations → Firefox OS
[Blocking Requested - why for this release]:
Basque is a critical Tako shipping locale
blocking-b2g: --- → 2.1?
Duplicate of this bug: 1087079
Actually happens on multiple shipping locales
Summary: [2.1][l10n][Usage] Basque: If byte count reaches 3 digits it overlaps the source text next to it → [2.1][l10n][Usage] Multiple locales: If byte count reaches 3 digits it overlaps the source text next to it
triage: identifiable regression
blocking-b2g: 2.1? → 2.1+
Assignee: nobody → pacorampas
Attached file patch in github
Attachment #8509396 - Flags: review?(mri)
Attached image usage-digits-truncate.png (obsolete) —
Attachment #8509398 - Attachment is obsolete: true
Attachment #8510073 - Flags: ui-review?
Attachment #8510073 - Flags: ui-review?
Attachment #8510073 - Flags: ui-review?(amlee)
Comment on attachment 8510073 [details]
usage-digits-truncate.png

This looks good to me. Thanks for the fix.
Attachment #8510073 - Flags: ui-review?(amlee) → ui-review+
Comment on attachment 8509396 [details] [review]
patch in github

LGTM. Thanks!
Attachment #8509396 - Flags: review?(marina.rodrigueziglesias) → review+
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(dharris)
Clearing flag since Amy has given this a +.
Flags: needinfo?(firefoxos-ux-bugzilla)
Comment on attachment 8510073 [details]
usage-digits-truncate.png

Flagging UX for review as well.
Attachment #8510073 - Flags: ui-review?(kcaldwell)
Comment on attachment 8509396 [details] [review]
patch in github

[Approval Request Comment]
[Bug caused by] (feature/regressing bug #): text isn't truncate
[User impact] if declined: bad visualization
[Testing completed]: yes
[Risk to taking this patch] (and alternatives if risky): none
[String changes made]: none
Attachment #8509396 - Flags: approval-gaia-v2.1?
Blocks: 1088458
Hi Paco,

this has the r+, do you need someone to push it to master?
Flags: needinfo?(pacorampas)
Ni'ing Juwei as she is now the UX designer for Usage app
Flags: needinfo?(jhuang)
Comment on attachment 8510073 [details]
usage-digits-truncate.png

ui+ based on above png. [clearing juwei's NI]
Flags: needinfo?(jhuang)
Attachment #8510073 - Flags: ui-review?(kcaldwell) → ui-review+
(In reply to Francisco Jordano [:arcturus] [:francisco] from comment #15)
> Hi Paco,
> 
> this has the r+, do you need someone to push it to master?

No, I was waiting for showing all green on gaia-try. I am going to merge :):)
Flags: needinfo?(pacorampas)
merged: a26704ed33f9251d360675a2083dcf9f2510bbd9
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
Attachment #8509396 - Flags: approval-gaia-v2.1? → approval-gaia-v2.1+
Verified the issue is fixed on 2.2 and 2.1 builds,
The string has ellipses now and no overlapping appears on the screen with 3+ digits 

Device: Flame 2.2 Master KK
BuildID: 20141030040201
Gaia: 0dfc1996eb583c8b507a82bf6b8319624bba23ea
Gecko: 80e18ff7c7b2
Gonk: 48835395daa6a49b281db62c50805bd6ca24077e
Version: 36.0a1 (2.2 Master)
Firmware: V188
User Agent: Mozilla/5.0 (Mobile; rv:36.0) Gecko/36.0 Firefox/36.0

Device: Flame 2.1 KK
BuildID: 20141030001201
Gaia: 3e585d8be5e2dffc376f83313299c9b6d53c3db4
Gecko: b643d78a23c6
Gonk: 48835395daa6a49b281db62c50805bd6ca24077e
Version: 34.0 (2.1)
Firmware: V188
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0
Status: RESOLVED → VERIFIED
QA Whiteboard: [QAnalyst-Triage+] → [QAnalyst-Triage?]
Flags: needinfo?(ktucker)
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(ktucker)
You need to log in before you can comment on or make changes to this bug.