When navigating from about:home with a displayed forward button, sometimes forward does not hide

RESOLVED DUPLICATE of bug 1086981

Status

()

Firefox for Android
General
RESOLVED DUPLICATE of bug 1086981
4 years ago
4 years ago

People

(Reporter: mcomella, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

1) Open a new tab
2) Navigate to a page, e.g. apple.com
3) Hit back (maybe wait for page load)
4) Navigate to a new page (

Expected: Forward hides itself
Actual: Forward SOMETIMES stays visible - seems racey. Note this happens less often than not.

Found when testing patches for bug 1086981. May be caused by that bug (which hasn't landed yet), but it seems unlikely. Note that that bug ensures the button will be disabled so functionality is not changed, just appearances.
Silly me, a problem in BrowserToolbarTabletBase.updateNavigationButtons.
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1086981
You need to log in before you can comment on or make changes to this bug.