Closed Bug 108715 Opened 18 years ago Closed 15 years ago

width on span not used

Categories

(Core :: CSS Parsing and Computation, defect)

x86
Windows 2000
defect
Not set

Tracking

()

VERIFIED DUPLICATE of bug 50626

People

(Reporter: bugzilla, Assigned: dbaron)

References

()

Details

on http://gemal.dk/test/news.html
I have a span that is set to width: 150px via CSS but Mozilla doesn't seem to 
respect that. IE renders the span at width 150 but Mozilla just ignores the 
width.

20011106
CSS2 section 10.3.1 says 'width' and 'height' don't apply to non-replaced inline
elements.
Status: NEW → RESOLVED
Closed: 18 years ago
Resolution: --- → INVALID
really...?
it validates as correct css at css validator..:)
any clues what I can use if I want:
<span>test</span><span>test2</span>

and want test and test2 to be 100px width
?
It's perfectly valid.  It just doesn't do anything.  The CSS validator would
have to do the complete cascade and all of selector matching to warn about this
situation.  Consider:

.foo {
  width: 150px;
}

span {
  display: inline;
}

<span class="foo">Hi!</span>
You likely want inline-block instead of inline for display.  Unfortunately,
support for inline-block is rather slim so far....
Status: RESOLVED → VERIFIED
Status: VERIFIED → REOPENED
Resolution: INVALID → ---

*** This bug has been marked as a duplicate of 50626 ***
Status: REOPENED → RESOLVED
Closed: 18 years ago15 years ago
Resolution: --- → DUPLICATE
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.