[Midori 2.0][Call] The background color sometimes is not diaplay when press number on the dial

RESOLVED WONTFIX

Status

Firefox OS
Gaia::Dialer
P2
normal
RESOLVED WONTFIX
4 years ago
4 years ago

People

(Reporter: sync-1, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

1.90 MB, application/x-zip-compressed
Details
23.87 KB, application/x-zip-compressed
Details
(Reporter)

Description

4 years ago
FFOS2.0 baseline BuildID: 20140916000205
 
 DEFECT DESCRIPTION:
  The background color sometimes is not diaplay when press number on the dial
  REPRODUCING PROCEDURES:
  1.enter to call
  2.press number ->The background color sometimes is not diaplay when press   number on the dial-->ko
  
  EXPECTED BEHAVIOUR:
  ko:The background color should always diaplay when press number 
  
  ASSOCIATE SPECIFICATION:
 
  TEST PLAN REFERENCE:
 
  TOOLS AND PLATFORMS USED:
 
  USER IMPACT:
  MEDIUM
  REPRODUCING RATE:
  1/5
  For FT PR, Please list reference mobile's behavior:
(Reporter)

Comment 1

4 years ago
Created attachment 8509254 [details]
vedio
(Reporter)

Comment 2

4 years ago
Created attachment 8509255 [details]
jrdlog

Comment 3

4 years ago
Dears,

Please see the vedio.
This looks like a minor performance issue. Do you agree Gabriele?
Flags: needinfo?(gsvelto)
(In reply to Johan Lorenzo [:jlorenzo] (QA) from comment #4)
> This looks like a minor performance issue. Do you agree Gabriele?

Yeah, there's not much we can do here. The button color is changed by setting its active property via CSS. When the user taps a button the layout engine will schedule an event to repaint that element as soon as it gets a chance. However, since we're drawing the numbers at the top of the screen which will keep it busy, when the users taps quickly by the time the layout engine can catch up the button will not be pressed anymore and thus the repaint will be discarded.

To improve this we'd need to significantly refactor the callscreen CSS and layout to ensure quicker painting but that's not an easy task and hard to justify for such a minor issue.
Flags: needinfo?(gsvelto)
Per comment 5, the tradeoff doesn't worth it.
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.