If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Websocket Tests fails under Mac OS X

VERIFIED DUPLICATE of bug 1083891

Status

Hello (Loop)
Server
VERIFIED DUPLICATE of bug 1083891
3 years ago
3 years ago

People

(Reporter: tarek, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

3 years ago
There's probably a race condition problem


  1) websockets with two clients should proxy the reason on action/terminate:
     Uncaught AssertionError: expected undefined to deeply equal 'cancel'
      at WebSocket.<anonymous> (/Users/tarek/Dev/github.com/loop-server/test/websockets_test.js:653:34)
      at WebSocket.EventEmitter.emit (events.js:98:17)
      at Receiver.self._receiver.ontext (/Users/tarek/Dev/github.com/loop-server/node_modules/ws/lib/WebSocket.js:697:10)
      at Receiver.opcodes.1.finish (/Users/tarek/Dev/github.com/loop-server/node_modules/ws/lib/Receiver.js:397:14)
      at Receiver.<anonymous> (/Users/tarek/Dev/github.com/loop-server/node_modules/ws/lib/Receiver.js:384:31)
      at Receiver.add (/Users/tarek/Dev/github.com/loop-server/node_modules/ws/lib/Receiver.js:93:24)
      at Socket.firstHandler (/Users/tarek/Dev/github.com/loop-server/node_modules/ws/lib/WebSocket.js:678:22)
      at Socket.EventEmitter.emit (events.js:95:17)
      at Socket.<anonymous> (_stream_readable.js:746:14)
      at Socket.EventEmitter.emit (events.js:92:17)
      at emitReadable_ (_stream_readable.js:408:10)
      at emitReadable (_stream_readable.js:404:5)
      at readableAddChunk (_stream_readable.js:165:9)
      at Socket.Readable.push (_stream_readable.js:127:10)
      at TCP.onread (net.js:528:21)

  2) websockets with two clients should close the connection if callee doesn't connect:
     Error: not opened
      at WebSocket.send (/Users/tarek/Dev/github.com/loop-server/node_modules/ws/lib/WebSocket.js:187:16)
      at Context.<anonymous> (/Users/tarek/Dev/github.com/loop-server/test/websockets_test.js:717:16)
      at Test.Runnable.run (/Users/tarek/Dev/github.com/loop-server/node_modules/mocha/lib/runnable.js:196:15)
      at Runner.runTest (/Users/tarek/Dev/github.com/loop-server/node_modules/mocha/lib/runner.js:373:10)
      at /Users/tarek/Dev/github.com/loop-server/node_modules/mocha/lib/runner.js:451:12
      at next (/Users/tarek/Dev/github.com/loop-server/node_modules/mocha/lib/runner.js:298:14)
      at /Users/tarek/Dev/github.com/loop-server/node_modules/mocha/lib/runner.js:308:7
      at next (/Users/tarek/Dev/github.com/loop-server/node_modules/mocha/lib/runner.js:246:23)
      at /Users/tarek/Dev/github.com/loop-server/node_modules/mocha/lib/runner.js:270:7
      at done (/Users/tarek/Dev/github.com/loop-server/node_modules/mocha/lib/runnable.js:185:5)
      at /Users/tarek/Dev/github.com/loop-server/node_modules/mocha/lib/runnable.js:199:9
      at try_callback (/Users/tarek/Dev/github.com/loop-server/node_modules/redis/index.js:592:9)
      at RedisClient.return_reply (/Users/tarek/Dev/github.com/loop-server/node_modules/redis/index.js:685:13)
      at HiredisReplyParser.<anonymous> (/Users/tarek/Dev/github.com/loop-server/node_modules/redis/index.js:321:14)
      at HiredisReplyParser.EventEmitter.emit (events.js:95:17)
      at HiredisReplyParser.execute (/Users/tarek/Dev/github.com/loop-server/node_modules/redis/lib/parser/hiredis.js:43:18)
      at RedisClient.on_data (/Users/tarek/Dev/github.com/loop-server/node_modules/redis/index.js:547:27)
      at Socket.<anonymous> (/Users/tarek/Dev/github.com/loop-server/node_modules/redis/index.js:102:14)
      at Socket.EventEmitter.emit (events.js:95:17)
      at Socket.<anonymous> (_stream_readable.js:746:14)
      at Socket.EventEmitter.emit (events.js:92:17)
      at emitReadable_ (_stream_readable.js:408:10)
      at emitReadable (_stream_readable.js:404:5)
      at readableAddChunk (_stream_readable.js:165:9)
      at Socket.Readable.push (_stream_readable.js:127:10)
      at TCP.onread (net.js:528:21)

  3) websockets with two clients should close the connection if caller doesn't connect:
     Error: not opened
      at WebSocket.send (/Users/tarek/Dev/github.com/loop-server/node_modules/ws/lib/WebSocket.js:187:16)
      at Context.<anonymous> (/Users/tarek/Dev/github.com/loop-server/test/websockets_test.js:743:16)
      at Test.Runnable.run (/Users/tarek/Dev/github.com/loop-server/node_modules/mocha/lib/runnable.js:196:15)
      at Runner.runTest (/Users/tarek/Dev/github.com/loop-server/node_modules/mocha/lib/runner.js:373:10)
      at /Users/tarek/Dev/github.com/loop-server/node_modules/mocha/lib/runner.js:451:12
      at next (/Users/tarek/Dev/github.com/loop-server/node_modules/mocha/lib/runner.js:298:14)
      at /Users/tarek/Dev/github.com/loop-server/node_modules/mocha/lib/runner.js:308:7
      at next (/Users/tarek/Dev/github.com/loop-server/node_modules/mocha/lib/runner.js:246:23)
      at /Users/tarek/Dev/github.com/loop-server/node_modules/mocha/lib/runner.js:270:7
      at done (/Users/tarek/Dev/github.com/loop-server/node_modules/mocha/lib/runnable.js:185:5)
      at /Users/tarek/Dev/github.com/loop-server/node_modules/mocha/lib/runnable.js:199:9
      at try_callback (/Users/tarek/Dev/github.com/loop-server/node_modules/redis/index.js:592:9)
      at RedisClient.return_reply (/Users/tarek/Dev/github.com/loop-server/node_modules/redis/index.js:685:13)
      at HiredisReplyParser.<anonymous> (/Users/tarek/Dev/github.com/loop-server/node_modules/redis/index.js:321:14)
      at HiredisReplyParser.EventEmitter.emit (events.js:95:17)
      at HiredisReplyParser.execute (/Users/tarek/Dev/github.com/loop-server/node_modules/redis/lib/parser/hiredis.js:43:18)
      at RedisClient.on_data (/Users/tarek/Dev/github.com/loop-server/node_modules/redis/index.js:547:27)
      at Socket.<anonymous> (/Users/tarek/Dev/github.com/loop-server/node_modules/redis/index.js:102:14)
      at Socket.EventEmitter.emit (events.js:95:17)
      at Socket.<anonymous> (_stream_readable.js:746:14)
      at Socket.EventEmitter.emit (events.js:92:17)
      at emitReadable_ (_stream_readable.js:408:10)
      at emitReadable (_stream_readable.js:404:5)
      at readableAddChunk (_stream_readable.js:165:9)
      at Socket.Readable.push (_stream_readable.js:127:10)
      at TCP.onread (net.js:528:21)

  4) websockets "before each" hook:
     Uncaught Error: not opened
      at WebSocket.send (/Users/tarek/Dev/github.com/loop-server/node_modules/ws/lib/WebSocket.js:187:16)
      at WebSocket.<anonymous> (/Users/tarek/Dev/github.com/loop-server/test/websockets_test.js:756:20)
      at WebSocket.EventEmitter.emit (events.js:117:20)
      at Receiver.self._receiver.ontext (/Users/tarek/Dev/github.com/loop-server/node_modules/ws/lib/WebSocket.js:697:10)
      at Receiver.opcodes.1.finish (/Users/tarek/Dev/github.com/loop-server/node_modules/ws/lib/Receiver.js:397:14)
      at Receiver.expectHandler (/Users/tarek/Dev/github.com/loop-server/node_modules/ws/lib/Receiver.js:384:31)
      at Receiver.add (/Users/tarek/Dev/github.com/loop-server/node_modules/ws/lib/Receiver.js:93:24)
      at Socket.firstHandler (/Users/tarek/Dev/github.com/loop-server/node_modules/ws/lib/WebSocket.js:678:22)
      at Socket.EventEmitter.emit (events.js:95:17)
      at Socket.<anonymous> (_stream_readable.js:746:14)
      at Socket.EventEmitter.emit (events.js:92:17)
      at emitReadable_ (_stream_readable.js:408:10)
      at emitReadable (_stream_readable.js:404:5)
      at readableAddChunk (_stream_readable.js:165:9)
      at Socket.Readable.push (_stream_readable.js:127:10)
      at TCP.onread (net.js:528:21)
This is a dupe of bug 1083891
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1083891
Yep. Duplicate.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.