Closed Bug 1087257 Opened 8 years ago Closed 8 years ago

Corruption when scrolling a page, with OMTC (or e10s) & without HWA

Categories

(Core :: Graphics: Layers, defect)

36 Branch
defect
Not set
major

Tracking

()

VERIFIED FIXED
mozilla36
Tracking Status
firefox35 --- unaffected
firefox36 + verified

People

(Reporter: ananuti, Unassigned)

References

Details

(Keywords: dogfood, regression)

Attachments

(2 files)

Attached image screenshot
+++ This bug was initially created as a clone of Bug #1085223 +++

The first bad revision is: mozilla-central changeset fa9c6845338e

Steps:
 - Disable HWA
 - Scrolling a page.

Graphics:
Adapter Description          Mobile Intel(R) 4 Series Express Chipset Family
Adapter Drivers              igdumdx32 igd10umd32
Adapter RAM                  Unknown
ClearType Parameters         Gamma: 2200 Pixel Structure: B ClearType Level: 0 Enhanced Contrast: 50
Device ID                    0x2a42
DirectWrite Enabled          false (6.2.9200.16571)
Driver Date                  10-4-2012
Driver Version               8.15.10.2869
GPU #2 Active                false
GPU Accelerated              Windows 0/1 Basic (OMTC)
Subsys ID                    20e417aa
Vendor ID                    0x8086
WebGL Renderer               Google Inc. -- ANGLE (Mobile Intel(R) 4 Series Express Chipset Family Direct3D9Ex vs_3_0 ps_3_0)
windowLayerManagerRemote     true
AzureCanvasBackend           skia
AzureContentBackend          cairo
AzureFallbackCanvasBackend   cairo
AzureSkiaAccelerated         0


The bug goes away if switch off OMTC.
Keywords: regression
OS: Windows 7 → All
Hardware: x86 → All
This bug makes it difficult to effectively use Firefox while in a Remote Desktop (RDP) session, because hardware acceleration is disabled there by default.
Severity: normal → major
Matt/Benoit, can this be fixed today? If not, we should back out bug 1085223 since Nightly is effectively busted for people that can't use HWA.
Flags: needinfo?(matt.woodrow)
Flags: needinfo?(bgirard)
Keywords: dogfood
This bug makes Bugzilla completely unusable, if you have "layers.offmainthreadcomposition.enabled" turned on, or if you're using e10s.
Summary: Corruptions when scrolling a page if HWA disabled → Corruptions when scrolling a page, with OMTC (or e10s) & without HWA
Summary: Corruptions when scrolling a page, with OMTC (or e10s) & without HWA → Corruption when scrolling a page, with OMTC (or e10s) & without HWA
Chatted w/ mattwoodrow; he's OK with backing out to fix this, since this breaks the web for people w/ e10s enabled [depending on their hardware], and we've been aggressively pushing Nightly users to enable e10s.

I'll land the backout patch once the tree reopens.
Flags: needinfo?(matt.woodrow)
Flags: needinfo?(dholbert)
Flags: needinfo?(bgirard)
Backed out bug 1085223 (as noted in bug 1085223 comment 9), which should fix this.

Leaving open until that backout-cset is merged to central.
Flags: needinfo?(dholbert)
https://hg.mozilla.org/mozilla-central/rev/0d2784aa8739
Status: NEW → RESOLVED
Closed: 8 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla36
verified fixed in 36.0a1 20141023030203.
Status: RESOLVED → VERIFIED
QA Contact: ananuti
You need to log in before you can comment on or make changes to this bug.