vp8 compile error - building b2g for flatfish on ubuntu 14.10

RESOLVED DUPLICATE of bug 1087096

Status

RESOLVED DUPLICATE of bug 1087096
4 years ago
4 years ago

People

(Reporter: gabriele.vidali, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

4 years ago
User Agent: Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:35.0) Gecko/20100101 Firefox/35.0
Build ID: 20141004131458

Steps to reproduce:

Building b2g for flatfish on ubuntu 14.10


Actual results:

In file included from ./glslang_lex.cpp:999:0:
../../../gecko/gfx/angle/src/compiler/translator/ParseContext.h: In constructor 'TParseContext::TParseContext(TSymbolTable&, TExtensionBehavior&, TIntermediate&, sh::GLenum, ShShaderSpec, int, bool, char const*, TInfoSink&)':
../../../gecko/gfx/angle/src/compiler/translator/ParseContext.h:65:18: warning: 'TParseContext::diagnostics' will be initialized after [-Wreorder]
../../../gecko/gfx/angle/src/compiler/translator/ParseContext.h:52:9: warning:   'int TParseContext::shaderVersion' [-Wreorder]
../../../gecko/gfx/angle/src/compiler/translator/ParseContext.h:28:5: warning:   when initialized here [-Wreorder]
glslang_tab.o
In file included from ../../../gecko/gfx/angle/src/compiler/translator/glslang_tab.cpp:89:0:
../../../gecko/gfx/angle/src/compiler/translator/ParseContext.h: In constructor 'TParseContext::TParseContext(TSymbolTable&, TExtensionBehavior&, TIntermediate&, sh::GLenum, ShShaderSpec, int, bool, char const*, TInfoSink&)':
../../../gecko/gfx/angle/src/compiler/translator/ParseContext.h:65:18: warning: 'TParseContext::diagnostics' will be initialized after [-Wreorder]
../../../gecko/gfx/angle/src/compiler/translator/ParseContext.h:52:9: warning:   'int TParseContext::shaderVersion' [-Wreorder]
../../../gecko/gfx/angle/src/compiler/translator/ParseContext.h:28:5: warning:   when initialized here [-Wreorder]
Unified_cpp_gfx_angle0.o
Unified_cpp_gfx_angle1.o
In file included from ../../../gecko/gfx/angle/src/compiler/translator/Compiler.cpp:13:0,
                 from Unified_cpp_gfx_angle1.cpp:47:
../../../gecko/gfx/angle/src/compiler/translator/InitializeVariables.h: In constructor 'InitializeVariables::InitializeVariables(const InitVariableInfoList&)':
../../../gecko/gfx/angle/src/compiler/translator/InitializeVariables.h:47:10: warning: 'InitializeVariables::mCodeInserted' will be initialized after [-Wreorder]
../../../gecko/gfx/angle/src/compiler/translator/InitializeVariables.h:46:26: warning:   'InitializeVariables::InitVariableInfoList InitializeVariables::mVariables' [-Wreorder]
../../../gecko/gfx/angle/src/compiler/translator/InitializeVariables.h:28:5: warning:   when initialized here [-Wreorder]
In file included from ../../../gecko/gfx/angle/src/compiler/translator/Compiler.cpp:14:0,
                 from Unified_cpp_gfx_angle1.cpp:47:
../../../gecko/gfx/angle/src/compiler/translator/ParseContext.h: In constructor 'TParseContext::TParseContext(TSymbolTable&, TExtensionBehavior&, TIntermediate&, sh::GLenum, ShShaderSpec, int, bool, char const*, TInfoSink&)':
../../../gecko/gfx/angle/src/compiler/translator/ParseContext.h:65:18: warning: 'TParseContext::diagnostics' will be initialized after [-Wreorder]
../../../gecko/gfx/angle/src/compiler/translator/ParseContext.h:52:9: warning:   'int TParseContext::shaderVersion' [-Wreorder]
../../../gecko/gfx/angle/src/compiler/translator/ParseContext.h:28:5: warning:   when initialized here [-Wreorder]
Unified_cpp_gfx_angle2.o
In file included from ../../../gecko/gfx/angle/src/compiler/translator/InitializeVariables.cpp:7:0,
                 from Unified_cpp_gfx_angle2.cpp:2:
../../../gecko/gfx/angle/src/compiler/translator/InitializeVariables.h: In constructor 'InitializeVariables::InitializeVariables(const InitVariableInfoList&)':
../../../gecko/gfx/angle/src/compiler/translator/InitializeVariables.h:47:10: warning: 'InitializeVariables::mCodeInserted' will be initialized after [-Wreorder]
../../../gecko/gfx/angle/src/compiler/translator/InitializeVariables.h:46:26: warning:   'InitializeVariables::InitVariableInfoList InitializeVariables::mVariables' [-Wreorder]
../../../gecko/gfx/angle/src/compiler/translator/InitializeVariables.h:28:5: warning:   when initialized here [-Wreorder]
In file included from ../../../gecko/gfx/angle/src/compiler/translator/OutputGLSLBase.h:14:0,
                 from ../../../gecko/gfx/angle/src/compiler/translator/OutputESSL.h:10,
                 from ../../../gecko/gfx/angle/src/compiler/translator/OutputESSL.cpp:7,
                 from Unified_cpp_gfx_angle2.cpp:47:
../../../gecko/gfx/angle/src/compiler/translator/ParseContext.h: In constructor 'TParseContext::TParseContext(TSymbolTable&, TExtensionBehavior&, TIntermediate&, sh::GLenum, ShShaderSpec, int, bool, char const*, TInfoSink&)':
../../../gecko/gfx/angle/src/compiler/translator/ParseContext.h:65:18: warning: 'TParseContext::diagnostics' will be initialized after [-Wreorder]
../../../gecko/gfx/angle/src/compiler/translator/ParseContext.h:52:9: warning:   'int TParseContext::shaderVersion' [-Wreorder]
../../../gecko/gfx/angle/src/compiler/translator/ParseContext.h:28:5: warning:   when initialized here [-Wreorder]
Unified_cpp_gfx_angle3.o
In file included from ../../../gecko/gfx/angle/src/compiler/translator/SearchSymbol.h:13:0,
                 from ../../../gecko/gfx/angle/src/compiler/translator/SearchSymbol.cpp:9,
                 from Unified_cpp_gfx_angle3.cpp:2:
../../../gecko/gfx/angle/src/compiler/translator/ParseContext.h: In constructor 'TParseContext::TParseContext(TSymbolTable&, TExtensionBehavior&, TIntermediate&, sh::GLenum, ShShaderSpec, int, bool, char const*, TInfoSink&)':
../../../gecko/gfx/angle/src/compiler/translator/ParseContext.h:65:18: warning: 'TParseContext::diagnostics' will be initialized after [-Wreorder]
../../../gecko/gfx/angle/src/compiler/translator/ParseContext.h:52:9: warning:   'int TParseContext::shaderVersion' [-Wreorder]
../../../gecko/gfx/angle/src/compiler/translator/ParseContext.h:28:5: warning:   when initialized here [-Wreorder]
Unified_cpp_gfx_angle4.o
In file included from ../../../gecko/gfx/angle/src/compiler/translator/compilerdebug.cpp:15:0,
                 from Unified_cpp_gfx_angle4.cpp:20:
../../../gecko/gfx/angle/src/compiler/translator/ParseContext.h: In constructor 'TParseContext::TParseContext(TSymbolTable&, TExtensionBehavior&, TIntermediate&, sh::GLenum, ShShaderSpec, int, bool, char const*, TInfoSink&)':
../../../gecko/gfx/angle/src/compiler/translator/ParseContext.h:65:18: warning: 'TParseContext::diagnostics' will be initialized after [-Wreorder]
../../../gecko/gfx/angle/src/compiler/translator/ParseContext.h:52:9: warning:   'int TParseContext::shaderVersion' [-Wreorder]
../../../gecko/gfx/angle/src/compiler/translator/ParseContext.h:28:5: warning:   when initialized here [-Wreorder]
libgfx_angle.a.desc
Unified_c_media_libogg0.o
libmedia_libogg.a.desc
rtcd.o
sad_c.o
bitstream.o
onyx_if.o
vp8_dx_iface.o
vp9_alloccommon.o
vp9_blockd.o
vp9_common_data.o
vp9_convolve.o
vp9_debugmodes.o
vp9_entropy.o
vp9_entropymode.o
vp9_entropymv.o
vp9_filter.o
vp9_frame_buffers.o
vp9_idct.o
vp9_loopfilter.o
vp9_loopfilter_filters.o
vp9_mvref_common.o
vp9_pred_common.o
vp9_prob.o
vp9_quant_common.o
vp9_reconinter.o
vp9_reconintra.o
vp9_rtcd.o
vp9_scale.o
vp9_scan.o
vp9_seg_common.o
vp9_thread.o
vp9_tile_common.o
vp9_decodeframe.o
vp9_decodemv.o
vp9_decoder.o
vp9_detokenize.o
vp9_dsubexp.o
vp9_dthread.o
vp9_reader.o
vp9_aq_complexity.o
vp9_aq_cyclicrefresh.o
vp9_aq_variance.o
vp9_bitstream.o
vp9_context_tree.o
vp9_cost.o
vp9_dct.o
vp9_encodeframe.o
vp9_encodemb.o
vp9_encodemv.o
vp9_encoder.o
vp9_extend.o
vp9_firstpass.o
vp9_lookahead.o
vp9_mbgraph.o
vp9_mcomp.o
vp9_picklpf.o
vp9_pickmode.o
vp9_quantize.o
vp9_ratectrl.o
vp9_rd.o
vp9_rdopt.o
vp9_resize.o
vp9_sad.o
vp9_segmentation.o
vp9_speed_features.o
vp9_subexp.o
vp9_svc_layercontext.o
vp9_temporal_filter.o
vp9_tokenize.o
vp9_treewriter.o
vp9_variance.o
vp9_write_bit_buffer.o
vp9_writer.o
vp9_cx_iface.o
vp9_dx_iface.o
svc_encodeframe.o
vpx_encoder.o
vpx_mem.o
yv12config.o
yv12extend.o
vpx_scale_rtcd.o
error_concealment.o
idct_blk_v6.o
bilinearfilter_arm.o
dequantize_arm.o
filter_arm.o
loopfilter_arm.o
bilinearpredict_neon.o
copymem_neon.o
dc_only_idct_add_neon.o
dequant_idct_neon.o
dequantizeb_neon.o
idct_blk_neon.o
idct_dequant_0_2x_neon.o
idct_dequant_full_2x_neon.o
iwalsh_neon.o
loopfilter_neon.o
loopfiltersimplehorizontaledge_neon.o
loopfiltersimpleverticaledge_neon.o
mbloopfilter_neon.o
reconintra_neon.o
sad_neon.o
shortidct4x4llm_neon.o
sixtappredict_neon.o
variance_neon.o
vp8_subpixelvariance_neon.o
variance_arm.o
boolhuff_arm.o
dct_arm.o
denoising_neon.o
shortfdct_neon.o
subtract_neon.o
vp8_shortwalsh4x4_neon.o
../../../gecko/media/libvpx/vp8/encoder/arm/neon/vp8_shortwalsh4x4_neon.c: In function 'vp8_short_walsh4x4_neon':
../../../gecko/media/libvpx/vp8/encoder/arm/neon/vp8_shortwalsh4x4_neon.c:118:1: internal compiler error: in trunc_int_for_mode, at explow.c:56
Please submit a full bug report,
with preprocessed source if appropriate.
See <http://gcc.gnu.org/bugs.html> for instructions.

In the directory  /mnt/fxos/flatfish/b2g_flatfish/objdir-gecko/media/libvpx
The following command failed to execute properly:
/usr/bin/ccache /mnt/fxos/flatfish/b2g_flatfish/prebuilts/gcc/linux-x86/arm/arm-linux-androideabi-4.6/bin/arm-linux-androideabi-gcc -o vp8_shortwalsh4x4_neon.o -c -I../../dist/system_wrappers -include /mnt/fxos/flatfish/b2g_flatfish/gecko/config/gcc_hidden_dso_handle.h -DHAVE_CONFIG_H=vpx_config.h -D__linux__ -DAB_CD=en-US -DNO_NSPR_10_SUPPORT -I/mnt/fxos/flatfish/b2g_flatfish/gecko/media/libvpx -I. -I/mnt/fxos/flatfish/b2g_flatfish/ndk/sources/android/cpufeatures -I../../dist/include -I/mnt/fxos/flatfish/b2g_flatfish/objdir-gecko/dist/include/nspr -I/mnt/fxos/flatfish/b2g_flatfish/objdir-gecko/dist/include/nss -fPIC -DANDROID -isystem /mnt/fxos/flatfish/b2g_flatfish/bionic/libc/arch-arm/include -isystem /mnt/fxos/flatfish/b2g_flatfish/bionic/libc/include/ -isystem /mnt/fxos/flatfish/b2g_flatfish/bionic/libc/kernel/common -isystem /mnt/fxos/flatfish/b2g_flatfish/bionic/libc/kernel/arch-arm -isystem /mnt/fxos/flatfish/b2g_flatfish/bionic/libm/include -I/mnt/fxos/flatfish/b2g_flatfish/system -I/mnt/fxos/flatfish/b2g_flatfish/system/core/include -isystem /mnt/fxos/flatfish/b2g_flatfish/bionic -I/mnt/fxos/flatfish/b2g_flatfish/hardware/libhardware/include -I/mnt/fxos/flatfish/b2g_flatfish/external/valgrind/fxos-include -I/mnt/fxos/flatfish/b2g_flatfish/frameworks/native/include -I/mnt/fxos/flatfish/b2g_flatfish/frameworks/av/include -I/mnt/fxos/flatfish/b2g_flatfish/frameworks/av/include/media -I/mnt/fxos/flatfish/b2g_flatfish/frameworks/av/include/camera -I/mnt/fxos/flatfish/b2g_flatfish/frameworks/native/include/media/openmax -I/mnt/fxos/flatfish/b2g_flatfish/frameworks/av/media/libstagefright/include -include ../../mozilla-config.h -DMOZILLA_CLIENT -MD -MP -MF .deps/vp8_shortwalsh4x4_neon.o.pp -DANDROID -isystem /mnt/fxos/flatfish/b2g_flatfish/bionic/libc/arch-arm/include -isystem /mnt/fxos/flatfish/b2g_flatfish/bionic/libc/include/ -isystem /mnt/fxos/flatfish/b2g_flatfish/bionic/libc/kernel/common -isystem /mnt/fxos/flatfish/b2g_flatfish/bionic/libc/kernel/arch-arm -isystem /mnt/fxos/flatfish/b2g_flatfish/bionic/libm/include -I/mnt/fxos/flatfish/b2g_flatfish/system -I/mnt/fxos/flatfish/b2g_flatfish/system/core/include -isystem /mnt/fxos/flatfish/b2g_flatfish/bionic -I/mnt/fxos/flatfish/b2g_flatfish/hardware/libhardware/include -I/mnt/fxos/flatfish/b2g_flatfish/external/valgrind/fxos-include -I/mnt/fxos/flatfish/b2g_flatfish/frameworks/native/include -I/mnt/fxos/flatfish/b2g_flatfish/frameworks/av/include -I/mnt/fxos/flatfish/b2g_flatfish/frameworks/av/include/media -I/mnt/fxos/flatfish/b2g_flatfish/frameworks/av/include/camera -I/mnt/fxos/flatfish/b2g_flatfish/frameworks/native/include/media/openmax -I/mnt/fxos/flatfish/b2g_flatfish/frameworks/av/media/libstagefright/include -Wall -Wdeclaration-after-statement -Wempty-body -Wpointer-to-int-cast -Wsign-compare -Wtype-limits -Werror=char-subscripts -Werror=comment -Werror=endif-labels -Werror=enum-compare -Werror=ignored-qualifiers -Werror=int-to-pointer-cast -Werror=multichar -Werror=nonnull -Werror=pointer-arith -Werror=pointer-sign -Werror=return-type -Werror=sequence-point -Werror=trigraphs -Werror=unknown-pragmas -Wno-unused -mandroid -fno-short-enums -fno-exceptions -march=armv7-a -mthumb -mfpu=neon -mfloat-abi=softfp -std=gnu99 -fgnu89-inline -fno-strict-aliasing -ffunction-sections -fdata-sections -fno-math-errno -pipe -DNDEBUG -DTRIMMED -g -freorder-blocks -Os -fno-reorder-functions -funwind-tables -mfpu=neon -Wno-sign-compare /mnt/fxos/flatfish/b2g_flatfish/gecko/media/libvpx/vp8/encoder/arm/neon/vp8_shortwalsh4x4_neon.c
make[6]: *** [vp8_shortwalsh4x4_neon.o] Error 1
make[5]: *** [media/libvpx/target] Error 2
make[4]: *** [compile] Error 2
make[3]: *** [default] Error 2
make[2]: *** [realbuild] Error 2
make[1]: *** [build] Error 2
make: *** [out/target/product/flatfish/obj/DATA/gecko_intermediates/gecko] Error 2

real    183m20.292s
user    147m29.270s
sys     9m53.780s

> Build failed! <
(Reporter)

Updated

4 years ago
blocking-b2g: --- → 2.2?
OS: All → Gonk (Firefox OS)
Hardware: All → ARM

Updated

4 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1087096
blocking-b2g: 2.2? → ---
You need to log in before you can comment on or make changes to this bug.