Internet sharing (tethering) doesnt use the correct APN.

RESOLVED WONTFIX

Status

RESOLVED WONTFIX
4 years ago
6 months ago

People

(Reporter: juanjose.iglesias, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(3 attachments)

(Reporter)

Description

4 years ago
When the tethering opction is actived in the device, the apn setting should change from default apn to the registered apn profile
in tethering settings. 

In the case of Movistar ES SIM, the APN must changed from telefonica.es (default data apn profile) to movistar.es 
(default tethering apn profile). But when internet sharing is activated, the APN doesnt change and continue using telefonica.es

Add two log: 
- WIFIInternetSharing_root: log from device which actives the internet sharing. 
- WIFIInternetSharing_device: log form device which uses the tethering connection.

I have used a flame master (Gecko 719072f Gaia 3c90141).
(Reporter)

Comment 1

4 years ago
Created attachment 8509602 [details]
WIFIInternetSharing_device.txt
(Reporter)

Comment 2

4 years ago
Created attachment 8509603 [details]
WIFIInternetSharing_Root.txt

Updated

4 years ago
Assignee: nobody → alberto.crespellperez

Comment 3

4 years ago
As detailed in https://bugzilla.mozilla.org/show_bug.cgi?id=960865#c22 there are two requisites in order to enable dun tethering:

- Build with iproute2.

- Gecko checks if dun is enabled by reading the android property 'ro.tethering.dun_required', the property must be defined with value '1'.

Our flame Telefonica builds are using iproute2 but that property is not defined.

Comment 4

4 years ago
Is there a way to easily enable the property for all builds of Firefox OS?
Flags: needinfo?(htsai)

Updated

4 years ago
Assignee: alberto.crespellperez → nobody
(In reply to Albert [:albert] from comment #4)
> Is there a way to easily enable the property for all builds of Firefox OS?

The way should be to have this property defined in makefile, and rebuild it :(
Flags: needinfo?(htsai)

Comment 6

4 years ago
Hi QuYi:

FYI, learned this issue and confirmed w/ Hsin-Yi about comment#5 that need your effort to fix.
Flags: needinfo?(yi.qu)

Comment 7

4 years ago
Dear wehuang@mozilla.com,
   the ro.tethering.dun_required only can be used on mozilla ril.
   But our device is using qcom ril.  
   And your patch is only effect after define MOZ_B2G_RIL.

Comment 8

4 years ago
Hi Wesly,

Per comment#7, it needs Mozilla and Qualcom work together to support this feature.

Please help to push this case.

Thanks.
Flags: needinfo?(wehuang)
I guess we need vendor RIL support. Could you please help here? We need vendor RIL to take into account that DUN profile is available for DUN connections.
Flags: needinfo?(mvines)
Flags: needinfo?(anshulj)
(discussing offline)
Flags: needinfo?(mvines)
Flags: needinfo?(anshulj)
(discussing offline)
(In reply to buri.blff from comment #7)
> Dear wehuang@mozilla.com,
>    the ro.tethering.dun_required only can be used on mozilla ril.
>    But our device is using qcom ril.  
>    And your patch is only effect after define MOZ_B2G_RIL.

Can you please try enabling ro.tethering.dun_required as requested and re-test.  If it doesn't work still then please raise an SR for support.

Comment 13

4 years ago
(In reply to Michael Vines [:m1] [:evilmachines] from comment #12)
> Can you please try enabling ro.tethering.dun_required as requested and
> re-test.  If it doesn't work still then please raise an SR for support.

Dears  Michael,

  Only enabling ro.tethering.dun_required can't make it works. And we think it must modified something in NetworkManager.js.

Comment 14

4 years ago
Dear  Beatriz,

  In mozilla's code, it only support for it's RIL. We think mozilla must support other's RIL(qcom) in  the file NetworkManager.js.

Updated

4 years ago
Flags: needinfo?(beatriz.rodriguezgomez)

Comment 15

4 years ago
Dear  Hsin-Yi, 

  Could you help check the file NetworkManager.js and make it use qcom  RIL. Thanks.
Flags: needinfo?(htsai)
Hsin-Yi, could you please help and check comment 15?
Flags: needinfo?(beatriz.rodriguezgomez)

Comment 17

4 years ago
Tested ro.tethering.dun_required with commercial ril and it works on v2.0, no changes required.

With that property enabled, ril will setup a data call with the APN defined in settings > "Cellular & Data" > "Tethering settings" > APN. Please ensure that this setting is properly set.


I did find that there is a bug in 2.2 that breaks this feature (bug 1106656), but this shouldn't affect v2.0 unless some patches were back-ported.

Comment 18

4 years ago
(In reply to pgravel from comment #17)
> Tested ro.tethering.dun_required with commercial ril and it works on v2.0,
> no changes required.

Dear pgravel,
  
It only use ro.tethering.dun_required if definied MOZ_B2G_RIL. You may check the code
https://github.com/mozilla/gecko-dev/blob/b2g32_v2_0/dom/system/gonk/NetworkManager.js#L688

Now we could remove the MOZ_B2G_RIL limit about DUN, but we can't  known Whether it brings new issues.
Hi Ray, is MOZ_B2G_RIL not defined in your build?  It should be.

Comment 20

4 years ago
(In reply to Michael Vines [:m1] [:evilmachines] from comment #19)
> Hi Ray, is MOZ_B2G_RIL not defined in your build?  It should be.

Hi Michael, Our base code from qcom doesn't defined the MOZ_B2G_RIL. If need, please tell us how to do. Thanks.
If MOZ_B2G_RIL (eg, --enable-b2g-ril) was not defined then the device could not make any phone calls/SMS/etc.  MOZ_B2G_RIL will be defined within gecko/configure.in during the start of normal Gecko build, there's nothing needed to explicitly define it in gonk-misc/default-gecko-config or elsewhere.

Comment 22

4 years ago
(In reply to Michael Vines [:m1] [:evilmachines] from comment #21)
> If MOZ_B2G_RIL (eg, --enable-b2g-ril) was not defined then the device could
> not make any phone calls/SMS/etc.  MOZ_B2G_RIL will be defined within
> gecko/configure.in during the start of normal Gecko build, there's nothing
> needed to explicitly define it in gonk-misc/default-gecko-config or
> elsewhere.

I'm sure the MOZ_B2G_RIL not defined in our code and the calls/SMS/etc works well.
Sorry, I am afraid I cannot help much for comment 15 as I know little about commRIL. Looks Phil is helping on the commril side. Canceling NI flag on me for now. Feel free to pin me again for further mozril or network manager questions, thanks.
Flags: needinfo?(htsai)
(In reply to Ray REN from comment #22)
> I'm sure the MOZ_B2G_RIL not defined in our code and the calls/SMS/etc works
> well.

Can you please confirm that MOZ_B2G_RIL is not getting defined by gecko/configure.in when building Gecko in your source tree?  As you can see from http://dxr.mozilla.org/mozilla-central/search?q=MOZ_B2G_RIL, if MOZ_B2G_RIL is not defined then most of the Gecko telephony code is disabled and that would be a serious problem for your device.  Note that MOZ_B2G_RIL has nothing to do with the RIL implementation being used, MOZ_B2G_RIL declares to the Gecko source code that a RIL exists.

Comment 25

4 years ago
(In reply to Albert [:albert] from comment #3)
> As detailed in https://bugzilla.mozilla.org/show_bug.cgi?id=960865#c22 there
> are two requisites in order to enable dun tethering:
> 
> - Build with iproute2.
> 
> - Gecko checks if dun is enabled by reading the android property
> 'ro.tethering.dun_required', the property must be defined with value '1'.
> 
> Our flame Telefonica builds are using iproute2 but that property is not
> defined.

how can we build project with iproute2??

Comment 26

4 years ago
(In reply to Michael Vines [:m1] [:evilmachines] from comment #12)
> (In reply to buri.blff from comment #7)
> > Dear wehuang@mozilla.com,
> >    the ro.tethering.dun_required only can be used on mozilla ril.
> >    But our device is using qcom ril.  
> >    And your patch is only effect after define MOZ_B2G_RIL.
> 
> Can you please try enabling ro.tethering.dun_required as requested and
> re-test.  If it doesn't work still then please raise an SR for support.

Dear mvines:
   After set  ro.tethering.dun_required  to true and define MOZ_B2G_RIL, we find the wifi tethering  can't be open.
   we have add the log:"can't open wifi tethering.txt"
  
   we find the log give follow error, then it disabled the wifi tethering.
 
  V/NatController(  206): runCmd(/system/bin/ip route flush cache) res=0
E/NatController(  206): Error setting route rules

Comment 27

4 years ago
Created attachment 8536274 [details]
can't open wifi tethering.txt

the log for open wifi tethering fail

Updated

4 years ago
Flags: needinfo?(mvines)
(Clearing ni. As mentioned in comment 12, for non-Mozilla support on this issue please raise an SR or discuss with your TAM.  Thanks!)
Flags: needinfo?(mvines)

Comment 29

4 years ago
(In reply to Michael Vines [:m1] [:evilmachines] from comment #28)
> (Clearing ni. As mentioned in comment 12, for non-Mozilla support on this
> issue please raise an SR or discuss with your TAM.  Thanks!)

i have raise an SR:01841078

Comment 30

4 years ago
clear ni since this issue is followed by partner and QC offline w/ SR.
Flags: needinfo?(yi.qu)
Flags: needinfo?(wehuang)

Comment 31

6 months ago
Firefox OS is not being worked on
Status: NEW → RESOLVED
Last Resolved: 6 months ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.