newtab page isn't a real history page, and can't be 'back'ed to.

RESOLVED DUPLICATE of bug 776167

Status

()

RESOLVED DUPLICATE of bug 776167
4 years ago
4 years ago

People

(Reporter: glind, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

To reproduce:

1.  Open a new tab.
2.  Click a tile.
3.  attempt to 'back'
4.  Fail and be sad.

Why this is a problem:

1.  As newtab assumes a more central role as the central launching point for content, I want to get back to it.  
2.  Causes fear of following suggested links / inhibits impulsiveness from newtab.


Fixes:
1.  (suggesting!) Make it a real page (in history)
2.  Make new tab opening instant / fast / cheap.  

Tried so far:
- finding where this happens, by searching mxr for about:, about:newtab.  Unable to find where this is.

Observed:
- if a 'normal' url is set as `browser.newtab.url`, that page is 'back'able.
- only the 'first page' is not counted.  page -> about:newtab -> page works as expected.
- private windows, the newtab page is (different) and works as expected.
- "browser.newtab.preload" doesn't seem to affect this.


Might also affect: 
- thumbnail policy:  http://mxr.mozilla.org/mozilla-central/source/browser/base/content/browser-thumbnails.js#136
Yes, that's a huge annoyance.

There is bug 776477 which tracks work to make about:newtab unprivileged. That seems to be the major problem here.
Depends on: 776477
(I see now that this was Intentional, back in https://bugzilla.mozilla.org/show_bug.cgi?id=724239.  

Concurring with https://bugzilla.mozilla.org/show_bug.cgi?id=724239#c31 that if it's supposed to remove all 'first tab' pages, then the fix is incomplete.  )

(Still think this should be re-evaluated, given increased role of about:newtab in UX).
(In reply to Gregg Lind (User Advocacy - Test Pilot) from comment #2)
> ...
> (Still think this should be re-evaluated, given increased role of
> about:newtab in UX).

+1. I also think that navigating back to about:newtab is useful.
Duping this to bug 776167. We're not only considering it but also planning it. But we unfortunately have higher priority stuff to work on at the moment. It will become even more important with the ongoing e10s work in the near future though. Stay tuned.
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 776167
You need to log in before you can comment on or make changes to this bug.