Restart to Update button doesn't work; can't update FF

RESOLVED WORKSFORME

Status

()

Toolkit
Application Update
RESOLVED WORKSFORME
4 years ago
3 years ago

People

(Reporter: WBT, Unassigned)

Tracking

30 Branch
x86_64
Windows 7
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

4 years ago
Steps I'm observing:
1. Open Firefox (FF).
2. In the Help menu, click About Firefox.
3. See a window that tells me I'm using FF 30.0 with a "Check for updates" button.
4. Click the "Check for updates" button. 
5. For a moment, the button is replaced by "Checking for updates" text with a spinning load-wheel.
6. The text is quickly replaced by a button that says "Update to 33.0." 
7. I click that button. 
8. The button is replaced with another that says "Restart to Update."
9. I click that button.
10. Nothing happens.
11. I repeat steps 9 & 10 several times.
12. I manually close Firefox.
13. I use Windows Task Manager to verify that no Firefox process is running.
14. I restart Firefox.
15. I repeat the entire process above.  
16. Firefox remains at version 30.0.

The expected behavior is that in steps 10 or 15:
Firefox restarts; when it is restarted it is version 33, all my add-ons work because I was not warned of any incompatibilities prior to making the update decision, and all the tabs I had open are restored.
(Reporter)

Comment 1

4 years ago
See related Bug 1023939.
(Reporter)

Comment 2

4 years ago
Per that bug's recommendation to check the browser console, I see the following:

1414001776381	addons.update-checker	WARN	Update manifest for {BBDA0591-3099-440a-AA10-41764D9DB4DB} did not contain an updates property
This was a Firefox -> General bug in the about window code which has since been fixed. Resolving -> WFM.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → WORKSFORME
(Reporter)

Comment 4

3 years ago
Thanks!
You need to log in before you can comment on or make changes to this bug.