Firefox crashes in Android Safe Mode (java.lang.IllegalStateException: Could not fetch Health Report content provider)

RESOLVED DUPLICATE of bug 728587

Status

()

Firefox for Android
General
RESOLVED DUPLICATE of bug 728587
4 years ago
2 years ago

People

(Reporter: Alwyn Edison Mendonca, Unassigned)

Tracking

33 Branch
Other
Android
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

4 years ago
User Agent: Mozilla/5.0 (Android; Mobile; rv:33.0) Gecko/33.0 Firefox/33.0
Build ID: 20141011014717

Steps to reproduce:

I have been to android safe mode profile, where I tried to open Firefox 33 and its crashing instantly. Not even loading homepage also.


Actual results:

In android safe mode Firefox crashes.


Expected results:

Browser must work in android safe mode like chrome does.
Can you capture and attach a log-cat from your device when you attempt to launch Firefox in Android safe-mode?
Flags: needinfo?(alwyne.edison)
(Reporter)

Comment 2

4 years ago
How to do that? Actually while opening browser it crashes soon and says Firefox stopped working. Only 'OK' is the option left for me to choose. In my nexus 4 power button long press 10 seconds bug is remaining since android version 4.3. Somewhere I read moving to android safe mode and whether that bug persists. I forgot the steps what that website told so I opened Firefox and I found this problem.
Flags: needinfo?(alwyne.edison)
Ok, I see on my Nexus 7 that applications aren't available. Only system applications are available in Android safe-mode. This is likely to ensure that the user can boot their phone into an environment that is free of third-party software.

To use Firefox you need to get your device out of safe-mode.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → INVALID
(Reporter)

Comment 4

4 years ago
Yes. In my phone in safe mode how it shows third party apps?
Well, I guess we shouldn't crash.

We crash in 

E/GeckoCrashHandler( 1906): >>> REPORTING UNCAUGHT EXCEPTION FROM THREAD 130 ("GeckoBackgroundThread")
E/GeckoCrashHandler( 1906): java.lang.IllegalStateException: Could not fetch Health Report content provider.
E/GeckoCrashHandler( 1906): 	at org.mozilla.gecko.health.BrowserHealthRecorder.<init>(BrowserHealthRecorder.java:142)
E/GeckoCrashHandler( 1906): 	at org.mozilla.gecko.BrowserApp.createHealthRecorder(BrowserApp.java:3240)
E/GeckoCrashHandler( 1906): 	at org.mozilla.gecko.GeckoApp$17.run(GeckoApp.java:1345)
E/GeckoCrashHandler( 1906): 	at android.os.Handler.handleCallback(Handler.java:733)
E/GeckoCrashHandler( 1906): 	at android.os.Handler.dispatchMessage(Handler.java:95)
E/GeckoCrashHandler( 1906): 	at android.os.Looper.loop(Looper.java:136)
E/GeckoCrashHandler( 1906): 	at org.mozilla.gecko.util.GeckoBackgroundThread.run(GeckoBackgroundThread.java:43)
E/GeckoCrashHandler( 1906): Main thread (1) stack:


E/ActivityThread( 1906): Failed to find provider info for org.mozilla.fennec.health
E/GeckoCrashHandler( 1906):     java.lang.BootClassLoader.getInstance(ClassLoader.java:748)
E/GeckoCrashHandler( 1906):     java.lang.ClassLoader.findLoadedClass(ClassLoader.java:346)
E/GeckoCrashHandler( 1906):     java.lang.ClassLoader.loadClass(ClassLoader.java:487)
E/GeckoCrashHandler( 1906):     java.lang.ClassLoader.loadClass(ClassLoader.java:457)
E/GeckoCrashHandler( 1906):     dalvik.system.DexFile.defineClassNative(Native Method)
E/GeckoCrashHandler( 1906):     dalvik.system.DexFile.defineClass(DexFile.java:222)
E/GeckoCrashHandler( 1906):     dalvik.system.DexFile.loadClassBinaryName(DexFile.java:215)
E/GeckoCrashHandler( 1906):     dalvik.system.DexPathList.findClass(DexPathList.java:322)
E/GeckoCrashHandler( 1906):     dalvik.system.BaseDexClassLoader.findClass(BaseDexClassLoader.java:54)
E/GeckoCrashHandler( 1906):     java.lang.ClassLoader.loadClass(ClassLoader.java:497)
E/GeckoCrashHandler( 1906):     java.lang.ClassLoader.loadClass(ClassLoader.java:457)
E/GeckoCrashHandler( 1906):     org.mozilla.gecko.BrowserApp.onCreate(BrowserApp.java:480)
E/GeckoCrashHandler( 1906):     android.app.Activity.performCreate(Activity.java:5231)
E/GeckoCrashHandler( 1906):     android.app.Instrumentation.callActivityOnCreate(Instrumentation.java:1087)

Updated

4 years ago
Status: RESOLVED → REOPENED
Ever confirmed: true
Resolution: INVALID → ---

Updated

4 years ago
Summary: Can't use Firefox in android safe mode → Firefox crashes in Android Safe Mode (java.lang.IllegalStateException: Could not fetch Health Report content provider.)
(Reporter)

Comment 6

4 years ago
I rechecked again by moving to safe mode, where in all apps, no third party apps are visible. If we add any shortcuts to home screen, then those apps are available to use in safe mode. I have tried few apps ther like whatsapp and banking apps will works finely, but Firefox, cscanner and cmsecurity were crashing.
If we can't get the FHR CP, I'd be surprised if we could get our others, too.

An easy way to test this out is to comment out the assignment to mHealthRecorder in GeckoApp.onCreate. If bookmarking and history works, then we can narrow the scope of this bug; if not, then this is likely a WONTFIX.
(Reporter)

Comment 8

4 years ago
OK.
Summary: Firefox crashes in Android Safe Mode (java.lang.IllegalStateException: Could not fetch Health Report content provider.) → Firefox crashes in Android Safe Mode (java.lang.IllegalStateException: Could not fetch Health Report content provider.). WONTFIX BUG
Status: REOPENED → RESOLVED
Last Resolved: 4 years ago4 years ago
Resolution: --- → DUPLICATE
Summary: Firefox crashes in Android Safe Mode (java.lang.IllegalStateException: Could not fetch Health Report content provider.). WONTFIX BUG → Firefox crashes in Android Safe Mode (java.lang.IllegalStateException: Could not fetch Health Report content provider)
Duplicate of bug: 728587

Updated

4 years ago
Duplicate of this bug: 1090316
You need to log in before you can comment on or make changes to this bug.