Urlbar behavior favoring search first and history second should be configurable

RESOLVED DUPLICATE of bug 1045105

Status

()

RESOLVED DUPLICATE of bug 1045105
4 years ago
4 years ago

People

(Reporter: themoz, Unassigned)

Tracking

35 Branch
x86_64
Windows 7
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

4 years ago
User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:35.0) Gecko/20100101 Firefox/35.0
Build ID: 20141020004004

Steps to reproduce:

Type the name of a site in your browser's history, especially one that has a space in its title.


Actual results:

As of recent versions of Firefox Aurora, the behavior of the Urlbar has changed such that as the user types the words identifying their destination, the first option in the drop-down menu is most often a "Search for [your input]."  Previously, the history entry that best matched the keywords provided would be rendered first.


Expected results:

This behavior appears to be following the lead of Chrome.  I know why Chrome strongly encourages a user to use a search engine; Firefox should be favoring the user's local history first.  The behavior prior to this change was ideal and was a competitive advantage (in my opinion) versus Chrome because virtually all of my navigation could occur by typing a word or two from a site's title, then pressing the down arrow once, and then pressing enter.

Although I do not expect Mozilla to revert this change outright, I would plead that a preference be added, even in about:config, that allows the user to either (a) remove the search engine option entirely from the urlbar's suggestions or (b) prioritize search below local history results.

Searching is already quite easy with the separate search control or keyword-enabled bookmarks; I see no reason to make it the preferred behavior of the Urlbar as well (unless, of course, driving search hits is important to Mozilla as an organization.)

Comment 1

4 years ago
The first entry is meant to already be selected, so that (just as before) hitting the down arrow key will select the topmost history item.

Marco, we're still going to do that for 35, right? It's kind of unfortunate this has made it off Nightly with this bug still there...
Flags: needinfo?(mak77)
(In reply to :Gijs Kruitbosch from comment #1)
> The first entry is meant to already be selected, so that (just as before)
> hitting the down arrow key will select the topmost history item.
> 
> Marco, we're still going to do that for 35, right? It's kind of unfortunate
> this has made it off Nightly with this bug still there...

We disabled unified complete in Aurora. bug 1081297.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 4 years ago
Flags: needinfo?(mak77)
Resolution: --- → DUPLICATE
Duplicate of bug: 1045105
You need to log in before you can comment on or make changes to this bug.