Closed Bug 1087824 Opened 5 years ago Closed 5 years ago

Intermittent test_bug732665.xul | Chrome should be able to have at least 10 heavy frames more stack than content: 147, 139 | Chrome should be invokable from content script with an exhausted stack: 8

Categories

(Core :: XPConnect, defect)

36 Branch
x86_64
Windows 8.1
defect
Not set

Tracking

()

RESOLVED FIXED
mozilla36
Tracking Status
firefox34 --- unaffected
firefox35 --- unaffected
firefox-esr31 --- unaffected

People

(Reporter: KWierso, Assigned: bholley)

References

Details

(Keywords: intermittent-failure)

Attachments

(2 files)

https://treeherder.mozilla.org/ui/logviewer.html#?job_id=3230492&repo=mozilla-inbound
builder 	Windows 7 32-bit mozilla-inbound pgo test mochitest-other
buildid 	20141022133005
builduid 	9377299c15714aae8c022556d65eaa72
results 	warnings (1)
revision 	f0520d8ed4ed
slave 	t-w732-ix-095
starttime 	Wed Oct 22 2014 16:10:19 GMT-0700 (Pacific Standard Time)



16:17:33 INFO - 1409 INFO TEST-START | chrome://mochitests/content/chrome/js/xpconnect/tests/chrome/test_bug706301.xul
16:17:33 INFO - 1410 INFO TEST-OK | chrome://mochitests/content/chrome/js/xpconnect/tests/chrome/test_bug706301.xul | took 48ms
16:17:33 INFO - 1411 INFO TEST-START | chrome://mochitests/content/chrome/js/xpconnect/tests/chrome/test_bug726949.xul
16:17:33 INFO - 1412 INFO TEST-OK | chrome://mochitests/content/chrome/js/xpconnect/tests/chrome/test_bug726949.xul | took 32ms
16:17:33 INFO - 1413 INFO TEST-START | chrome://mochitests/content/chrome/js/xpconnect/tests/chrome/test_bug732665.xul
16:17:33 INFO - 1414 INFO TEST-UNEXPECTED-FAIL | chrome://mochitests/content/chrome/js/xpconnect/tests/chrome/test_bug732665.xul | Chrome should be able to have at least 10 heavy frames more stack than content: 147, 139 - expected PASS
16:17:33 INFO - 1415 INFO TEST-UNEXPECTED-FAIL | chrome://mochitests/content/chrome/js/xpconnect/tests/chrome/test_bug732665.xul | Chrome should be invokable from content script with an exhausted stack: 8 - expected PASS
16:17:33 INFO - 1416 INFO TEST-OK | chrome://mochitests/content/chrome/js/xpconnect/tests/chrome/test_bug732665.xul | took 40ms
16:17:33 INFO - 1417 INFO TEST-START | chrome://mochitests/content/chrome/js/xpconnect/tests/chrome/test_bug738244.xul
16:17:33 INFO - 1418 INFO TEST-OK | chrome://mochitests/content/chrome/js/xpconnect/tests/chrome/test_bug738244.xul | took 52ms
16:17:33 INFO - 1419 INFO TEST-START | chrome://mochitests/content/chrome/js/xpconnect/tests/chrome/test_bug743843.xul
16:17:33 INFO - 1420 INFO TEST-OK | chrome://mochitests/content/chrome/js/xpconnect/tests/chrome/test_bug743843.xul | took 33ms
Hrm, this actually seems to be a permafail on Windows PGO builds...

Bug 1019191 seems like a good candidate for the cause.

bz, any ideas?
Depends on: 1019191
Flags: needinfo?(bzbarsky)
Sadly, not so far.  I mean, if this is Windows PGO only it might be a matter of how big the stack frames for some random C++ end up being or something.  :(  Looks like we reserve 10KB of stack, which can easily not be enough for 10 C++ stackframes!

Bobby, any ideas?
Flags: needinfo?(bzbarsky)
I triggered PGO on this bug's push and the one prior so we can confirm it's at fault, but it'll be another two hours before builds are finished, let alone tests...
And the retriggers on bug 1019191's push came back green. Awesome.
(In reply to Boris Zbarsky [:bz] from comment #7)
> Sadly, not so far.  I mean, if this is Windows PGO only it might be a matter
> of how big the stack frames for some random C++ end up being or something. 
> :(  Looks like we reserve 10KB of stack, which can easily not be enough for
> 10 C++ stackframes!
> 
> Bobby, any ideas?

The point of this test is just to make sure we continuously measure the size of stack frames and update the stack limits accordingly. I'll attach a patch.
Attachment #8510110 - Flags: review?(luke)
Attachment #8510110 - Flags: review?(luke) → review+
https://hg.mozilla.org/mozilla-central/rev/9d422498fd5c
Assignee: nobody → bobbyholley
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla36
hm seems not fixed becaue same problem on fx-team -> https://treeherder.mozilla.org/ui/logviewer.html#?job_id=992385&repo=fx-team
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
(In reply to Carsten Book [:Tomcat] from comment #23)
> hm seems not fixed becaue same problem on fx-team ->
> https://treeherder.mozilla.org/ui/logviewer.html#?job_id=992385&repo=fx-team

Looks like it went from two errors down to one, though.
Looks like 64-bit is actually slightly affected. In both cases now we're one
frame too short (because we need 11 for the test).
Attachment #8511603 - Flags: review?(luke)
Attachment #8511603 - Flags: review?(luke) → review+
https://hg.mozilla.org/mozilla-central/rev/eec905f5d364
Status: REOPENED → RESOLVED
Closed: 5 years ago5 years ago
Resolution: --- → FIXED
See Also: → 1119363
You need to log in before you can comment on or make changes to this bug.