find solution for improving Firefox gUM flow for https://hello.firefox.com

RESOLVED DUPLICATE of bug 1066019

Status

defect
P5
normal
RESOLVED DUPLICATE of bug 1066019
5 years ago
5 years ago

People

(Reporter: RT, Unassigned)

Tracking

unspecified
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

Currently Loop link clickers on Firefox have to accept sharing their mic and camera through the gUM door hanger when they initiate a call.

Given that we manage the web app on the https://hello.firefox.com domain can't we avoid requesting the user to share his mic/cam through the gUM door hanger given that users often don't see this prompt or by mistake click somewhere else on the page which causes the door hanger to be closed and hard to find again by the users.

Also it's unfortunate that for a user the link clicker experience is better on Chrome currently given that Chrome only requires acceptance once per https domain.

TokBox reported to us that the drop-off when users get prompted to share the mic/cam on Firefox is much higher than on Chrome.
No longer blocks: 1047040
Isn't the real issue here that we should push for FF to be fixed?

Disabling the prompt is going to cause users to not be able to select the microphone or camera to be used, which is not going to be good for user experience.

I thought the long-term goal was also to have links opened in FF's conversation window... though that might have changed with the switch to rooms.
(In reply to Mark Banner (:standard8) from comment #1)
> Isn't the real issue here that we should push for FF to be fixed?

Probably. See https://bugzilla.mozilla.org/show_bug.cgi?id=1081248
So I think we should depend on bug 104740 - that will give the user some info, and bug 1081248 that will hopefully improve FF itself.
Depends on: 1047040, 1081248
backlog: --- → Fx38?
We're not going to disable the doorhanger entirely. Fixing doorhangers or finding some other mechanism for prompting are options.
Summary: Investigate disabling gUM door hanger on Firefox for https://hello.firefox.com domain → find solution for improving Firefox gUM flow for https://hello.firefox.com
putting as such a low priority - as Jared is landing a fix for bug 1047040 and beyond that we should wait and see what firefox team does with the general door hanger bug.  it's on their backlog now - so we can check back on this later.  may close if we find metrics saying our issue went away.
Priority: -- → P5
Actually the need for this goes away with bug 1066019.
Marking this as a duplicate.
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1066019
You need to log in before you can comment on or make changes to this bug.