If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Assertion failure: !used(), at c:\mozilla\builds\nightly\mozilla\js\src\jit/Label.h:91

RESOLVED WORKSFORME

Status

()

Core
JavaScript Engine
RESOLVED WORKSFORME
3 years ago
2 years ago

People

(Reporter: Tomcat, Unassigned)

Tracking

(Blocks: 1 bug, {assertion})

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(2 attachments)

(Reporter)

Description

3 years ago
Created attachment 8510230 [details]
bughunter stack

found via bughunter and reproduced on windows 7 trunk debug build:

Steps to reproduce:

-> Load http://www.lgr.co.uk/ 
-> You will see a lot of JavaScript error: http://www.lgr.co.uk/wp-content/themes/lgr-v2.2/js/jquery-latest.min.js, line 2: too much recursion
and finally crashes

Bughunter reports this as:
Assertion failure: !used(), at c:\mozilla\builds\nightly\mozilla\js\src\jit/Label.h:91

but i was not able to reproduce this assertion locally. However got this in windbg and got data from there.
(Reporter)

Comment 1

3 years ago
Created attachment 8510232 [details]
windgb data win 7 trunk debug build
(Reporter)

Comment 2

3 years ago
note: opt builds seems to have problems with this site too. Got stuck in a loop with the unresponsive script and had to force quit the nightly on 10.9
See Also: → bug 1100080

Comment 3

2 years ago
Retested with OSX 10.{6,8,9}, RHEL6 {32,64}bit, Windows 7 {32,64}bit, Beta/38, Aurora/39, Nightly/40 and no crash. -> WFM.
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.