Come up with a way to easily view treeherder logs from all prod nodes in one place

RESOLVED DUPLICATE of bug 1151800

Status

P3
normal
RESOLVED DUPLICATE of bug 1151800
4 years ago
3 years ago

People

(Reporter: emorley, Unassigned)

Tracking

Details

(Reporter)

Description

4 years ago
13:48 <•edmorley> mdoglio: do logger.error()s appear in newrelic?
13:49 <•edmorley> mdoglio: I'm presuming not?
13:49 <•mdoglio> no it doesn;t
13:50 <•edmorley> mdoglio: should we come up with a way to do so, or do you think it's not worth it?
13:50 <•mdoglio> edmorley: don't think it's worth it
13:50 <•mdoglio> edmorley: I would prefer to have a central place to write logs to, so that we can keep it under control
13:51 <•mdoglio> we now have too many machines to log into each and read the logs
13:51 <•edmorley> mdoglio: yeah I agree on that
13:51 <•mdoglio> we probably have already something in place for it but we don't know
13:51 <•mdoglio> it wouldn't surprise me at all
(Reporter)

Comment 1

4 years ago
Do you have any suggestions for ways to do this/does Mozilla already have a tool/dashboard for this? :-)
Flags: needinfo?(klibby)
Looks like we're going to try to put together logstash, or an equivalent, in 2015. Would it be sufficient to have all of the raw logs in one place, a la syslog?
Flags: needinfo?(klibby)
(Reporter)

Updated

4 years ago
Blocks: 1080757
No longer blocks: 1072681
(Reporter)

Comment 3

4 years ago
(In reply to Kendall Libby [:fubar] from comment #2)
> Looks like we're going to try to put together logstash, or an equivalent, in
> 2015. Would it be sufficient to have all of the raw logs in one place, a la
> syslog?

Yeah I think anything would be better than the current situation :-)
Priority: -- → P2

Updated

4 years ago
Depends on: 1093763
(Reporter)

Updated

4 years ago
No longer blocks: 1080757
(Reporter)

Updated

4 years ago
Component: Treeherder → Treeherder: Infrastructure
(Reporter)

Updated

4 years ago
Priority: P2 → P3
(Reporter)

Updated

4 years ago
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1151800
(Reporter)

Updated

3 years ago
No longer depends on: 1093763
You need to log in before you can comment on or make changes to this bug.