[Top sites] Web page appears duplicated in topsites list

RESOLVED INVALID

Status

Firefox OS
Gaia::System
RESOLVED INVALID
4 years ago
4 years ago

People

(Reporter: lolimartinezcr, Unassigned)

Tracking

unspecified
ARM
Gonk (Firefox OS)

Firefox Tracking Flags

(b2g-v2.0 unaffected, b2g-v2.1 affected, b2g-v2.2 affected)

Details

(Whiteboard: [systemsfe])

Attachments

(1 attachment)

(Reporter)

Description

4 years ago
Created attachment 8510361 [details]
2014-10-23-16-54-38.png

Flame
2.2
User
Gecko-0dbdde5
Gaia-3c90141

Prerequites:
-"topsites_movistar.json" file with this configuration:

{
  "topSites": [
    {
      "title": "Movistar",
      "url": "http://www.movistar.es/",
      "tilePath": "resources/movistar.ico"
    },
    {
      "title": "Facebook",
      "url": "https://m.facebook.com/",
      "tilePath": "resources/movistar.ico"
    }

]
}

- Configured  SIM card with pin.

STRs:
1. Open browser app.
2. Open a web page which is not added to the top sites list (for example: www.hotmail.com).
3. Again, open the same web page in step 2. (Tap in navigation bar, url in step 2 appear in this bar and tap "Enter" button)
4. Open top sites list.

Actual result:
In top sites list, user can see web page (step 2 and step 3) two times.

Expected result:
In topsites list, user can see web page (step 2 and step 3) only a time, because it is same web page.

Note: I attached image about duplicate web pages in topsites.
(Reporter)

Updated

4 years ago
Summary: [Top sites] Web page appear some times in topsites list → [Top sites] Web page appears duplicated in topsites list
Whiteboard: [systemsfe]
status-b2g-v2.2: --- → affected
(Reporter)

Comment 1

4 years ago
Tested and working in: 
Flame
2.0
User
Gecko-72d5bb6
Gaia-5e532a8
status-b2g-v2.0: --- → unaffected
Keywords: regression
(Reporter)

Comment 2

4 years ago
Tested and bug *is reproduced* in: 
Flame
user
v2.1
188based
Gecko-49daf73
Gaia-1b231b8
status-b2g-v2.1: --- → affected
[Blocking Requested - why for this release]:

Asking for being a blocker as it is a regression
blocking-b2g: --- → 2.1?
Keywords: regressionwindow-wanted
We have gone over this bug previously, hotmail.com redirects to https://login.live.com/, that means there will be (at least) 2 seperate urls stored in places (and top sites) for that visit, the browser in 2.0 will only ever show an even number of results, so if you have an odd number of top sites then it may truncate a result however it did register both urls as top sites, in >= 2.1 we show all the top sites, so although the exact sites that are shown may change, its a specific change in the behaviour of the UI, not a regression of functionality.
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Keywords: regression, regressionwindow-wanted
Resolution: --- → INVALID

Updated

4 years ago
blocking-b2g: 2.1? → ---
You need to log in before you can comment on or make changes to this bug.