Can't authenticate with SIM card from the carrier Free

RESOLVED FIXED

Status

Cloud Services
MobileID
RESOLVED FIXED
3 years ago
3 years ago

People

(Reporter: jlorenzo, Assigned: natim)

Tracking

(Blocks: 1 bug)

unspecified
ARM
Gonk (Firefox OS)
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(b2g-v2.0 affected, b2g-v2.1 affected)

Details

(Whiteboard: [2.1-bug-bash] )

Attachments

(1 attachment)

(Reporter)

Description

3 years ago
Build Information
Gaia-Rev        1e48e3e40e0780c0cd07a3457e5fe2efeeb542d1
Gecko-Rev       https://hg.mozilla.org/releases/mozilla-b2g34_v2_1/rev/09fb60a37850
Build-ID        20141023001201
Version         34.0
Device-Name     flame
Base image:     v188

Pre-requisites
* Have a disconected device
* Have a SIM card from the French carrier Free. 

Steps to Reproduce
1. Run Firefox Hello and go through the tutorial
2. Select "Use phone number" 
3. Select you Free Sim card
4. Wait

Expected Results
Like any other SIM card, you should receive a silent SMS and you should get connected.

Actual Results
After about 1 minute, you get an error message asking you to resend it. Once you tap the resend button, you receive the SMSes but Firefox Hello doesn't log you.

Reproduction Frequency: 4/4, tried with 1 or 2 SIM cards.
(Reporter)

Comment 1

3 years ago
Please tell me which logs you'd like to see for that bug.
Whiteboard: [2.1-FC-bug-bash] → [2.1-bug-bash]

Comment 2

3 years ago
does the phone settings itself recognize the carrier?  or just the Firefox Hello app?  

Qawanted to try your "Free" sim with Settings app first, as well as checking on 2.0 builds.

adding loop meta bug to the dependency list.
Blocks: 988276
status-b2g-v2.1: --- → affected
Flags: needinfo?(jlorenzo)
Keywords: qawanted
Blocks: 1021594
No longer blocks: 988276
Component: Gaia::Loop → DOM: Device Interfaces
Product: Firefox OS → Core
Although this is not a blocker, as the initial target market is not users of those SIM Cards I’d like to investigate a bit more the root cause of this issue just in case it might affect some of our target users. Adding ni to Fernando so he can have a look when is back from his Holidays.
Flags: needinfo?(ferjmoreno)
(Reporter)

Comment 4

3 years ago
(In reply to Tony Chung [:tchung] from comment #2)
> does the phone settings itself recognize the carrier?  or just the Firefox
> Hello app?  
Just the Hello app. When I go to settings -> SIM Manager, the carrier is correctly displayed.

I checked again against 2.1 with loop client revision 689cae0ec9ffe5e7281bf4d1ccb7c92367416fae => KO, the SMS is received (from 36178, with something like a SHA-1 as the body) but the app is stuck at the authenticating page.

Same thing on 2.0:
Gaia-Rev        9f5b6f025e528fabfcc068782cb9b492cb51a7f9
Gecko-Rev       https://hg.mozilla.org/releases/mozilla-b2g32_v2_0/rev/de8cfd54bf93
Build-ID        20141029000205
Version         32.0
Device-Name     flame
FW-Release      4.4.2
FW-Incremental  39
FW-Date         Thu Oct 16 18:19:14 CST 2014
Bootloader      L1TC00011880
Loop Client     689cae0ec9ffe5e7281bf4d1ccb7c92367416fae
status-b2g-v2.0: --- → affected
Flags: needinfo?(jlorenzo)
Keywords: qawanted

Comment 5

3 years ago
Johan, could you set the Mobile ID debug prefs [1] on and attach the Mobile ID logs to the bug, please? Also, can you reproduce this issue with a SIM card from a different carrier? Thanks!

[1] https://wiki.mozilla.org/WebAPI/MobileIdentity#Debugging
Flags: needinfo?(ferjmoreno) → needinfo?(jlorenzo)
(Reporter)

Comment 6

3 years ago
Created attachment 8518228 [details]
Logcat with Mobile ID

Here's attached the full logcat.

I cannot repro on an Orange SIM card. If it helps, I heard Free SIMs cards don't have STK.
Flags: needinfo?(jlorenzo)

Updated

3 years ago
Attachment #8518228 - Attachment filename: logcat → logcat.txt

Updated

3 years ago
Attachment #8518228 - Attachment mime type: text/x-vhdl → text/plain

Comment 7

3 years ago
Thank you Johan! This is very helpful.

I can see in the log that we are having two issues:

1- We are allowing the MO+MT flow for Free SIM cards with no MSISDN written on it, while we shouldn't:

I/Gecko   (  209): 1415291946612	MobileId	DEBUG	iccInfo {"clientId":0,"iccId":"8933150113100628901","mcc":"208","mnc":"15","msisdn":null,"operator":"Free","roaming":false}
I/Gecko   (  209): 1415291947821	Hawk	DEBUG	Response text: {"verificationMethods":["sms/momt"],"verificationDetails":{"sms/momt":{"mtSender":"Mozilla@","moVerifier":"+33644639987"}}}

2- We are sending the SMS MO with the uuid generated in the client but we are not getting an SMS MT from the server as response, so we timeout.

I/Gecko   (  209): 1415291952658	MobileId	DEBUG	Sending /sms/momt/verify b3e87ff6313ca9e24441814002739e808f5b00d5c0497a2159ac510947569378 to +33644639987
I/Gecko   (  209): 1415291954909	MobileId	DEBUG	Silent message successfully sent
I/Gecko   (  209): 1415292012616	MobileId	ERROR	UI error VERIFICATION_CODE_TIMEOUT
I/Gecko   (  209): 1415292012632	MobileId	WARN	doVerification VERIFICATION_CODE_TIMEOUT

Rémy, I believe we need to do two things here. Check why are not replying to the SMS MO and forbid the SMS MO flow for Free SIM cards. I thought we were already forbidding the MO flow by default.
Flags: needinfo?(rhubscher)

Updated

3 years ago
Component: DOM: Device Interfaces → MobileID
Product: Core → Mozilla Services
QA Contact: jbonacci
(Assignee)

Comment 8

3 years ago
I confirm that we can start the MOMT flow in France since message are unlimited for most offers nowadays.

    msisdn-cli -H https://msisdn.services.mozilla.com -c 208
Flags: needinfo?(rhubscher)

Comment 9

3 years ago
Thank you Rémy. Do you mean that we are allowing clients to use the MOMT flow in France by default?

Johan, could you check that you are able to receive SMS on that SIM card, please?
Flags: needinfo?(jlorenzo)
(Assignee)

Comment 10

3 years ago
> Do you mean that we are allowing clients to use the MOMT flow in France by default?

Yes
(Reporter)

Comment 11

3 years ago
(In reply to Fernando Jiménez Moreno [:ferjm] from comment #9)
> Johan, could you check that you are able to receive SMS on that SIM card,
> please?
Like said in comment 0 and comment 4,  I receive the SMS on that SIM card.
Flags: needinfo?(jlorenzo)

Comment 12

3 years ago
Oh right, sorry, I just read it again. You mention that the SMS is received from the 36178 number, while we are observing messages coming from "Mozilla@" (note the mtSender field in the logs). That's probably the reason of this issue.
(Assignee)

Comment 13

3 years ago
> the SMS is received from the 36178 number, while we are observing messages coming from "Mozilla@"

Yes I am currently in contact with Nexmo about that.
(Assignee)

Comment 14

3 years ago
We have seen the same problem with the MT Flow in France.
(Assignee)

Comment 15

3 years ago
Ok so apparently there are some restriction I wasn't aware of for France.

https://help.nexmo.com/hc/en-us/articles/204017483-France-Direct-route-

The solution for us is to define the full french number as the MT Sender.

I am creating Bugs to configure that in production.
(Assignee)

Updated

3 years ago
Depends on: 1096300
(Assignee)

Comment 16

3 years ago
I have open Bug 1096300 and Bug 1096306 to fix this.
Assignee: nobody → rhubscher
Status: NEW → ASSIGNED
(Assignee)

Updated

3 years ago
Status: ASSIGNED → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.