[Flame][v2.1] Getting a SMS with null message on first run

RESOLVED INVALID

Status

Firefox OS
Gaia::SMS
RESOLVED INVALID
3 years ago
3 years ago

People

(Reporter: Martijn Wargers (dead), Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [2.1-bug-bash] )

(Reporter)

Description

3 years ago
On Firefox OS 2.1 on the Flame, I get a weird SMS message with "null" text in it on FTU.
I have SIMS in it from the provider named "Choozze" (from the Netherlands).

Expected result:
- I don't expect to receive any SMS.
(Reporter)

Updated

3 years ago
Summary: [Flame][v2.1] Gettin ga SMS with null message on first run → [Flame][v2.1] Getting a SMS with null message on first run
It looks like you get an empty SMS from your carrier :) I don't think we can do much...

The "null" text issue is bug 1062034.
Whiteboard: [2.1-FC-bug-bash] → [2.1-bug-bash]

Comment 2

3 years ago
sounds like by design per carrier.  To confirm, please try this SIM with an android device to see if there really is a blank SMS notification or not.   

if yes, please reopen bug.  And bug 1062034 is tracking the null message.
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → INVALID
(Reporter)

Comment 3

3 years ago
Ok, now I get a notification from Sim 2 saying "Thanks for using the service".
This is with FirefoxOS 2.1, but I've seen this with trunk (FirefoxOS 2.2) too.
Why only SIM 2? No idea, because SIM 1 is from the same provider, I would expect an sms from that one as well, then.

So I can't reproduce this at all, anymore, it seems.
(Reporter)

Comment 4

3 years ago
(In reply to Martijn Wargers [:mwargers] (QA) from comment #3)
> Ok, now I get a notification from Sim 2 saying "Thanks for using the
> service".

Ok, that notification happens apparently, because I haven't used the sim card yet.
Looks good then? :)
(Reporter)

Comment 6

3 years ago
Yes, it looks good. Sorry, it might look like spamming this bug, but I'm commenting in case other people encounter this problem.
You need to log in before you can comment on or make changes to this bug.