If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

add points for Tarako reviews; extra for additional platforms; make non-privileged packaged apps the same points as hosted.

RESOLVED FIXED in 2014-11-25

Status

Marketplace
Reviewer Tools
P3
normal
RESOLVED FIXED
3 years ago
3 years ago

People

(Reporter: eviljeff, Assigned: eviljeff)

Tracking

Avenir
2014-11-25
x86_64
Windows 7
Points:
---

Details

(Assignee)

Description

3 years ago
summary of what we want to change:
* change the points currently given to all packaged apps to privileged packaged apps only (i.e. the ones that require more time due to code review).  It doesn't make sense to give more points based on the distribution format as they don't take any more review effort.  

* give points for reviews in the additional queues (just Tarako currently, but ideally the code should be generic enough to apply to future queues too).  I propose 30 points per review (same as re-review)

* give additional points per platform an app is available for, for new submissions.  propose +10 per platform.  So a hosted app available for Desktop only would be 60; for Desktop+FxOS would be 70; etc.

Once we're agreed I'll file sub-bugs.

Updated

3 years ago
Priority: -- → P3
(Assignee)

Updated

3 years ago
Assignee: nobody → awilliamson
(Assignee)

Comment 1

3 years ago
https://github.com/mozilla/zamboni/pull/2736
(Assignee)

Comment 2

3 years ago
https://github.com/mozilla/zamboni/commit/caeb13780085e90d5338e07455c2a63089c81c00
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → FIXED
Summary: Incentive points refresh → add points for Tarako reviews; extra for additional platforms; make non-privileged packaged apps the same points as hosted.
Target Milestone: --- → 2014-11-25

Comment 3

3 years ago
Verified in FF36(Win7) in marketplace-dev.allizom.org
Currently no points are added after a tarako review. Please view this screencast: http://screencast.com/t/rddOfJ6fTxOH

Hosted apps reviews give the same amount as non-privileged packaged apps(60 points, +10 for each extra platform). Privileged packaged apps reviews give 120 points.

So the only issue here is that no points are given for tarako reviews.
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
(Assignee)

Comment 4

3 years ago
no idea why the code was failing but:

https://github.com/mozilla/zamboni/commit/7d5b4d37d89de0f29610061c8cf0fdaae70981f9
Status: REOPENED → RESOLVED
Last Resolved: 3 years ago3 years ago
Resolution: --- → FIXED

Comment 5

3 years ago
The points are added for a tarako review: http://screencast.com/t/ik9vnSA5A
the problem is that the awarded points are not displayed like they are when, for example, approving a hosted app.
There is no overlay displayed with the points awarded for a tarako review. The points are only displayed in Recent points section or can be noticed if the user compares the value of All Time points before and after the tarako review.
I am talking about this overlay: http://screencast.com/t/M4ZJaCqq8yeO
(Assignee)

Comment 6

3 years ago
(In reply to Madalin Cotetiu from comment #5)
> The points are added for a tarako review: http://screencast.com/t/ik9vnSA5A
> the problem is that the awarded points are not displayed like they are when,
> for example, approving a hosted app.
> There is no overlay displayed with the points awarded for a tarako review.
> The points are only displayed in Recent points section or can be noticed if
> the user compares the value of All Time points before and after the tarako
> review.
> I am talking about this overlay: http://screencast.com/t/M4ZJaCqq8yeO

Going to log this as a new bug - the way Tarako reviews are processed (via the API) means the method the normal reviews use for displaying point updates isn't available.
(Assignee)

Updated

3 years ago
Blocks: 1105318
You need to log in before you can comment on or make changes to this bug.