Closed Bug 1088166 Opened 7 years ago Closed 7 years ago

Add sanity marionette JS tests for the CardView

Categories

(Firefox OS Graveyard :: Gaia::System::Window Mgmt, defect)

x86
macOS
defect
Not set
normal

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: etienne, Assigned: etienne)

Details

Attachments

(1 file)

46 bytes, text/x-github-pull-request
sfoster
: review+
Details | Review
* screenshots displayed
* basic navigation
* behavior when "exiting" with home
Assignee: nobody → etienne
Attached file Gaia PR
Harder than expected (mainly because of the screenshoting).
Moving to review while I watch for any intermittent
Attachment #8518969 - Flags: review?(sfoster)
Comment on attachment 8518969 [details] [review]
Gaia PR

Tests look great, I ran task_manager_test.js locally and it passed 5/5. The tree-herder Gij story is not pretty though. I'm not sure of some of those failures are caused by the changes here (e.g. to apps/system/test/marionette/lib/system.js) or what. I'll re-trigger a few times, but I think we'll need to see that green up before we can land this.
Attachment #8518969 - Flags: review?(sfoster)
New try, "good" thing is those were actually permareds.
https://treeherder.mozilla.org/ui/#/jobs?repo=gaia-try&revision=1f19b0b1fd18
1/5 Gij was green. I retriggered a few more times to see how intermittent those are.
(In reply to Sam Foster [:sfoster] from comment #4)
> 1/5 Gij was green. I retriggered a few more times to see how intermittent
> those are.

yeah this wasn't ready for prime time, posted a new try link. we should probably just use the last one on the PR.
Comment on attachment 8518969 [details] [review]
Gaia PR

Much better now, ready for review, will retrigger the Gij slice with the test a bunch of times.
Attachment #8518969 - Flags: review?(sfoster)
Comment on attachment 8518969 [details] [review]
Gaia PR

Look great. I just left one comment in GH about potential ref-test style checking on what's in those task-cards vs. examining the style.backgroundImage for the property we expect. We've talked about some lightweight/low-maintenance ref test infrastrcture in the context of other tests (e.g. icons?) so is probably a candidate for a follow-up.
Attachment #8518969 - Flags: review?(sfoster) → review+
Blocks: 1100293
https://github.com/mozilla-b2g/gaia/commit/88a17bc134ffb1d281de11f9df6fb8ad4f4fd722

(filed bug 1100293)
No longer blocks: 1100293
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.