Exiting fullscreen mode causes artifact on the right window border

VERIFIED FIXED in Firefox 36

Status

()

--
major
VERIFIED FIXED
4 years ago
a year ago

People

(Reporter: Virtual, Assigned: bbondy)

Tracking

(Blocks: 1 bug, {nightly-community, regression})

36 Branch
mozilla36
x86_64
Windows 7
nightly-community, regression
Points:
---

Firefox Tracking Flags

(firefox35 unaffected, firefox36 verified)

Details

(URL)

Attachments

(2 attachments)

Created attachment 8510567 [details]
bug.jpg

1. Go to https://www.youtube.com/watch?v=WwSMAhBgOIw&hd=1
2. Enter fullscreen mode
3. Exit fullscreen mode
4. Enjoy artifact on the right window border

Comment 1

4 years ago
[Tracking Requested - why for this release]:

The problem happens on not only youtube site but also about;home page

Steps to Reproduce:
1. Start Nightly with default toolbar setting(hide title bar etc..)
2. Maximized
3. Enter Full Screen
4. Exit Full Screen

Regression window(m-i)
Good:
https://hg.mozilla.org/integration/mozilla-inbound/rev/b79232598a90
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:36.0) Gecko/20100101 Firefox/36.0 ID:20141018140412
Bad:
https://hg.mozilla.org/integration/mozilla-inbound/rev/53244356f497
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:36.0) Gecko/20100101 Firefox/36.0 ID:20141018174412
Pushlog:
http://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=b79232598a90&tochange=53244356f497

Regressed by:
53244356f497	Harsh Vardhan ? Bug 1026865 - Fullscreen Maximize Fixed in nsWindow.cpp. r=bbondy
Blocks: 1026865
status-firefox35: --- → unaffected
status-firefox36: --- → affected
tracking-firefox36: --- → ?
Keywords: regressionwindow-wanted
Summary: Exiting fullscreen mode with HTML5 player on Youtube causes artifact on the right window border → Exiting fullscreen mode causes artifact on the right window border

Updated

4 years ago
Component: Video/Audio → Widget: Win32

Updated

4 years ago
Duplicate of this bug: 1088479
(Assignee)

Updated

4 years ago
Assignee: nobody → netzen

Updated

4 years ago
Duplicate of this bug: 1091931

Comment 4

4 years ago
My Windows taskbar located at left side. I have artifact at bottom too.
https://pp.vk.me/c622919/v622919541/8ac5/BtE_S9CoTNo.jpg

Updated

4 years ago
Duplicate of this bug: 1092695

Comment 6

4 years ago
:royalharsh95

It is time to backed out the offending patch.
Flags: needinfo?(harshvd95)

Comment 7

4 years ago
Created attachment 8516153 [details]
bug.png

And Right edge of the browser is cut off if taskbar on the left.
So window control buttons, hamburger menu button are missing.

Str
1. Taskbar placed on the left side
2. Hide Titlebar
3. Maximized
4.  Enter Full screen
5. Exit Fullscreen

Updated

4 years ago
Flags: needinfo?(netzen)
(Assignee)

Comment 8

4 years ago
I'll back out the offending bug and re-open it. I'll leave this open as well and we'll eventually re-land both at the same time.
Flags: needinfo?(netzen)
Tracking this but Brian can you update this to resolved when you confirm after backout.
tracking-firefox36: ? → +
(Assignee)

Comment 10

4 years ago
Yep. The blocking bug was the one that needed a backout because of this.   It was backed out yesterday, although it hasn't been merged to m-c yet See bug 1026865.
status-firefox36: affected → unaffected
tracking-firefox36: + → ---
Backout fixed the problem in latest Nightly, so I'm marking this as FIXED looking on Benjamin Kerensa [:bkerensa] comment.
Status: NEW → RESOLVED
Last Resolved: 4 years ago
status-firefox36: unaffected → verified
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.