[Settings] The "Confirm" and "Cancel" buttons on the "Forget Network" screen are UI enabled but perform no action.

RESOLVED DUPLICATE of bug 1090694

Status

Firefox OS
Gaia::Settings
RESOLVED DUPLICATE of bug 1090694
3 years ago
3 years ago

People

(Reporter: SMiko, Assigned: mancas)

Tracking

({regression})

unspecified
ARM
Gonk (Firefox OS)
regression

Firefox Tracking Flags

(b2g-v2.1 unaffected, b2g-v2.2 affected)

Details

(Whiteboard: [2.2-Daily-Testing], URL)

Attachments

(2 attachments)

(Reporter)

Description

3 years ago
Created attachment 8510630 [details]
network.txt

Description: The user is unable to forget a connected network via "Manage Networks."

Repro Steps:
1: Update a Flame to 20141023040204
2: Open Settings > Wifi and connect to a network
3: Open Settings > Wifi > Manage Networks > chose the connected network 
4: Tap "Confirm" or "Cancel" on the "Forget network?" confirmation page.

Actual:
Neither button performs an action when tapped.

Expected:
The user is able to select "Confirm" or "Cancel"

Device: Flame 2.2
BuildID: 20141023040204
Gaia: 27a1d1baaa8e375b70e043efee67d5f2206c330b
Gecko: 88adcf8fef83
Gonk: 05aa7b98d3f891b334031dc710d48d0d6b82ec1d
Version: 36.0a1 (2.2)
Firmware: V188
User Agent: Mozilla/5.0 (Mobile; rv:36.0) Gecko/36.0 Firefox/36.0

Repro frequency: 4/4

See attached: logcat

Video clip: http://youtu.be/qjWgVcSxLVI
(Reporter)

Comment 1

3 years ago
This issue does NOT repro on Flame 2.1 (319mb/full flash)

Actual result: The user is able to select "Confirm" and "Cancel"Device: 

Flame 2.1
BuildID: 20141023001201
Gaia: 1e48e3e40e0780c0cd07a3457e5fe2efeeb542d1
Gecko: 09fb60a37850
Gonk: 05aa7b98d3f891b334031dc710d48d0d6b82ec1d
Version: 34.0 (2.1)
Firmware: V188
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0
_____________________________________________________________________________________________________________________________________

This issue DOES repro on Flame 2.2 (319/full flash/20141022040201)

Actual result: Buttons do not function

Device: Flame 2.2
BuildID: 20141022040201
Gaia: 4d7f051cede6544f4c83580253c743c22b0cb279
Gecko: ae4d9b4ff2ee
Gonk: 05aa7b98d3f891b334031dc710d48d0d6b82ec1d
Version: 36.0a1 (2.2)
Firmware: V188
User Agent: Mozilla/5.0 (Mobile; rv:36.0) Gecko/36.0 Firefox/36.0
QA Whiteboard: [QAnalyst-Triage?]
status-b2g-v2.1: --- → unaffected
status-b2g-v2.2: --- → affected
Flags: needinfo?(pbylenga)
Keywords: regression
Whiteboard: [2.1-FC-bug-bash]
(Reporter)

Updated

3 years ago
Whiteboard: [2.1-FC-bug-bash] → [2.2-Daily-Testing]
[Blocking Requested - why for this release]:
Functional regression of a core feature.

Requesting a window.
blocking-b2g: --- → 2.2?
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(pbylenga)
Keywords: regressionwindow-wanted
QA Contact: aalldredge
(Assignee)

Updated

3 years ago
Assignee: nobody → b.mcb
(Assignee)

Comment 3

3 years ago
Created attachment 8511931 [details] [review]
Buttons work properly
Attachment #8511931 - Flags: review?(arthur.chen)
----------------------------------------------------
B2G-Inbound Regression Window (Shallow Flash)
----------------------------------------------------

Last Working:
Device: Flame 2.2 Master
BuildID: 20141020205719
Gaia: e09e1734ad523cf63351a28f6f84454319349fbe
Gecko: 4da1f6a151d6
Version: 36.0a1 (2.2 Master)
Firmware: V188
User Agent: Mozilla/5.0 (Mobile; rv:36.0) Gecko/36.0 Firefox/36.0

First Broken:
Device: Flame 2.2 Master
BuildID: 20141020214218
Gaia: ba10744d64411a8a12ae68f7cf1ec3e3ac897d21
Gecko: bcc5df613d83
Version: 36.0a1 (2.2 Master)
Firmware: V188
User Agent: Mozilla/5.0 (Mobile; rv:36.0) Gecko/36.0 Firefox/36.0

Last Working Gaia First Broken Gecko: Issue does NOT reproduce
Gaia: e09e1734ad523cf63351a28f6f84454319349fbe
Gecko: bcc5df613d83

First Broken Gaia Last Working Gecko: Issue DOES reproduce
Gaia: ba10744d64411a8a12ae68f7cf1ec3e3ac897d21
Gecko: 4da1f6a151d6

Pushlog:
https://github.com/mozilla-b2g/gaia/compare/e09e1734ad523cf63351a28f6f84454319349fbe...ba10744d64411a8a12ae68f7cf1ec3e3ac897d21

Caused by Bug 1007600
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(jmitchell)
Keywords: regressionwindow-wanted
Regression cause identified but patch already in the works (comment 3) so no action here at this time.
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(jmitchell)
Thanks for the patch. This is a regression caused by bug 1007600. I've already provide a fix in bug 1090694.
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1090694
Attachment #8511931 - Flags: review?(arthur.chen)
blocking-b2g: 2.2? → ---
You need to log in before you can comment on or make changes to this bug.