[Flame]User is able to add invalid email address in email field of a new contact form

RESOLVED WONTFIX

Status

--
enhancement
RESOLVED WONTFIX
4 years ago
6 months ago

People

(Reporter: pensacola_m2000, Unassigned)

Tracking

unspecified
x86
Linux

Firefox Tracking Flags

(b2g-v2.1 affected)

Details

(Whiteboard: [2.1-bug-bash] )

(Reporter)

Description

4 years ago
Gaia   f5d4ff60ffed8961f7d0380ada9d0facfdfd56b1
SourceStamp ad497694e258
BuildID 20141013000205
Version 34.0a2
v180
2.1.0


Steps to Reproduce
1. Launch Contacts app
2. Tap Add new contacts button
3. Enter name and then insert an invalid email address. 

Expected Results
User should not be able to save a contact with invalid email address. An error message should be displayed.

Actual Results
User is able to add invalid email address in email field of a new contact form
(Reporter)

Updated

4 years ago
Whiteboard: [2.1-FC-bug-bash]
Whiteboard: [2.1-FC-bug-bash] → [2.1-bug-bash]
This is a new feature. Carrie, do we need to check the user's input in that case?
Flags: needinfo?(cawang)

Comment 2

4 years ago
Marcela, can you give us an example of the input that you wrote?
Flags: needinfo?(pensacola_m2000)
(Reporter)

Comment 3

4 years ago
(In reply to James from comment #2)
> Marcela, can you give us an example of the input that you wrote?

Sure, you can write anything in email address field. e.g fox and then save it. No error or warning message displayed informing the user that email address is invalid.
Flags: needinfo?(pensacola_m2000)

Updated

4 years ago
status-b2g-v2.1: --- → affected
This is a feature, but I wonder do we really need it? Because we need to consider that sometimes users have their own way to input things in Contacts and poping up a warning window is quite disturbing in this case. Hence, I'd say this is a nice-to-have feature and I don't think it's that urgent and necessary. Thanks!
Flags: needinfo?(cawang)

Updated

4 years ago
Severity: normal → enhancement

Comment 5

6 months ago
Firefox OS is not being worked on
Status: NEW → RESOLVED
Last Resolved: 6 months ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.