If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

[FTU][Language Select] Selected language is not properly indicated with check-mark

RESOLVED WORKSFORME

Status

Firefox OS
Gaia::First Time Experience
RESOLVED WORKSFORME
3 years ago
3 years ago

People

(Reporter: Marty, Assigned: sfoster)

Tracking

({regression})

unspecified
ARM
Gonk (Firefox OS)
regression

Firefox Tracking Flags

(b2g-v2.1 unaffected, b2g-v2.2 verified)

Details

(Whiteboard: [2.2-Daily-Testing])

Attachments

(1 attachment)

(Reporter)

Description

3 years ago
Created attachment 8510670 [details]
Language_Screenshot.png

Description:
In the first screen of the FTU, the selected language is not indicated by a check-mark. The text for many of the languages does not bold when selected, the missing check-mark means that there is no indication at all which language is currently selected.

Note: If the user selects a 'Right to Left' language, the check-mark will reappear over top the language name, on the right of the screen.

Repro Steps:
1) Update a Flame device to BuildID: 20141023040204
2) In the FTU, select several of the language options.
  
Actual:
There is no check-mark symbol indicating what language is currently selected.
  
Expected: 
There is a check mark symbol indicating what language is currently selected.
  
Environmental Variables:
Device: Flame 2.2 Master (319MB)
BuildID: 20141023040204 (Full Flash)
Gaia: 27a1d1baaa8e375b70e043efee67d5f2206c330b
Gecko: 88adcf8fef83
Gonk: 05aa7b98d3f891b334031dc710d48d0d6b82ec1d
Version: 36.0a1 (2.2 Master)
Firmware: V188
User Agent: Mozilla/5.0 (Mobile; rv:36.0) Gecko/36.0 Firefox/36.0

  
Repro frequency: 4/4
See attached: screenshot

------------------------------------------------------------

This issue does NOT occur on Flame 2.1.
There is a check mark symbol indicating what language is currently selected.

Environmental Variables:
Device: Flame 2.1
BuildID: 20141023001201
Gaia: 1e48e3e40e0780c0cd07a3457e5fe2efeeb542d1
Gecko: 09fb60a37850
Gonk: 05aa7b98d3f891b334031dc710d48d0d6b82ec1d
Version: 34.0 (2.1)
Firmware: V188
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0
(Reporter)

Updated

3 years ago
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(pbylenga)
[Blocking Requested - why for this release]:
Bad UX regression with high visibility.  User should be able to easily tell which language is selected, not all languages utilize fonts with bolding.

requesting a window
blocking-b2g: --- → 2.2?
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(pbylenga)
Keywords: regression, regressionwindow-wanted
QA Contact: jmitchell
(Assignee)

Comment 2

3 years ago
I'm taking a look into this. Interested to see the regression window as there's been no changes to the stylesheet or languages.js that build this control between v2.1 and current master. However, the checkmark is clearly there on v2.1
Assignee: nobody → sfoster
Central Regression Window:

Last Working:
Device: Flame 2.2
Build ID: 20141010183447
Gaia: cc5da7b055e2b06fdeb46fa94970550392ee571d
Gecko: 708b45d9b1b1
Version: 35.0a1 (2.2)
Firmware Version: v188
User Agent: Mozilla/5.0 (Mobile; rv:35.0) Gecko/35.0 Firefox/35.0

First Broken:
Device: Flame 2.2
Build ID: 20141010185447
Gaia: 95f580a1522ffd0f09302372b78200dab9b6f322
Gecko: 999ad2f1e108
Version: 35.0a1 (2.2)
Firmware Version: v188
User Agent: Mozilla/5.0 (Mobile; rv:35.0) Gecko/35.0 Firefox/35.0

Gaia/Gecko Swap
Last Working Gaia First Broken Gecko: Issue Does NOT reproduce
Gaia: cc5da7b055e2b06fdeb46fa94970550392ee571d
Gecko: 999ad2f1e108
First Broken Gaia Last Working Gecko: Issue DOES reproduce
Gaia: 95f580a1522ffd0f09302372b78200dab9b6f322
Gecko: 708b45d9b1b1

Gaia pushlog: https://github.com/mozilla-b2g/gaia/compare/cc5da7b055e2b06fdeb46fa94970550392ee571d...95f580a1522ffd0f09302372b78200dab9b6f322

---------------------------------------------------------------------------------

B2G-Inbound Regression Window:

Last Working:
Device: Flame 2.2
Build ID: 20141010062306
Gaia: f4451c52a0947a561abc0b1d42a39e3068768ad8
Gecko: 5a432ef3804b
Version: 35.0a1 (2.2)
Firmware Version: v188
User Agent: Mozilla/5.0 (Mobile; rv:35.0) Gecko/35.0 Firefox/35.0

First Broken:
Device: Flame 2.2
Build ID: 20141010065708
Gaia: f81d4c5099ebfeed5450b1db9267a01ddabcfa81
Gecko: 8e904b0ab3e8
Version: 35.0a1 (2.2)
Firmware Version: v188
User Agent: Mozilla/5.0 (Mobile; rv:35.0) Gecko/35.0 Firefox/35.0


Gaia/Gecko Swap
Last Working Gaia First Broken Gecko: Issue does NOT reproduce
Gaia: f4451c52a0947a561abc0b1d42a39e3068768ad8
Gecko: 8e904b0ab3e8
First Broken Gaia Last Working Gecko: Issue DOES reproduce
Gaia: f81d4c5099ebfeed5450b1db9267a01ddabcfa81
Gecko: 5a432ef3804b

Gaia pushlog: https://github.com/mozilla-b2g/gaia/compare/f4451c52a0947a561abc0b1d42a39e3068768ad8...f81d4c5099ebfeed5450b1db9267a01ddabcfa81
QA Whiteboard: [QAnalyst-Triage?]
Keywords: regressionwindow-wanted
QA Contact: jmitchell
Bug 1078904 seems to have caused this issue. Sam can you please take a look at this?
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(sfoster)
(Assignee)

Comment 5

3 years ago
Thanks for getting the regression window. Bug 1053708 made changes to the shared control which is used to render the language picker and seems a likely candidate for the regression. But... I cant reproduce the issue on today's master. The bolding of the selected language and checkmark look in all languages, including the pseudo mirrored english language. I don't see anything in the git log in ./shared/style that would have fixed it in the last few days. There was bug 1082494 that got merged several days ago, could be that? Either way, if you can confirm it is un-regressed, we can close as works-for-me.
Flags: needinfo?(dharris)
(Assignee)

Comment 6

3 years ago
clearing flag.
Flags: needinfo?(sfoster)
I can confirm comment 5 - that this issue is un-regressed.

closing as WFM per comment 5


Device: Flame 2.2
Build ID: 20141103040034
Gaia: bc168c17474dabbcceaa349e9bc7c95654435aec
Gecko: 5999e92e89ff
Gonk: 48835395daa6a49b281db62c50805bd6ca24077e
Version: 36.0a1 (2.2)
Firmware Version: v188
User Agent: Mozilla/5.0 (Mobile; rv:36.0) Gecko/36.0 Firefox/36.0
Status: NEW → RESOLVED
Last Resolved: 3 years ago
status-b2g-v2.2: affected → verified
Flags: needinfo?(dharris)
Resolution: --- → WORKSFORME
blocking-b2g: 2.2? → ---
You need to log in before you can comment on or make changes to this bug.