If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Very few Statusbar icons display when opening smart collection

VERIFIED FIXED in Firefox OS v2.1

Status

Firefox OS
Gaia::System
VERIFIED FIXED
3 years ago
3 years ago

People

(Reporter: mikehenrty, Assigned: kgrandon)

Tracking

unspecified
2.1 S8 (7Nov)
ARM
Gonk (Firefox OS)

Firefox Tracking Flags

(blocking-b2g:2.1+, b2g-v2.1 verified, b2g-v2.2 verified)

Details

(Whiteboard: [2.1-bug-bash] [systemsfe])

Attachments

(2 attachments)

Created attachment 8510765 [details]
[screenshot]

Build Information
Gaia-Rev        1e48e3e40e0780c0cd07a3457e5fe2efeeb542d1
Gecko-Rev       https://hg.mozilla.org/releases/mozilla-b2g34_v2_1/rev/09fb60a37850
Build-ID        20141023001201
Version         34.0
Device-Name     flame
Base image:     188


Description
When opening e.me, only a few icons display. Oddly, it only seems to happen after opening several browser windows.

Steps to Reproduce
1.) Open the browser, navigate to cnn.com
2.) Long press on a link, and open it in a new tab
3.) From here, long press on a link and open it in a new tab
4.) Press the home button
5.) Immediately open a smart collection


Expected Results
Statusbar icons should fill up the statusbar.


Actual Results
Only a couple icons show up in the statusbar, see screenshot.


Reproduction Frequency: 100%
Broken feature.
blocking-b2g: --- → 2.1+
Whiteboard: [2.1-FC-bug-bash] → [2.1-FC-bug-bash][systemsfe]
Target Milestone: --- → 2.1 S8 (7Nov)
Guillaume, can you take a look here?
Flags: needinfo?(gmarty)
Whiteboard: [2.1-FC-bug-bash][systemsfe] → [2.1-bug-bash]
This is due to Bug 1087710.

But there is another problem: the maximised status bar should be displayed on smart collections. Currently we show the minimised one, even though there is no rocket bar here.

The CSS code is complex and I know from experience that changing it may have side effects, so redirecting to Kevin. Can we make sure the maximised status bar is always shown on smart collections?
Flags: needinfo?(gmarty) → needinfo?(kgrandon)
(Assignee)

Comment 4

3 years ago
I think we can also adjust the minimized statusbar width on activityopened. I'll take this one.
Assignee: nobody → kgrandon
Status: NEW → ASSIGNED
Flags: needinfo?(kgrandon)
(Assignee)

Comment 5

3 years ago
Created attachment 8512129 [details] [review]
Github pull request

Update minimized statusbar width for activityopened.
(Assignee)

Comment 6

3 years ago
Comment on attachment 8512129 [details] [review]
Github pull request

Guillaume - would you mind giving this a review?
Attachment #8512129 - Flags: review?(gmarty)
Comment on attachment 8512129 [details] [review]
Github pull request

Thanks Kevin, your patch fixes the issue.
However I can only give f+ as I'm not a peer/owner so redirecting r? to Etienne.
Attachment #8512129 - Flags: review?(gmarty)
Attachment #8512129 - Flags: review?(etienne)
Attachment #8512129 - Flags: feedback+
(Assignee)

Comment 8

3 years ago
(In reply to Guillaume Marty [:gmarty] from comment #7)
> Thanks Kevin, your patch fixes the issue.
> However I can only give f+ as I'm not a peer/owner so redirecting r? to
> Etienne.

Sure, though based on what we discussed on the mailing list recently, this is one of those cases where since you've done some work here, you should be able to review for a system peer. IMHO it saves everyone time in the long run, but no harm in re-directing to a peer. Thanks for taking a look.
Comment on attachment 8512129 [details] [review]
Github pull request

(In reply to Kevin Grandon :kgrandon from comment #8)
> (In reply to Guillaume Marty [:gmarty] from comment #7)
> > Thanks Kevin, your patch fixes the issue.
> > However I can only give f+ as I'm not a peer/owner so redirecting r? to
> > Etienne.
> 
> Sure, though based on what we discussed on the mailing list recently, this
> is one of those cases where since you've done some work here, you should be
> able to review for a system peer. IMHO it saves everyone time in the long
> run, but no harm in re-directing to a peer. Thanks for taking a look.

+1, when a system peer sends/redirects you a review you can totally grant the review.
That's how we make new peers ;)
Attachment #8512129 - Flags: review?(etienne) → review+
(Assignee)

Comment 10

3 years ago
Thanks for the review.

In master: https://github.com/mozilla-b2g/gaia/commit/13b0ac34a06237a544615c72ec208572be83c821
Status: ASSIGNED → RESOLVED
Last Resolved: 3 years ago
status-b2g-v2.1: --- → affected
status-b2g-v2.2: --- → fixed
Resolution: --- → FIXED
(Assignee)

Comment 11

3 years ago
Comment on attachment 8512129 [details] [review]
Github pull request

[Approval Request Comment]
[Bug caused by] (feature/regressing bug #): v2.1 feature implementation.
[User impact] if declined: Less than ideal experience when opening smart collections as icons in the statusbar will disappear.
[Testing completed]: Manual and a simple unit test.
[Risk to taking this patch] (and alternatives if risky): Low risk, basically a one-liner with a test.
[String changes made]: None.
Attachment #8512129 - Flags: approval-gaia-v2.1?(fabrice)

Updated

3 years ago
Attachment #8512129 - Flags: approval-gaia-v2.1?(fabrice) → approval-gaia-v2.1+
v2.1: https://github.com/mozilla-b2g/gaia/commit/3701d5cfc19085598e321607fe3c210ffaf1ce0e
status-b2g-v2.1: affected → fixed
Issue verified fixed on Flame 2.1 and Flame 2.2

Actual Results: Expected amount of icons appear in status bar

Device: Flame 2.1 (319mb)(Kitkat Base)(Full Flash)
BuildID: 20141031001201
Gaia: f89c7b12c36572262c9ea76058694a139b1a8634
Gecko: 50d48f8a04c7
Gonk: 48835395daa6a49b281db62c50805bd6ca24077e
Version: 34.0 (2.1)
Firmware: V188
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0

Device: Flame 2.2 Master (319mb)(Kitkat Base)(Full Flash)
BuildID: 20141031061804
Gaia: a07994714f0552f89801d6097982308d8b0a1ee1
Gecko: 6bd2071b373f
Gonk: 48835395daa6a49b281db62c50805bd6ca24077e
Version: 36.0a1 (2.2) 
Firmware Version: v188
User Agent: Mozilla/5.0 (Mobile; rv:36.0) Gecko/36.0 Firefox/36.0
Status: RESOLVED → VERIFIED
QA Whiteboard: [QAnalyst-Triage?]
status-b2g-v2.1: fixed → verified
status-b2g-v2.2: fixed → verified
Flags: needinfo?(ktucker)
Whiteboard: [2.1-bug-bash] → [2.1-bug-bash] [systemsfe]
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(ktucker)
You need to log in before you can comment on or make changes to this bug.