Add automated tests for "Browse http/https and ftp websites with different settings"

RESOLVED WONTFIX

Status

defect
RESOLVED WONTFIX
5 years ago
7 days ago

People

(Reporter: mihaelav, Unassigned)

Tracking

Version 2
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

1. Open Firefox and browse some http/https, ftp websites. (eg: ftp://ftp.mozilla.org/ http://www.gnu.org/prep/ftp.html http://ftp.mozilla.org/ https://ftp.mozilla.org/ )
 - The browsing goes smooth
2. Go to Options (Preferences) /Advanced/Network/Settings
3. Check ‘Manual proxy configuration’ option
4. Write a HTTP proxy (eg. IP: 62.253.249.48) and Port (eg. Port: 8080), then hit Ok
   (Here is a list of free proxy servers http://www.hidemyass.com/proxy-list/ For a faster browsing experience choose a proxy from your country. There may be some proxy servers that will not work, if you encounter one of those simply choose another one)
5. Browse some http/https, ftp websites. (eg: ftp://ftp.mozilla.org/ http://www.gnu.org/prep/ftp.html http://ftp.mozilla.org/ https://ftp.mozilla.org/ )
 - The browsing goes smooth
6. Go to Options (Preferences) /Advanced/Network/Settings
7. Check ‘Automatic proxy configuration URL:’ option
8. Fill in the path of ‘proxy.pac’ file and hit Ok (eg: C:\Users\Name\Desktop\proxy.pac)
9. Edit using Notepad/Gedit/TextEditor the file and replace the IP and Port with one that works fine ("PROXY 37.59.81.65:3128" | where 37.59.81.65 is the IP and 3128 is the PORT)
   (Here is a list of free proxy servers http://www.hidemyass.com/proxy-list/ For a faster browsing experience choose a proxy from your country. There may be some proxy servers that will not work, if you encounter one of those simply choose another one)
10. Browse some http/https, ftp websites (eg: ftp://ftp.mozilla.org/ http://www.gnu.org/prep/ftp.html http://ftp.mozilla.org/ https://ftp.mozilla.org/ )
 - The browsing goes smooth

Moztrap test: https://moztrap.mozilla.org/manage/case/11509/

Note: this is a test from the manual Regression suite
We won't use any free proxy for our tests. Please see bug 1060624 for a proxy setup by ourselves which can reach mozqa.com for testing. This bug will be blocked on it. Also all remote pages should be loaded from mozqa.com
Depends on: 1060624
Depends on: 917204
No longer depends on: 1060624
Moving to Firefox UI tests since Mozmill is being dropped out.
Component: Mozmill Tests → Firefox UI Tests
Product: Mozilla QA → Testing

There was no more request for getting those tests added, and ftp is not really an option anymore. Also Firefox UI tests are going away soon.

Status: NEW → RESOLVED
Closed: 7 days ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.