[AppPermissions]Very hard to click "Hide info" to contract the info.

VERIFIED FIXED in Firefox OS v2.1

Status

VERIFIED FIXED
4 years ago
4 years ago

People

(Reporter: mlien, Assigned: mancas)

Tracking

unspecified
2.1 S8 (7Nov)
ARM
Gonk (Firefox OS)

Firefox Tracking Flags

(blocking-b2g:2.1+, b2g-v2.1 verified, b2g-v2.2 verified)

Details

(Whiteboard: [2.1-bug-bash] )

Attachments

(1 attachment)

(Reporter)

Description

4 years ago
Build Information
Gaia-Rev        0f76e0baac733cca56d0140e954c5f446ebc061f
Gecko-Rev       https://hg.mozilla.org/releases/mozilla-b2g34_v2_1/rev/7d78ff7d25b6
Build-ID        20141023161200
Version         34.0
Device-Name     flame
FW-Release      4.4.2
FW-Incremental  39
FW-Date         Thu Oct 16 18:19:14 CST 2014
Bootloader      L1TC00011880

Description
Click "More info" to expand information then click "Hide info" to contract cannot work


Reproduce Steps
1. Launch any app which has app permissions
2. Click "More info" to expand information
3. Click "Hide info" to contract information

Expected Results
Expand and contract information can work normally

Actual Results
Click "Hide info" to contract information almost doesn't work

Reproduction Frequency: 
90%
Whiteboard: [2.1-FC-bug-bash] → [2.1-bug-bash]

Updated

4 years ago
blocking-b2g: --- → 2.2?
(Assignee)

Updated

4 years ago
Assignee: nobody → b.mcb
(Assignee)

Comment 1

4 years ago
Created attachment 8517967 [details] [review]
Proposed patch

Hey Kevin, the problem was a duplicate event so when the user try to tap 'hide more info', the method |toggleInfo| is called twice and it seemed to have no effect.

Also, I've added a unit test for this case.

Thanks!
Attachment #8517967 - Flags: review?(kgrandon)
(Assignee)

Updated

4 years ago
Blocks: 1088592
Comment on attachment 8517967 [details] [review]
Proposed patch

This is working very nicely now. Thanks!
Attachment #8517967 - Flags: review?(kgrandon) → review+
In master: https://github.com/mozilla-b2g/gaia/commit/dfa5465d9c817973a0a67a191756dc5393b997a9
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
blocking-b2g: 2.2? → ---
(Reporter)

Comment 4

4 years ago
set blocking-b2g: 2.1? to see if this should upplift to v2.1
blocking-b2g: --- → 2.1?

Comment 5

4 years ago
taking for blocking 2.1+.  please request approval for uplift.
blocking-b2g: 2.1? → 2.1+
Flags: needinfo?(kgrandon)
Comment on attachment 8517967 [details] [review]
Proposed patch

[Approval Request Comment]
[Bug caused by] (feature/regressing bug #): Not sure, maybe feature implementation?
[User impact] if declined: Poor UX with permission dialogs.
[Testing completed]: Manual and unit test.
[Risk to taking this patch] (and alternatives if risky): I think it's pretty low risk, it's a small self-contained patch in a single file.
[String changes made]: None.
Flags: needinfo?(kgrandon)
Attachment #8517967 - Flags: approval-gaia-v2.1?

Comment 7

4 years ago
Verified the issue is fixed on Flame 2.2

"More info" and "Hide info" button is easily can be tapped and information can be revealed or hidden

"Flame 2.2

Device: Flame 2.2 Master (319mb)(Kitkat Base)(Full Flash)
Build ID: 20141222040204
Gaia: ca6e91e09ef3ab417a0f6b6d6668d43597d85700
Gecko: b915a50bc6be
Gonk: e5c6b275d77ca95fb0f2051c3d2242e6e0d0e442
Version: 37.0a1 (2.2)
Firmware Version: v188-1
User Agent: Mozilla/5.0 (Mobile; rv:37.0) Gecko/37.0 Firefox/37.0"
==================================================================
Adding "verifyme" for 2.1 patch uplift
Status: RESOLVED → VERIFIED
QA Whiteboard: [QAnalyst-Triage?]
status-b2g-v2.2: --- → verified
Flags: needinfo?(ktucker)
Keywords: verifyme

Updated

4 years ago
Attachment #8517967 - Flags: approval-gaia-v2.1? → approval-gaia-v2.1+
v2.1: https://github.com/mozilla-b2g/gaia/commit/8da9c72b17a642c166ac1fc1d6d0a403625f98a3
status-b2g-v2.1: --- → fixed
Target Milestone: --- → 2.1 S8 (7Nov)

Comment 9

4 years ago
This issue has been verified successfully on Flame 2.1
Reproducing rate: 0/10

Flame 2.1 build:
Gaia-Rev        73be51f998031f06db0cd660c0e388fa621c9f4c
Gecko-Rev       https://hg.mozilla.org/releases/mozilla-b2g34_v2_1/rev/05dd053f1d90
Build-ID        20150103001211
Version         34.0
status-b2g-v2.1: fixed → verified
(Reporter)

Updated

4 years ago
Keywords: verifyme
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(ktucker)
You need to log in before you can comment on or make changes to this bug.