Clicking on a link in the terms/privacy policy pages during Create Pin loads a blank screen

RESOLVED WONTFIX

Status

Marketplace
Payments/Refunds
P3
normal
RESOLVED WONTFIX
3 years ago
2 years ago

People

(Reporter: krupa, Unassigned)

Tracking

({papercut})

x86
Gonk (Firefox OS)
papercut
Points:
---

Details

Attachments

(1 attachment)

(Reporter)

Description

3 years ago
Created attachment 8511090 [details]
screenshot.png

Connectivity: wifi
SIM used:
Gaia/device: 2.1/Flame

steps to reproduce:
1. Search for :paid
2. Start the purchase of a flow
3. In the Create a PIN screen, click on the Terms link
4. In the Terms page, click on one of the links
 
observed behavior:
Assignee: nobody → scolville
Keywords: papercut
Priority: -- → P3
Here's a demo of how preventing clicks might work. http://jsbin.com/vupih/1/

Will see how it goes implementing something similar on Spartacus.
We can't fix this in Spartacus in a sane way mainly due to not being able to scroll the terms unless we apply some arbitrarily large height to the iframe so it overflows a container.

I think we are going to need to update/remove the links in the terms or add some JS so that the links don't work in the iframed content rather than try and tackle this from the SPA side.
Talking in the stand-up it sounds like the best approach is going to be to generate the terms + pp sans links special casing the Payment iframe. 

However, if we think this is going to go away (e.g. we're going to lose the trusted-ui at some point) then we might want to consider waiting for that because iframing these pages will then be unecesary.
Assignee: scolville → nobody

Comment 4

2 years ago
Based on the recently announced future plans for the Marketplace to remove payments, closing these bugs.
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.