Adobe pdf viewing broken in Firefox 33.0 on MacOS 10.9.5

RESOLVED DUPLICATE of bug 1083740

Status

()

Firefox
Untriaged
--
major
RESOLVED DUPLICATE of bug 1083740
3 years ago
3 years ago

People

(Reporter: D Link, Unassigned)

Tracking

33 Branch
x86
Mac OS X
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

3 years ago
User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.9; rv:32.0) Gecko/20100101 Firefox/32.0
Build ID: 20140923175406

Steps to reproduce:

Logged in to Consolidated/Surewest to view my monthly bill. PDF of bill did not appear, telling me to use an alternate pdf viewer. I tried saving the bill, rather than viewing, but this did not help either, showing error: "aspx.part could not be saved, because the source file could not be read."
I was able to view the bill in Safari, so I downgraded Firefox from 33.0 to 32.0.3. IT WORKS AGAIN! 


Actual results:

No ability to view or save pdf while using Firefox at Consolidated/Surewest website. I did not check other websites.


Expected results:

Monthly pdf of bill should have appeared on screen, using Adobe pdf online viewer plug-in, but it was blank. I clicked the download button, but it failed (nothing to download).
(Reporter)

Updated

3 years ago
Severity: normal → major
Status: UNCONFIRMED → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1083740
This is the story behind the issue.
When you start to access a page on a server, the server reports the size of the following data to Firefox.
The data can be a html page or a pdf file.

In your example the server reports a wrong size of the data. For example it tells Firefox that the data is 10KB and then it sends only 8KB data.
Firefox ignored this wrong size until Firefox33 but that can lead to incomplete downloads.
You want to download for example a 4GB File and you get a network error in the middle and end with a 2GB file.

What can you do ?
You should complain to surewest that they have a problem with their server for PDF downloads.
it seems the additional error check that caused this issue will be changed in bug 1088850 and that would fix this bug for you.
You need to log in before you can comment on or make changes to this bug.