Select correct server for <news:msg-id> URLs

NEW
Unassigned

Status

MailNews Core
Networking: NNTP
--
enhancement
17 years ago
8 years ago

People

(Reporter: BenB, Unassigned)

Tracking

(Depends on: 3 bugs, Blocks: 1 bug)

Dependency tree / graph
Bug Flags:
blocking1.3b -

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

17 years ago
Support URLs of type <news:msg-id>, like <news:3BE8FDB2.2050705@logic.univie.ac.at>.

(E.g., try to enter them in the urlbar of the browser, should then also work for
Mailnews standalone msg windows.) We already support them for
<news://server:port/msg-id>, e.g.
<news://news.t-online.de/3BE8FDB2.2050705@logic.univie.ac.at>.
(Reporter)

Updated

17 years ago
Depends on: 108876

Comment 1

17 years ago
Stephend, is this in the common RFCs or specs?
(Reporter)

Comment 2

17 years ago
Yes.
Dup of "URI-parser fails for news:3B48D5FC.3030004@sc.rr.com"

*** This bug has been marked as a duplicate of 89939 ***
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE
verified dup.
Status: RESOLVED → VERIFIED
(Reporter)

Comment 5

17 years ago
No dup. The other bug is about the parser only (which I assumed does work
already). This bug is mainly to ensure that we select the right server (using
bug 108876). Maybe, if all deps are resolved, nothing is left here, but then we
should at least verify that it works. OTOH, there might need to be some glue
code to make it work together. REOPENing.
Status: VERIFIED → REOPENED
Depends on: 89939
Resolution: DUPLICATE → ---

Updated

17 years ago
Status: REOPENED → ASSIGNED
Target Milestone: --- → mozilla1.2

Comment 6

16 years ago
*** Bug 148659 has been marked as a duplicate of this bug. ***
(Reporter)

Updated

16 years ago
Depends on: 37653

Comment 7

16 years ago
What's the status of this bug ?

Comment 8

16 years ago
It still does not work. My suggestion for a solution while we wait on the
dependencies is to use the servers in the order they are listed until we succeed.

Later, if we have the dependencies solved we should:
a) Retrieve from msg-store if available, else
b) Retrieve from default server if available, else
c) Retrieve from the other servers in the order they are listed as above.

I suggest to move the target milestone from the past to whatever and get it going;-)

pi

Comment 9

16 years ago
The support of very basic URLs is really needed. Requesting 1.3b blocking.

pi
Flags: blocking1.3b?

Updated

16 years ago
Flags: blocking1.3b? → blocking1.3b-

Updated

15 years ago
Depends on: 11076

Updated

14 years ago
Blocks: 11076
No longer depends on: 11076
(Reporter)

Updated

14 years ago
No longer blocks: 11076

Updated

14 years ago
Depends on: 11076
Product: MailNews → Core

Comment 10

14 years ago
Updating summary per comment 5.
Summary: Support <news:msg-id> URLs → Select correct server for <news:msg-id> URLs

Comment 11

14 years ago
*** Bug 209011 has been marked as a duplicate of this bug. ***

Updated

13 years ago
Blocks: 311906

Updated

13 years ago
No longer blocks: 311906

Updated

11 years ago
Assignee: sspitzer → nobody
Status: ASSIGNED → NEW
QA Contact: stephend
Target Milestone: mozilla1.2alpha → ---
Switching out duped dep
No longer depends on: 108876
QA Contact: networking.news
(Assignee)

Updated

10 years ago
Product: Core → MailNews Core
(Reporter)

Comment 13

9 years ago
<http://www.apps.ietf.org/rfc/rfc1738.html> Section 3.6
<http://tools.ietf.org/html/draft-ellermann-news-nntp-uri-11#section-2.1>

Note: "news:" is *not* the same as "nntp:". It's completely different, and handling them the same is a bug.
You need to log in before you can comment on or make changes to this bug.