window.open ignores width and height

VERIFIED DUPLICATE of bug 29856

Status

()

Core
JavaScript Engine
VERIFIED DUPLICATE of bug 29856
17 years ago
17 years ago

People

(Reporter: Stanislav Malyshev, Assigned: rogerl (gone))

Tracking

Trunk
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

17 years ago
If I open a new window with javascript, like this:

 window.open("http://www.mozilla.org/", "test",
"toolbar=no,menubar=no,status=no,width=10,height=10");

the size parameters are ignored and window opens with size like the size of the
current window. This is reproduceable on: Mozilla/5.0 (X11; U; Linux i686;
en-US; rv:0.9.5) Gecko/20011012 (0.9.5 release).
(Reporter)

Comment 1

17 years ago
Created attachment 56885 [details]
Test-case - click and see window open with wrong size

Comment 2

17 years ago
works for me, 2001110612/linux.
1) could you try a recent nightly?
2) what windowmanager are you using / are there any Xresources for mozilla / etc?
(Reporter)

Comment 3

17 years ago
Sawfish window manager, no special resources for Mozilla. Will try nightly.
(Reporter)

Comment 4

17 years ago
Tried 2001110706 - same effect (new window opens with size of the browser
window, not 10x10). 
The default sawfish behavior is to override the app's desired size in some
circumstances.  This is one of those circumstances, because mozilla uses the
same window class for all its windows.



*** This bug has been marked as a duplicate of 29856 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE

Comment 6

17 years ago
Verified dupe. 

Note this is not a JavaScript Engine issue. JS Engine deals with the
abstract JavaScript programming language. Specifically, the objects
such as String(), Number(), and Date(). The JS Engine is not itself 
aware of browser or DOM objects like window, document, sockets, etc.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.