Closed Bug 1088864 Opened 5 years ago Closed 4 years ago

[Homescreen] User can bypass "Done" button when renaming a website that has been added to homescreen

Categories

(Firefox OS Graveyard :: Gaia::Homescreen, defect)

ARM
Gonk (Firefox OS)
defect
Not set

Tracking

(b2g-v2.0 unaffected, b2g-v2.1 affected, b2g-v2.2 affected)

RESOLVED WONTFIX
Tracking Status
b2g-v2.0 --- unaffected
b2g-v2.1 --- affected
b2g-v2.2 --- affected

People

(Reporter: SalvadorR, Unassigned)

References

Details

(Whiteboard: [2.1-exploratory-3][systemsfe])

Attachments

(3 files)

Attached image Overwrite done.png
Description: 
User can bypass the "Done" button by press enter when renaming a website that has been added to homescreen
   
Repro Steps:
1) Update a Flame device to BuildID: 20141024001204
2) Add a website to homescreen
3) Attempt to rename the website and dont put anything in the text field and hit "Return" on the keyboard
4) Observe
  
Actual:
User is able to bypass done button
  
Expected: 
Hitting return shouldn't allow you to proceed with name
  
Environmental Variables:
Device: Flame 2.1 KK Full Flash (319mb)
BuildID: 20141024001204
Gaia: 0f76e0baac733cca56d0140e954c5f446ebc061f
Gecko: 7d78ff7d25b6
Gonk: 05aa7b98d3f891b334031dc710d48d0d6b82ec1d
Version: 34.0 (2.1)
Firmware: V188
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0
  
Repro frequency: 5/5
See attached: Screenshot, logcat
Attached image Overwrite done.png
This issue also repros on Flame 2.2

Result: user can bypass "Done" by hitting return on keybaord

Flame 2.2

Environmental Variables:
Device: Flame Master (319mb)(KitKat Base)(FullFlash)
Build ID: 20141024040202
Gaia: d893a9b971a0f3ee48e5a57dca516837d92cf52b
Gecko: a5ee2769eb27
Version: 36.0a1 (Master)
Firmware Version: v188
User Agent: Mozilla/5.0 (Mobile; rv:36.0) Gecko/36.0 Firefox/36.0
---------------------------------------------------------------------
This issue does not repro on Flame 2.2

Result: User can't bypass "Done" button with return on keyboard

Flame 2.0

Environmental Variables:
Device: Flame 2.0  (319mb)(Kitkat Base)(Full Flash)
Build ID: 20141024000201
Gaia: 86d83f4b4111ca45ebc92ca779348cc966f43cff
Gecko: f8432250efb7
Version: 32.0 (2.0)
Firmware Version: v188
User Agent: Mozilla/5.0 (Mobile; rv:32.0) Gecko/32.0 Firefox/32.0
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(dharris)
Not nominating this as a blocker. It seems like it might be intended that pressing the return key would act as the "done" button, but this is a regression
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(dharris)
Mass update: Resolve wontfix all issues with legacy homescreens.

As of 2.6 we have a new homescreen and having these issues open is confusing. All issues will block bug 1231115 so we can use that to re-visit any of these if needed.
Blocks: 1231115
Status: NEW → RESOLVED
Closed: 4 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.