[Card view] Swiping to close a card not in the central position jumps the card to overlap the center

RESOLVED WORKSFORME

Status

RESOLVED WORKSFORME
4 years ago
3 years ago

People

(Reporter: rpribble, Unassigned)

Tracking

({regression})

unspecified
ARM
Gonk (Firefox OS)
regression

Firefox Tracking Flags

(b2g-v2.1 unaffected, b2g-v2.2 affected, b2g-v2.5 unaffected, b2g-master unaffected)

Details

(Whiteboard: [2.2-Daily-Testing] [systemsfe])

Attachments

(2 attachments)

(Reporter)

Description

4 years ago
Created attachment 8511286 [details]
Video.ogg

Description:
If there are multiple apps open in card view and one of the apps off to the side (not in the center of the view) is swiped up to close it, the card will be jumped to the center of the screen and will overlap the other cards as it slides upwwards.
   
Repro Steps:
1) Update a Flame device to BuildID: 20141024040202
2) Open multiple apps
3) Enter card view
4) Touch one of the apps on the right of left side of the viewing area and swipe it up to close it
5) Observe the card jump to the center of the card view and overlap with the others
   
Actual:
Cards that are swiped to close from the sides of the card view jump to the center and overlap.
  
Expected: 
The card swipes up to close just as it would while in the center position.
  
Environmental Variables:
Device: Flame 2.2 Master KK (319 MB)
BuildID: 20141024040202 (full flash)
Gaia: d893a9b971a0f3ee48e5a57dca516837d92cf52b
Gecko: a5ee2769eb27
Gonk: 05aa7b98d3f891b334031dc710d48d0d6b82ec1d
Version: 36.0a1 (2.2 Master)
Firmware: V188
User Agent: Mozilla/5.0 (Mobile; rv:36.0) Gecko/36.0 Firefox/36.0
  
Repro frequency: 5/5
See attached: Video, logcat
(Reporter)

Comment 1

4 years ago
Created attachment 8511287 [details]
Logcat.txt
(Reporter)

Updated

4 years ago
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(pbylenga)
Noticeable UX issue but could be seen as an unlikely use case.
Issue also appears unique to 2.2 as it's 'Card View' UI is different from that of 2.1; unable to manipulate non-centered cards in 2.1

**********************************************
Issue DOES NOT REPRO in 2.1 KK
Results: The center card may be swiped up to close; other's cannot be manipulated.

Environmental Variables:
----------------------------------------------
Device: Flame 2.1
BuildID: 20141028001203
Gaia: a0174f7166745256aaca1cb3aa9f894033fbffa6
Gecko: 43bda3541f6b
Gonk: 6e51d9216901d39d192d9e6dd86a5e15b0641a89
Version: 34.0 (2.1)
Firmware: V188
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0
----------------------------------------------
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
status-b2g-v2.1: --- → unaffected
Flags: needinfo?(pbylenga)
Keywords: regression
Whiteboard: [2.2-Daily-Testing] → [2.2-Daily-Testing] [systemsfe]
This issue also occurs in 3.0 

Environmental Variables:
Device: Flame Master (Flame KK, Full Flash, 319 mem)
Build ID: 20150319010201
Gaia: c39e15f631de80c69467fda0d4ea0bcda9e194ca
Gecko: cf1060d8ce9f
Gonk: b83fc73de7b64594cd74b33e498bf08332b5d87b
Version: 39.0a1 (Master)
Firmware Version: v188-1
User Agent: Mozilla/5.0 (Mobile; rv:39.0) Gecko/39.0 Firefox/39.0
status-b2g-master: --- → affected

Comment 4

3 years ago
Close this bug since unable to reproduce both on 2.5 and master(2.6).

2.5:
Build ID               20151110094039
Gaia Revision          07baf613699fa6225359c7f04825c5caeb71d424
Gaia Date              2015-11-09 21:32:50
Gecko Revision         http://hg.mozilla.org/releases/mozilla-b2g44_v2_5/rev/e14287b00a514a15418dfaa89287030c588ad19d
Gecko Version          44.0a2
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.worker.20151110.090006
Firmware Date          Tue Nov 10 09:00:15 UTC 2015
Bootloader             L1TC000118D0

master(2.6):
Build ID               20160115005446
Gaia Revision          113afdb919093dd517ce464a3f014c4baa87250f
Gaia Date              2016-01-15 00:16:49
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/9a358be6fa798f24deecac1b502742b2c37cd6bd
Gecko Version          46.0a1
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.worker.20160115.011813
Firmware Date          Fri Jan 15 01:18:25 UTC 2016
Bootloader             L1TC000118D0
Status: NEW → RESOLVED
Last Resolved: 3 years ago
status-b2g-v2.5: --- → unaffected
status-b2g-master: affected → unaffected
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.