Firefox scrolling is really slow while displaying SVG

RESOLVED WORKSFORME

Status

()

RESOLVED WORKSFORME
4 years ago
2 years ago

People

(Reporter: inscription, Unassigned)

Tracking

36 Branch
x86_64
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

4 years ago
User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:36.0) Gecko/20100101 Firefox/36.0
Build ID: 20141024080300

Steps to reproduce:

Firefox Nightly 64 bits on linux Mint 17, e10S disabled.
go on http://kartograph.org/showcase/italia/


Actual results:

The loading of the map is slow, but even worst : when the map is properly displayed the scrolling is really slow. Moreover, the animations on the map are really jerky.


Expected results:

When the map is fully rendered, the scrolling and the animations on it should be smooth.

It's not the first time I noticed performances issues on FF when it comes to SVG, that's why I decided to fill this bug
(Reporter)

Updated

4 years ago
Component: Untriaged → SVG
Product: Firefox → Core

Comment 1

3 years ago
Created attachment 8583050 [details]
slow_svg_profile.json

I have the same result on this article : http://www.lemonde.fr/politique/article/2015/03/24/departementales-l-alliance-front-de-gauche-europe-ecologie-les-verts-a-t-elle-fonctionne_4599573_823448.html

Scrolling is only slow when the svg map is visible.

The attached file is a profile recorded during scroll.
Best if you create your own bug Jean. Your example is slow on Mac whereas the comment 0 testcase is not.
(Reporter)

Comment 3

3 years ago
Maybe I should mark this bug as resolved, because this test case is running way better nowadays (maybe not completely smoothly, but at least it doesn't look really buggy anymore). What do you think Robert ?
As you raised it, it's up to you, feel free to close it as WORKSFORME if you wish.

Comment 5

2 years ago
WFM per comment 3
Status: UNCONFIRMED → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.