Closed Bug 1088940 Opened 8 years ago Closed 8 years ago

Update to Firefox V.33.0 breaks (among others) PayPal pages

Categories

(Core :: Networking: HTTP, defect)

33 Branch
x86_64
Windows 7
defect
Not set
major

Tracking

()

RESOLVED FIXED

People

(Reporter: karl.riedling, Unassigned)

References

Details

(Keywords: regression)

Attachments

(1 file)

Attached image Firefox Bug.jpg
User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:33.0) Gecko/20100101 Firefox/33.0
Build ID: 20141011015303

Steps to reproduce:

I was in the course of improving a PayPal payment function of an online shop. For the checkout operation, the shop's pages prepare a call to a PayPal page (in my case, since this was a test, https://www.sandbox.paypal.com) and redirect to a certain PayPal page. What is supposed to appear on the screen is shown in the upper part of the enclosed image, which I have obtained with Opera. Exactly like that was the result up to Firefox 32.x. With Firefox 33.0, the resulting page is totally garbled, as shown in the lower part of the picture. I happened to experience the effect live on one of my machines: It was still running 32.x and displayed the PayPal page properly. While it was doing so, Firefox updated to 33.0, and the result was the unusable page shown in the bottom of the enclosed image.


Actual results:

Upon update from V.32.x to V33.0, certain pages are no more correctly displayed. I noticed this fact with online payment pages supplied by PayPal, which were properly displayed with V32.x but are a mess with V33.0. Firefox reports a number of JavaScript errors with the broken pages which definitely were not there when the page was displayed with V32.x. (I could test that with the above mentioned machine which immediately afterwards was upgraded to V33.0.)


Expected results:

It would have been really nice if pages that have worked almost for ages with various versions of Firefox would continue to do so upon an upgrade! That buggy V33.0 has cost me several frustrating hours of newly installing Firefox...
Severity: normal → major
I just did a paypal checkout with Firefox33 and didn't observe and layout issues.
We had also no other reports about an issue with paypal (AFAIK).

What is entirely missing in your bug report is that there are no steps to reproduce and we can not proceed without.
Flags: needinfo?(karl.riedling)
Sorry, you are right: I should have supplied some test code. I had thought, though, that the problem would show on a major part of the PayPal pages, which obviously was a mistake.

I have installed a small script on a test server now which should demonstrate the problem:

http://test.riedling.at/test_curl_shop_demo.php

The above script creates a link which leads to the PayPal page in question. Invoke the script and click on the link with various browsers! (You must execute the script to receive a valid link; the link lives only for a few minutes.)
Flags: needinfo?(karl.riedling)
Last good revision: 80431d4fd0da (2014-06-16)
First bad revision: bb35d1b73634 (2014-06-17)
Pushlog:
https://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=80431d4fd0da&tochange=bb35d1b73634

I suspect bug 237623 
that fix would cause issues if there is a server bug somewhere. I will do a inbound regression range search and local builds (which takes 1h) to find the exact checkin that is causing this
Status: UNCONFIRMED → NEW
Ever confirmed: true
Product: Firefox → Core
confirmed with a local build that this is caused by bug 237623 and that means that this report is probably invalid but will be fixed with bug 1088850
Blocks: 237623
Component: Untriaged → Networking: HTTP
Keywords: regression
I just got an update to 33.0.1; however, the problem still persists (see http://test.riedling.at/test_curl_shop_demo.php)
www.sandbox.paypal.com is applying a gzip'd encoding to /MERCHANTPAYMENTWEB-640-20141004-1/css/core/xptdev.css which shrinks the document from 1532 bytes to 659.

Unfortunately they send a content-length of 1532, which is a non compliant HTTP response.

We'll try and work with this - see bug 1088850. But if you have paypal support contact it would be worth pointing them at this bug so they can fix their server.
should be resolved byt 1088850
Depends on: 1088850
comment 7
Status: NEW → RESOLVED
Closed: 8 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.