Closed Bug 1089003 Opened 8 years ago Closed 8 years ago

e10s prompt is really hard to get

Categories

(Firefox :: General, defect)

34 Branch
x86_64
Linux
defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 1089008
Tracking Status
e10s m4+ ---

People

(Reporter: billm, Assigned: mconley)

Details

Monica and I were trying to figure out why we don't see an e10s prompt in nightly. There seem to be two problems:

1. Since bug 1076314, we require the channel to be "nightly". For developer builds it's "default". I don't really know how to change this. I imagine there must be a way, but it doesn't seem possible to change via prefs. Felipe, how did you manage to test?

2. Also since bug 1076314, we don't prompt if hardware acceleration is disabled. That means we're not prompting Linux users. This seems worth fixing to me since many of our developers run Linux and we especially want them to be testing e10s.
For #1, you can either change it through browser-prefs.js, or through MOZCONFIG with:
ac_add_options --enable-update-channel=nightly

#2 yeah, we should fix this. Bug 1076314 wasn't clear enough that it doesn't apply to linux, but now reading the commit message and the code that it landed, I see that linux is ok without HW accel.
(In reply to Bill McCloskey (:billm) from comment #0)
> Monica and I were trying to figure out why we don't see an e10s prompt in
> nightly. There seem to be two problems:
> 
> 1. Since bug 1076314, we require the channel to be "nightly". For developer
> builds it's "default". I don't really know how to change this. I imagine
> there must be a way, but it doesn't seem possible to change via prefs.
> Felipe, how did you manage to test?

As said before, I'd really prefer not to fix this, because being prompted on startup for the default ./mach run (which always creates a new profile) is really annoying.
Assignee: nobody → wmccloskey
Assignee: wmccloskey → mconley
We're default-enabled on Nightly now, so we don't show the doorhanger for any users (at least for now). A fresh build of m-c on my Linux VM shows us defaulting to e10s enabled, and we show the notification dropdown to say thanks for testing.

So what's the action here? Is there anything to do?
Flags: needinfo?(wmccloskey)
Bill should confirm, but I believe the consensus was to use morph this bug into "offer e10s for linux users even with hw-accel off" (i.e., part 2 from comment 0). But Jim already made this change in bug 1089008. So I guess this bug is ready to be closed!
Yeah, I agree.
Status: NEW → RESOLVED
Closed: 8 years ago
Flags: needinfo?(wmccloskey)
Resolution: --- → DUPLICATE
Duplicate of bug: 1089008
You need to log in before you can comment on or make changes to this bug.