Youtube video goes silent intermittently

RESOLVED WORKSFORME

Status

()

P5
normal
RESOLVED WORKSFORME
4 years ago
4 years ago

People

(Reporter: sicking, Unassigned)

Tracking

(Blocks: 1 bug)

unspecified
x86
Mac OS X
Points:
---

Firefox Tracking Flags

(firefox36+ disabled)

Details

(URL)

I've noticed this a few times the last couple of days or so. It seems to be happening intermittently, but I've been able to reproduce a few times with one video. Reloading the video and playing again seems to sometimes solve it.

Steps to reproduce:
1. Go to https://www.youtube.com/watch?v=PR0gwyZYZ_Q&list=PLjHf9jaFs8XUXBnlkBAuRkOpUJosxJ0Vx&index=5
2. The video should start playing automatically
3. Click somewhere around the 2-minute mark on the timeline
4. Wait for the video to reach 2:30
5. You may need to repeat from step 1 a few times.
6. There is no step 6.

Actual behavior
Audio goes quiet.

Expected behavior
Video and audio should play as normal.


There's definitely something weird happening with the video for me at the 2:30 minute mark. Many times the audio goes quiet. Other times the video just stops and displays the buffering spinner indefinitely.

Definitely not impossible that this is a problem on YouTube's end.
Oh, and I'm using tonight's (20141024) nightly on OSX Maverick. Built from https://hg.mozilla.org/mozilla-central/rev/d6abb9bf43be

Comment 2

4 years ago
Can you right click on the video, choose 'Stats for Nerds', and provide the details here? Is it using DASH for example? When you tried it a couple of days ago when it didn't work, did you have media source enabled then?

Comment 3

4 years ago
If you could also let us know if the video is using MP4/AAC or WebM/Vorbis (available from stats for nerds as well).
Flags: needinfo?(jonas)
It's using DASH yes. Mime type is 'video/webm; codecs="vp9"'
Flags: needinfo?(jonas)
I haven't manually enabled/disabled any video specific prefs. But I don't know exactly when it started happening. Possibly on thursday. But there's some uncertainty since I don't apply the nightly update every day, and I don't watch youtube every day.
Duplicate of this bug: 1091784
[Tracking Requested - why for this release]: Breaks YouTube, so seems like a blocker.
tracking-firefox36: --- → ?
I can reproduce it every time with the video from 1091784 at the 1:30 mark

Last good revision: 88adcf8fef83 (2014-10-23)
First bad revision: d6abb9bf43be (2014-10-24)
Pushlog:
https://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=88adcf8fef83&tochange=d6abb9bf43be

checkins for video/audio in that range:
Bug 1087810 , Bug 1055395 , Bug 1000686

it could be this checkin
Chris Double — Bug 1000686 - Enable Media Source Extensions on non-release builds - r=kentuckyfriedtakahe

maybe this bug is a dupe of bug 1089937 but in that report the video also stops unlike in this bug report
Lets track this if we determine the cause is Bug 1089937 we can dupe.
tracking-firefox36: ? → +
Duplicate of this bug: 1097336
Duplicate of this bug: 1097194
I can still reproduce this with 36.0a1 (2014-11-25) on Windows 8.1 x64.
Ralph, if the bug still occurs, could you help here? Thanks
Flags: needinfo?(giles)
We've disabled webm-dash for now, while we're concentrating on mp4-dash, so this shouldn't be a problem currently, and won't affect users of Firefox 36 in release.
Flags: needinfo?(giles)
OK. I am going to untrack it in 36 thanks.
status-firefox36: --- → disabled
Blocks: 778617
Priority: -- → P5
Are you still experiencing the issue?

AFAIK, all of those have been fixed
Flags: needinfo?(jonas)
Nope, I haven't seen this lately
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Flags: needinfo?(jonas)
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.