Upgrading from 2001101516 to current version defaults to Netscape 4 profiles instead of previous Mozilla ones.

VERIFIED WORKSFORME

Status

--
enhancement
VERIFIED WORKSFORME
17 years ago
14 years ago

People

(Reporter: donntarris, Assigned: slogan)

Tracking

Trunk
PowerPC
Mac OS X

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

17 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Macintosh; U; PPC Mac OS X; en-US; rv:0.9.5) Gecko/20011015
BuildID:    latest as of Wed Nov 7 at noon

This is not a bug (I don't think). I've been using 2001101516 for over three
weeks, in which case I get the message to download and install the latest one. I
realize that these are trial versions, but shouldn't the installer recognize the
fact that I had the 2001101516 build and grabbed things like the profiles and
bookmarks from that version's folder? Instead, it wants to grab this information
from an older copy of Netscape...

Reproducible: Always
Steps to Reproduce:
1.Have a version of 6.x Navigator installed with profiles and bookmarks
2.Load an older than 3 weeks version of Mozilla
3.Install the latest Mozilla from the site

Actual Results:  The install went alright and created a new folder (I renamed
the old one to save it... does this affect the upgrade process? I'll check and
see). When I went to open it, it asked me to open from profiles that were in
effect in Netscape 6.x instead?

Expected Results:  I would have liked it if the new Mozilla would search out the
older Mozilla build folder instead of automatically loading from Netscape.

Updated

17 years ago
QA Contact: bugzilla → ktrina

Comment 1

17 years ago
Donn,

When you did the second install (which was done correctly btw) what did you see 
in Profile Manager?  Did you see Netscape 4.x profiles with the 'need to 
migrate' icon? Did you see any of the profiles created with Mozilla build?

Mozilla and Netscape 5.x use the same profile registry and profile manager- but 
I am not clear what you are seeing

Comment 2

17 years ago
Donn, please give this bug a meaningful Summary.
(Reporter)

Comment 3

17 years ago
I put this under "enhancement" as I don't know if it's a bug in anyone else's
eyes. For me, it would make it frustrating to upgrade (as it has), in fact
making me go back to the last version for now... (which I have)
I attempted to move up one version about a month ago and the same thing
happened. I didn't have time to play with it then, so I just bailed on it,
coincidentally with the rebuild of my OS X 10.0.4 box.
I have modified the summary as per Greg's request.
Summary: Upgrading from 2001101516 to current → Upgrading from 2001101516 to current version defaults to Netscape 4 profiles instead of previous Mozilla ones.

Comment 4

17 years ago
Donn, can you still reproduce this problem under 0.9.6?
-> wfm (no response and the profile manager should pickup the current profile)
Status: UNCONFIRMED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → WORKSFORME

Comment 6

17 years ago
Verified WFM. Reporter, please reopen if problem still occurs.
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.