Closed Bug 1089349 Opened 8 years ago Closed 8 years ago

[sharedtest] /unit/l10n/lib/resolver/indexes_test.js and newer version chai

Categories

(Firefox OS Graveyard :: Gaia::L10n, defect)

defect
Not set
normal

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: sv99, Assigned: stas)

References

Details

Attachments

(1 file, 1 obsolete file)

46 bytes, text/x-github-pull-request
Details | Review
User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.9; rv:36.0) Gecko/20100101 Firefox/36.0
Build ID: 20141025030202

Steps to reproduce:

In Bug 1087973 fixed env.indexUncalledMacro not have function, but real error message 'Macro [object Object] expects 1 argument(s), yet 0 given' vs 'Macro plural expects 1 argument(s), yet 0 given' which tested!
Attached file Link to PR (obsolete) —
Attachment #8511638 - Flags: review?(stas)
Blocks: 1070047
Comment on attachment 8511638 [details] [review]
Link to PR

This will likely work, but I think that we should fix the error message instead.  I'll have a patch in a second.
Attachment #8511638 - Flags: review?(stas) → review-
Attached file Fix the error message
So I think this should fix it, although I'm still not able to reproduce the original bug.  sv99 - can you test this and verify that it works?  Thanks!
Assignee: nobody → stas
Attachment #8511638 - Attachment is obsolete: true
Status: UNCONFIRMED → ASSIGNED
Ever confirmed: true
Attachment #8511944 - Flags: feedback?(sv99)
Yes it's worked fine! Thanks!
For reproduce this need upgrade used test-agent version chai. Used now version chai not tested realy throwing message and test OK for any message!
Stas, you can apply manually the patch in bug 1070047 to test :)
Comment on attachment 8511944 [details] [review]
Fix the error message

Work fine
Attachment #8511944 - Flags: feedback?(sv99)
You need to log in before you can comment on or make changes to this bug.