If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

asm.js vs Private Mode: Temporary storage contains URLs of visited sites

RESOLVED DUPLICATE of bug 819496

Status

()

Core
Untriaged
RESOLVED DUPLICATE of bug 819496
3 years ago
3 years ago

People

(Reporter: Kreuvf, Unassigned)

Tracking

33 Branch
x86_64
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

3 years ago
User Agent: Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:33.0) Gecko/20100101 Firefox/33.0
Build ID: 20141013200257

Steps to reproduce:

1. Make sure that there is no 'temporary' directory in the 'storage' directory in the profile directory used.
2. Start Firefox (Ubuntu 14.04 Firefox 33 with Ghostery 5.4.1 and DownloadHelper 4.9.24).
3. File -> New Private Window
4. Put 'www.meteoearth.com' into the url bar.
5. Go there.
6. Close Firefox.


Actual results:

Find a new 'temporary' directory in your profile directory with a subdirectory 'http+++www.meteoearth.com'.


Expected results:

Find no new 'temporary' directory in your profile directory with a subdirectory 'http+++www.meteoearth.com'.

Comment 1

3 years ago
Why is it related to asm.js?
It's related to PB mode and offline cache.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 819496
(Reporter)

Comment 2

3 years ago
Besides a .metadata file there is only an asmjs directory, that's why I figured that it has to do with asm.js ;) At least, tat explains why I did not find the other bug. Sorry for spamming the bug tracker.

Comment 3

3 years ago
np, it's better to report a dupe than to not report a bug. :)
You need to log in before you can comment on or make changes to this bug.