If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Blank page when printing with Brother HL-11 series printer

RESOLVED DUPLICATE of bug 1089188

Status

()

Core
Printing: Output
RESOLVED DUPLICATE of bug 1089188
3 years ago
3 years ago

People

(Reporter: Monkeyman, Unassigned)

Tracking

33 Branch
x86_64
Windows 8.1
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

3 years ago
User Agent: Mozilla/5.0 (Windows NT 6.3; WOW64; rv:33.0) Gecko/20100101 Firefox/33.0
Build ID: 20141011015303

Steps to reproduce:

Just installed Brother HL-1102 driver and tried to print from Firefox.


Actual results:

Printed pages were blank.


Expected results:

Printed pages should contain text and images. Tried to print from any other major browser and some Windows programs - everything was printed perfectly. Only FireFox fails.
Do you have the issue only with that printer or did the previous printer work as expected ?
Do you get blank pages on all URLs or only on one special URL ?
Do you see content in the print preview ?
Do you have the same issue in a new profile: http://support.mozilla.org/kb/Managing%20profiles
Flags: needinfo?(provitiligo)
(Reporter)

Comment 2

3 years ago
(In reply to Matthias Versen [:Matti] from comment #1)
> Do you have the issue only with that printer or did the previous printer work as expected ?

My other printer works good, yes.

> Do you get blank pages on all URLs or only on one special URL ?

Yes, all URLs. I've tested this on several pages.

> Do you see content in the print preview ?

Nope, blank as well.

> Do you have the same issue in a new profile:

This is a new profile I'm using. Just reinstalled my OS.
Flags: needinfo?(provitiligo)
Can you please attach the output of about:support (enter it as url) as a file on this bug ?
- https://bugzilla.mozilla.org/attachment.cgi?bugid=1089372&action=enter
(Reporter)

Comment 4

3 years ago
Created attachment 8511688 [details]
support.txt

Here's a content of about:support.
Sorry but i have no idea but you should really try it with a new additional test profile just to be sure
A blank preview is often caused by wrong margins but I do not see that in your about;support output

Comment 6

3 years ago
There are some add-ons in you profile.
It would be good to test:
1) in safe mode: https://support.mozilla.org/en-US/kb/troubleshoot-firefox-issues-using-safe-mode
2 with a clean profile: https://support.mozilla.org/en-US/kb/profile-manager-create-and-remove-firefox-profiles (don't install anything in this testing profile)

It's easy to do and that can help a lot.

In addition, could you test with:
1) HWA disabled (Options > Advanced > General, restart FF to apply)
2) OMTC disabled (about:config > layers.offmainthreadcomposition.enabled=false, restart FF to apply)
Flags: needinfo?(provitiligo)
(Reporter)

Comment 7

3 years ago
For now I did the following:

1. Restarted in safe mode.
2. Restarted with reset and all addons uninstalled manually.
3. Disabled HWA.
4. Disabled OMTC.

Nothing's changed, still a blank page. Will also try clean profile, but I highly doubt this is the issue. It's my second printer, which is having issues with printing in FF and not in any other browser. Last time issue was different, but related to printing in FF anyway.
Flags: needinfo?(provitiligo)

Comment 8

3 years ago
The strange thing is you get blank pages in print preview too, before sending data to the printer.
So it's probably an issue in Firefox, not with your printer.
Component: Untriaged → Printing: Output
Product: Firefox → Core
(Reporter)

Comment 9

3 years ago
OK, just did a clean profile - no go, still blank page in preview and on paper. My FF now clean as a baby, but can't print anything with Brother printer. My guess, it's a rendering issue, but might be something else.

Ah, it also creates wrong page count. For example, I've tried to print the very first FF welcome page everybody sees right now, and got FOUR blank pages in preview. Happened to me with 50/50 chance and looks pretty random.

Comment 10

3 years ago
Did you remember if you got the issue with previous versions of FF? It could be a regression in FF33.

Previous versions are here, you can download them if you want: http://ftp.mozilla.org/pub/mozilla.org/firefox/releases/
(Reporter)

Comment 11

3 years ago
This is actually a new printer and very newly installed Windows. I didn't have the issue with the same printer in Windows 7, this I can tell for sure. Was using it 1.5-2 months ago and it worked good.

Comment 12

3 years ago
You can install FF32 or 31 in a different folder and test to know if it regressed.
(Reporter)

Comment 13

3 years ago
Just installed FF 31 and tried to print - same results. Just to be sure, opened the same page in IE for printing - all good.

Comment 14

3 years ago
Do you see some error messages in the web/browser consoles when you are trying to print preview a webpage?
(Reporter)

Comment 15

3 years ago
You mean, console, which becomes available, when you click Inspect Element?

Comment 16

3 years ago
Web console: Ctrl+Shift+K
Browser console: Ctrl+Shift+J
(Reporter)

Comment 17

3 years ago
Well, that's the same console I was talking about. Nope, nothing in there.

Comment 18

3 years ago
Did you try to change the margin number? Try something lower.

Comment 19

3 years ago
In addition, in about:config, reset the variables print_printer and print.print_printer.
(Reporter)

Comment 20

3 years ago
I don't have print_printer variable, only print.print_printer. Did reset it. No go.

Margins were at zero, but I've tried to reset them to default. No go.

I doubt, it has something with options. At least, changing any of them doesn't help at all.
(Reporter)

Comment 21

3 years ago
I want to add to this more info. Just tried to print with my other printer - HP LJ P1102W and got the same blank pages. Looks like printing is broken completely. Still works in any other browser or program with printing option.

Also I am using Windows 10 Tech Preview, not 8.1. You may want to test it under this version to confirm the issue.
(Reporter)

Comment 22

3 years ago
More testing results. The same PDF document sent to printer from FF ends with blank pages and printed perfectly when saved and opened in Acrobat Reader.

Are you guys going to do something about it? Problem's clearly with FF, not with Windows or anything else.

Comment 23

3 years ago
It's probably an issue with Win 10 which is still in beta phase.
(Reporter)

Comment 24

3 years ago
(In reply to Loic from comment #23)
> It's probably an issue with Win 10 which is still in beta phase.

OK, once again: ANY other browser prints the documents properly, except FF. Why do you keep denying, that there's a problem with YOUR browser and NOT with Windows 10?

Is it SO hard to look into and fix? I gave you pretty much enough proof, that printing in FF completely ruined under Win 10.
(Reporter)

Comment 25

3 years ago
I did a little digging today and seems, that this problem exists for quite a long time already. People were having absolutely the same issue on Windows 8.1 with absolutely different printers.

Probably, the whole printing management algorithm is faulty in FF. I really doubt, that this is an OS problem.

Hope you'll finally fix this, because right now googling for "firefox printing white pages" gives a bunch of results and not only for Windows 10.

Comment 26

3 years ago
the problem is firefox needs to fix to support windows 10.
I have tried multiple printers, both usb and networked.
Everything works fine with both chrome and internet explorer, but ff will only print blank pages.

http://answers.microsoft.com/en-us/windows/forum/windows_tp-performance/anyone-having-a-problem-printing-from-firefox-in/b05be085-d36f-426f-9224-fe36f8f55af0

Updated

3 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1089188
You need to log in before you can comment on or make changes to this bug.