'Open in a new tab' should create the tab next to the current tab (like on PC); or scroll tabs tray into position showing newly opened tabs

RESOLVED INVALID

Status

()

Firefox for Android
General
RESOLVED INVALID
3 years ago
2 years ago

People

(Reporter: fl0, Unassigned)

Tracking

({ux-efficiency})

34 Branch
ARM
Android
ux-efficiency
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

3 years ago
User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:34.0) Gecko/20100101 Firefox/34.0
Build ID: 20141023111813

Steps to reproduce:

Touch on 'Open in a new tab' open the new tab at the end of the tab list.
This is I think a usability problem as you've to scroll down to see your new tab



Expected results:

This is I think a usability problem as you've to scroll down to see your new tab (and the 'subjects' of your browsing get messed up)
The behaviour of Fx PC should be followed:
'Open a new tab' open the new tab next to the tab you're on.
Moreover this current bad behaviour will probably be worse with the new tab-bar (may be it solve this problem but I didn't tested it)
When I open a link in a new tab (from context-menu on a link), the tabs tray automatically selects the newly opened tab for me without the need to conduct any scrolling in the view. Does that not work for you?
OS: Windows 7 → Android
Hardware: x86_64 → ARM
(Reporter)

Comment 2

3 years ago
I don't think so: when I open a new tab from the context menu (ie 'long touch and then open in a new tab'), the new tab is not focused, and when I open the tab tray it's still focused on the current tab and I've to scroll down to see the tab I've opened, however the new 'go to' pop-up can help, it's I think not the right way to solve this.

As I see this it's similar to the 'conclusion' of #707801 .
Ok, I tested that out and see that behaviour on trunk. I guess this needs UX input.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Keywords: ux-efficiency
Summary: 'Open in a new tab' should create the tab next to the current tab (like on PC) → 'Open in a new tab' should create the tab next to the current tab (like on PC); or scroll tabs tray into position showing newly opened tabs
Closing this because it a) was fixed in the old tabs tray implementation (scroll to active tab), and b) the new tabs tray implementation is different (although it's regressed the feature). I'm filing bug 1202753 for this problem in tabs-tray-v3.
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.