Status

RESOLVED FIXED
4 years ago
4 years ago

People

(Reporter: arnaud.bienner, Assigned: achavez)

Tracking

Details

Attachments

(1 attachment)

398 bytes, application/vnd.ms-publisher
Details
(Reporter)

Description

4 years ago
Created attachment 8511702 [details]
id_rsa.pub

Following a hard drive crash, I lost my ssh keys, which I used to push to try server.
Could you please replace the old one with that new one?
Initial commit access was given as part of bug 799517.
Let me know if you need any other information.
(Reporter)

Updated

4 years ago
Depends on: 799517
This needs to go over to server-ops or someone in IT to make the change. Moving the bug over.
Assignee: mozillamarcia.knous → server-ops

Updated

4 years ago
Assignee: server-ops → achavez
(Assignee)

Comment 2

4 years ago
SSH key has been replaced with new. It takes about an hour for that key to get copied out.
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
(Reporter)

Comment 3

4 years ago
Doesn't seem to work when I tried to push to try server :(

hg push -f try
pushing to ssh://hg.mozilla.org/try
remote: Permission denied (publickey).
abandon : no suitable response from remote hg !

ssh -v hg.mozilla.org
[...]
debug1: Host 'hg.mozilla.org' is known and matches the RSA host key.
debug1: Found key in /home/arno/.ssh/known_hosts:8
debug1: ssh_rsa_verify: signature correct
[...]
debug1: Offering RSA public key: /home/arno/.ssh/id_rsa
debug1: Authentications that can continue: publickey
debug1: Trying private key: /home/arno/.ssh/id_dsa
debug1: Trying private key: /home/arno/.ssh/id_ecdsa
debug1: Trying private key: /home/arno/.ssh/id_ed25519
debug1: No more authentication methods to try.
Permission denied (publickey).

Is there anything missing, or does it just need more time than expected?
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
(Reporter)

Comment 4

4 years ago
I tried again just now and it still doesn't work (with the same error).
Are you sure my public key has correctly been replicated?

Let me know if I can help.
Flags: needinfo?(achavez)
Component: Repository Account Requests → Server Operations
QA Contact: shyam
(Assignee)

Comment 5

4 years ago
Everything looks good on our side.  Make sure your private key file has 600 permissions.  If you still have problems, paste the whole output of  ssh -vvvv hg.mozilla.org
Flags: needinfo?(achavez)
(Reporter)

Comment 6

4 years ago
Still doesn't work, and everything looks correct to me (BTW I use the same key for GitHub and other platforms without problems):

ls -la ~/.ssh/id_rsa*
-rw------- 1 arno arno 1679 août   4 22:13 /home/arno/.ssh/id_rsa
-rw-r--r-- 1 arno arno  398 août   4 22:13 /home/arno/.ssh/id_rsa.pub

My .ssh dir:
drwx------   2 arno arno  4096 sept. 28 21:57 .ssh


The log:

ssh -vvvv hg.mozilla.org 
OpenSSH_6.6.1, OpenSSL 1.0.1f 6 Jan 2014
debug1: Reading configuration data /home/arno/.ssh/config
debug1: Reading configuration data /etc/ssh/ssh_config
debug1: /etc/ssh/ssh_config line 19: Applying options for *
debug2: ssh_connect: needpriv 0
debug1: Connecting to hg.mozilla.org [63.245.215.25] port 22.
debug1: Connection established.
debug3: Incorrect RSA1 identifier
debug3: Could not load "/home/arno/.ssh/id_rsa" as a RSA1 public key
debug1: identity file /home/arno/.ssh/id_rsa type 1
debug1: identity file /home/arno/.ssh/id_rsa-cert type -1
debug1: identity file /home/arno/.ssh/id_dsa type -1
debug1: identity file /home/arno/.ssh/id_dsa-cert type -1
debug1: identity file /home/arno/.ssh/id_ecdsa type -1
debug1: identity file /home/arno/.ssh/id_ecdsa-cert type -1
debug1: identity file /home/arno/.ssh/id_ed25519 type -1
debug1: identity file /home/arno/.ssh/id_ed25519-cert type -1
debug1: Enabling compatibility mode for protocol 2.0
debug1: Local version string SSH-2.0-OpenSSH_6.6.1p1 Ubuntu-2ubuntu2
debug1: Remote protocol version 2.0, remote software version OpenSSH_5.4
debug1: match: OpenSSH_5.4 pat OpenSSH_5* compat 0x0c000000
debug2: fd 3 setting O_NONBLOCK
debug3: load_hostkeys: loading entries for host "hg.mozilla.org" from file "/home/arno/.ssh/known_hosts"
debug3: load_hostkeys: found key type RSA in file /home/arno/.ssh/known_hosts:8
debug3: load_hostkeys: loaded 1 keys
debug3: order_hostkeyalgs: prefer hostkeyalgs: ssh-rsa-cert-v01@openssh.com,ssh-rsa-cert-v00@openssh.com,ssh-rsa
debug1: SSH2_MSG_KEXINIT sent
debug1: SSH2_MSG_KEXINIT received
debug2: kex_parse_kexinit: curve25519-sha256@libssh.org,ecdh-sha2-nistp256,ecdh-sha2-nistp384,ecdh-sha2-nistp521,diffie-hellman-group-exchange-sha256,diffie-hellman-group-exchange-sha1,diffie-hellman-group14-sha1,diffie-hellman-group1-sha1
debug2: kex_parse_kexinit: ssh-rsa-cert-v01@openssh.com,ssh-rsa-cert-v00@openssh.com,ssh-rsa,ecdsa-sha2-nistp256-cert-v01@openssh.com,ecdsa-sha2-nistp384-cert-v01@openssh.com,ecdsa-sha2-nistp521-cert-v01@openssh.com,ssh-ed25519-cert-v01@openssh.com,ssh-dss-cert-v01@openssh.com,ssh-dss-cert-v00@openssh.com,ecdsa-sha2-nistp256,ecdsa-sha2-nistp384,ecdsa-sha2-nistp521,ssh-ed25519,ssh-dss
debug2: kex_parse_kexinit: aes128-ctr,aes192-ctr,aes256-ctr,arcfour256,arcfour128,aes128-gcm@openssh.com,aes256-gcm@openssh.com,chacha20-poly1305@openssh.com,aes128-cbc,3des-cbc,blowfish-cbc,cast128-cbc,aes192-cbc,aes256-cbc,arcfour,rijndael-cbc@lysator.liu.se
debug2: kex_parse_kexinit: aes128-ctr,aes192-ctr,aes256-ctr,arcfour256,arcfour128,aes128-gcm@openssh.com,aes256-gcm@openssh.com,chacha20-poly1305@openssh.com,aes128-cbc,3des-cbc,blowfish-cbc,cast128-cbc,aes192-cbc,aes256-cbc,arcfour,rijndael-cbc@lysator.liu.se
debug2: kex_parse_kexinit: hmac-md5-etm@openssh.com,hmac-sha1-etm@openssh.com,umac-64-etm@openssh.com,umac-128-etm@openssh.com,hmac-sha2-256-etm@openssh.com,hmac-sha2-512-etm@openssh.com,hmac-ripemd160-etm@openssh.com,hmac-sha1-96-etm@openssh.com,hmac-md5-96-etm@openssh.com,hmac-md5,hmac-sha1,umac-64@openssh.com,umac-128@openssh.com,hmac-sha2-256,hmac-sha2-512,hmac-ripemd160,hmac-ripemd160@openssh.com,hmac-sha1-96,hmac-md5-96
debug2: kex_parse_kexinit: hmac-md5-etm@openssh.com,hmac-sha1-etm@openssh.com,umac-64-etm@openssh.com,umac-128-etm@openssh.com,hmac-sha2-256-etm@openssh.com,hmac-sha2-512-etm@openssh.com,hmac-ripemd160-etm@openssh.com,hmac-sha1-96-etm@openssh.com,hmac-md5-96-etm@openssh.com,hmac-md5,hmac-sha1,umac-64@openssh.com,umac-128@openssh.com,hmac-sha2-256,hmac-sha2-512,hmac-ripemd160,hmac-ripemd160@openssh.com,hmac-sha1-96,hmac-md5-96
debug2: kex_parse_kexinit: none,zlib@openssh.com,zlib
debug2: kex_parse_kexinit: none,zlib@openssh.com,zlib
debug2: kex_parse_kexinit: 
debug2: kex_parse_kexinit: 
debug2: kex_parse_kexinit: first_kex_follows 0 
debug2: kex_parse_kexinit: reserved 0 
debug2: kex_parse_kexinit: diffie-hellman-group-exchange-sha256,diffie-hellman-group-exchange-sha1,diffie-hellman-group14-sha1,diffie-hellman-group1-sha1
debug2: kex_parse_kexinit: ssh-rsa,ssh-dss
debug2: kex_parse_kexinit: aes128-ctr,aes192-ctr,aes256-ctr,arcfour256,arcfour128,aes128-cbc,3des-cbc,blowfish-cbc,cast128-cbc,aes192-cbc,aes256-cbc,arcfour,rijndael-cbc@lysator.liu.se
debug2: kex_parse_kexinit: aes128-ctr,aes192-ctr,aes256-ctr,arcfour256,arcfour128,aes128-cbc,3des-cbc,blowfish-cbc,cast128-cbc,aes192-cbc,aes256-cbc,arcfour,rijndael-cbc@lysator.liu.se
debug2: kex_parse_kexinit: hmac-md5,hmac-sha1,umac-64@openssh.com,hmac-ripemd160,hmac-ripemd160@openssh.com,hmac-sha1-96,hmac-md5-96
debug2: kex_parse_kexinit: hmac-md5,hmac-sha1,umac-64@openssh.com,hmac-ripemd160,hmac-ripemd160@openssh.com,hmac-sha1-96,hmac-md5-96
debug2: kex_parse_kexinit: none,zlib@openssh.com
debug2: kex_parse_kexinit: none,zlib@openssh.com
debug2: kex_parse_kexinit: 
debug2: kex_parse_kexinit: 
debug2: kex_parse_kexinit: first_kex_follows 0 
debug2: kex_parse_kexinit: reserved 0 
debug2: mac_setup: setup hmac-md5
debug1: kex: server->client aes128-ctr hmac-md5 none
debug2: mac_setup: setup hmac-md5
debug1: kex: client->server aes128-ctr hmac-md5 none
debug1: SSH2_MSG_KEX_DH_GEX_REQUEST(1024<3072<8192) sent
debug1: expecting SSH2_MSG_KEX_DH_GEX_GROUP
debug2: bits set: 1550/3072
debug1: SSH2_MSG_KEX_DH_GEX_INIT sent
debug1: expecting SSH2_MSG_KEX_DH_GEX_REPLY
debug1: Server host key: RSA fa:e8:5a:cc:de:02:e0:c7:6e:ff:14:92:90:b9:12:be
debug3: load_hostkeys: loading entries for host "hg.mozilla.org" from file "/home/arno/.ssh/known_hosts"
debug3: load_hostkeys: found key type RSA in file /home/arno/.ssh/known_hosts:8
debug3: load_hostkeys: loaded 1 keys
debug3: load_hostkeys: loading entries for host "63.245.215.25" from file "/home/arno/.ssh/known_hosts"
debug3: load_hostkeys: found key type RSA in file /home/arno/.ssh/known_hosts:9
debug3: load_hostkeys: loaded 1 keys
debug1: Host 'hg.mozilla.org' is known and matches the RSA host key.
debug1: Found key in /home/arno/.ssh/known_hosts:8
debug2: bits set: 1555/3072
debug1: ssh_rsa_verify: signature correct
debug2: kex_derive_keys
debug2: set_newkeys: mode 1
debug1: SSH2_MSG_NEWKEYS sent
debug1: expecting SSH2_MSG_NEWKEYS
debug2: set_newkeys: mode 0
debug1: SSH2_MSG_NEWKEYS received
debug1: Roaming not allowed by server
debug1: SSH2_MSG_SERVICE_REQUEST sent
debug2: service_accept: ssh-userauth
debug1: SSH2_MSG_SERVICE_ACCEPT received
debug2: key: /home/arno/.ssh/id_rsa (0x7f99c90765e0),
debug2: key: /home/arno/.ssh/id_dsa ((nil)),
debug2: key: /home/arno/.ssh/id_ecdsa ((nil)),
debug2: key: /home/arno/.ssh/id_ed25519 ((nil)),
debug1: Authentications that can continue: publickey
debug3: start over, passed a different list publickey
debug3: preferred gssapi-keyex,gssapi-with-mic,publickey,keyboard-interactive,password
debug3: authmethod_lookup publickey
debug3: remaining preferred: keyboard-interactive,password
debug3: authmethod_is_enabled publickey
debug1: Next authentication method: publickey
debug1: Offering RSA public key: /home/arno/.ssh/id_rsa
debug3: send_pubkey_test
debug2: we sent a publickey packet, wait for reply
debug1: Authentications that can continue: publickey
debug1: Trying private key: /home/arno/.ssh/id_dsa
debug3: no such identity: /home/arno/.ssh/id_dsa: No such file or directory
debug1: Trying private key: /home/arno/.ssh/id_ecdsa
debug3: no such identity: /home/arno/.ssh/id_ecdsa: No such file or directory
debug1: Trying private key: /home/arno/.ssh/id_ed25519
debug3: no such identity: /home/arno/.ssh/id_ed25519: No such file or directory
debug2: we did not send a packet, disable method
debug1: No more authentication methods to try.
Permission denied (publickey).


I double checked, and the ssh key I've attached is the correct one:
cat ~/.ssh/id_rsa.pub 
ssh-rsa AAAAB3NzaC1yc2EAAAADAQABAAABAQDETfIZpG/LP9Gv6TVthHptzbSN0NeTucc+lrr3tLBiBKeE76pgiZOafbjzipWNqDHkWzCDvh36ZNxoiXQyRt9KnDkE+moQ1vQKNHLzfMkVHMgkiYdXGZa0D7sbTvGu4bdNLW/R7JziQUbaOYfHeKscFyEG1A8N1LToFrt1zf7ZO6MzeGkSN7rBIzKkqszDYGRVT+HvrF0MVwbWDzn/sH+0/Uks2Fs2DIZ4i+4Wxd53Y6iMjZnOAQBXU5VRKlRn3VyeJU9fISxBOPPhiYkxEEi6w1YvJC5u2dKwVQnG0U7IAA0Ocb3reSxwrTkplzr9V3I+3myWnj00xnx8w3X/TEc5 arno@arno-laptop

Let me know if you need any other information, or if I can help in any way.
Thanks a lot for all your efforts about this!

Comment 7

4 years ago
debug1: Connecting to hg.mozilla.org [63.245.215.25] port 22.
debug1: Connection established.
debug3: Incorrect RSA1 identifier
debug3: Could not load "/home/arno/.ssh/id_rsa" as a RSA1 public key

I think your .ssh/config file is misconfigured  id_rsa.pub = public key, id_rsa = private key
(Reporter)

Comment 8

4 years ago
Problem fixed. Thanks a lot for your time and patience!

For the record: I simply (stupidly) missed to set the username to use (my LDAP username) when connecting to ssh://hg.mozilla.org as explained here [1] or [2].

> I think your .ssh/config file is misconfigured  id_rsa.pub = public key,
> id_rsa = private key

Just to be complete in case someone will face similar issue and read this in the future, this wasn't the cause of the issue, and doesn't seem to be an issue at all, according to [3] and [4].

[1]: https://wiki.mozilla.org/ReleaseEngineering/TryServer#.7E.2F.ssh.2Fconfig
[2]: https://developer.mozilla.org/en-US/docs/Mercurial_FAQ#How_do_I_check_stuff_in.3F(In reply to Rick 
[3]: https://bbs.archlinux.org/viewtopic.php?id=122646 #6
[4]: http://stackoverflow.com/questions/12449626/trying-to-use-rsa-keys-to-ssh-into-ec2-getting-incorrect-rsa1-identifier-pe/15563793#15563793
Status: REOPENED → RESOLVED
Last Resolved: 4 years ago4 years ago
Resolution: --- → FIXED
Product: mozilla.org → mozilla.org Graveyard
You need to log in before you can comment on or make changes to this bug.