EOY Form: Set United States to default country, remove js to "fake" placeholder color

RESOLVED FIXED

Status

Mozilla Foundation Communications
Website
RESOLVED FIXED
3 years ago
3 years ago

People

(Reporter: Kelli Klein, Assigned: thecount)

Tracking

Details

(Whiteboard: [EOYFR2014][donation flow])

Attachments

(1 attachment)

(Reporter)

Description

3 years ago
The transition inside the fields from light gray > black font as you're typing is consistent here in Chrome, but isn't working the same way in Firefox.

Updated

3 years ago
Whiteboard: [EOYFR2014] → [EOYFR2014][donation flow]
Can you include a screenshot or video? I can't reproduce this in any browser.
Flags: needinfo?(kelli)
When I type "U-n-i-t-e-d" I cannot see my typing, and the list isn't pulled up so that ONLY countries that started with "United" are listed. Also if I keep trying to fix it, by backing out and trying again, after I type "U-n-i-t" and hit space on a laptop, this is what I see: http://note.io/1u5luNT

EFF has a nice configuration:
http://note.io/1u5lahV

Then when you click, the drop down rests at United States in the list and you can select:
http://note.io/1pWtWYv

No need to gray out / not gray out.
Oh okay so you want the default to be united states. We'll get to work on that.
Assignee: aki → scott
Flags: needinfo?(kelli)
OS: Mac OS X → All
Hardware: x86 → All
Summary: Address the transition fields in on static donation form in Firefox → EOY Form: Set United States to default country, remove js to "fake" placeholder color
Aki ideally the alpha form moves based on what I'm typing. Meaning if I type "United" then all other countries that don't start with "United" disappear from the drop down list, and only those countries that have "United" in their name are still there to easily select.

In the interest of time, defaulting to "united states" is OK if ^ will be a lot of work. Could we set this form up so that we can change the default for localized versions? E.g. it defaults to "Germany" in the list for our DE version?
So what you're asking for is generally 100% dependent on the OS, we don't have a lot of control over that. I'm not really certain we have the ability to localise default country either. Not because it's impossible, by any means, but just due to a restriction of BSD (and possibly time).
OK, thanks for checking. We would need to set a default country for US-EN, DE, FR, PT-BR, SP. (Those are the locales for this form.) If not possible no worries.
(Assignee)

Comment 7

3 years ago
Created attachment 8513222 [details] [review]
https://github.com/mozilla/bsd-forms-and-wrappers/pull/5

This just defaults to US, nothing else. Not sure about the locale stuff or how that works yet, but I feel without the locale stuff, defaulting to US might not be the best idea.
(Assignee)

Comment 8

3 years ago
Merged
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.