[flame] Ticking noise at about 6hz starting at power on.

RESOLVED FIXED

Status

Firefox OS
General
RESOLVED FIXED
4 years ago
3 years ago

People

(Reporter: ajb44.geo, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [POVB] The ticks stop when in aeroplane mode or opening the camera app)

(Reporter)

Description

4 years ago
User Agent: Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:33.0) Gecko/20100101 Firefox/33.0
Build ID: 20141013200257

Steps to reproduce:

Power the device on!

version info: 2.1.0.0-prerelease
platform 34.0a2
build 20131013001201
commit c97463d6


Actual results:

At a certain point the device startes ticking at around 6hz. It is not completely evenly spaced, sometimes there are  a few ticks at double rate and sometimes nothing.  I would guess a buffer underrun. 

The ticks continue when a headphone is plugged in, BUT still through the speaker, not the headphones. 

The ticks stop when in aeroplane mode. 

The bug is similar to https://bugzilla.mozilla.org/show_bug.cgi?id=807144 but for flame instead of unagi, and does not require any actions to trigger



Expected results:

silence
(Reporter)

Comment 1

4 years ago
All audio pcm streams seem to be closed, so the bug is likely  be occurreing in the kernel level or below (unless I misunderstand what these proc files are saying)

root@flame:/ # grep '.' /proc/asound/msm8x10skuaasnd/pcm*/sub0/status          
/proc/asound/msm8x10skuaasnd/pcm0c/sub0/status:closed
/proc/asound/msm8x10skuaasnd/pcm0p/sub0/status:closed
/proc/asound/msm8x10skuaasnd/pcm10c/sub0/status:closed
/proc/asound/msm8x10skuaasnd/pcm10p/sub0/status:closed
/proc/asound/msm8x10skuaasnd/pcm11c/sub0/status:closed
/proc/asound/msm8x10skuaasnd/pcm12c/sub0/status:closed
/proc/asound/msm8x10skuaasnd/pcm12p/sub0/status:closed
/proc/asound/msm8x10skuaasnd/pcm13c/sub0/status:closed
/proc/asound/msm8x10skuaasnd/pcm13p/sub0/status:closed
/proc/asound/msm8x10skuaasnd/pcm14c/sub0/status:closed
/proc/asound/msm8x10skuaasnd/pcm14p/sub0/status:closed
/proc/asound/msm8x10skuaasnd/pcm15c/sub0/status:closed
/proc/asound/msm8x10skuaasnd/pcm15p/sub0/status:closed
/proc/asound/msm8x10skuaasnd/pcm16c/sub0/status:closed
/proc/asound/msm8x10skuaasnd/pcm16p/sub0/status:closed
/proc/asound/msm8x10skuaasnd/pcm1c/sub0/status:closed
/proc/asound/msm8x10skuaasnd/pcm1p/sub0/status:closed
/proc/asound/msm8x10skuaasnd/pcm2c/sub0/status:closed
/proc/asound/msm8x10skuaasnd/pcm2p/sub0/status:closed
/proc/asound/msm8x10skuaasnd/pcm3c/sub0/status:closed
/proc/asound/msm8x10skuaasnd/pcm3p/sub0/status:closed
/proc/asound/msm8x10skuaasnd/pcm4p/sub0/status:closed
/proc/asound/msm8x10skuaasnd/pcm5p/sub0/status:closed
/proc/asound/msm8x10skuaasnd/pcm6c/sub0/status:closed
/proc/asound/msm8x10skuaasnd/pcm6p/sub0/status:closed
/proc/asound/msm8x10skuaasnd/pcm7p/sub0/status:closed
/proc/asound/msm8x10skuaasnd/pcm8c/sub0/status:closed
OS: All → Gonk (Firefox OS)
Hardware: All → ARM
I see another user in flamenews having the same issue.

Have you recently flashed the 1.88 base image?
Would you mind trying one more time?

I'm surprised to see that your buildid is from 2013:
> build 20131013001201
Could you please check again?
Status: UNCONFIRMED → NEW
Ever confirmed: true
Whiteboard: The ticks stop when in aeroplane mode.

Comment 3

4 years ago
Sounds like https://bugzilla.mozilla.org/show_bug.cgi?id=1073414. Does it stop when you disable WLAN, or open the camera?
(Reporter)

Comment 4

4 years ago
Armen: You're right, it's build 20141013001201
It was flashed at mozfest with the engineering build. How do I tell which base image that was?
It will be a few days before I can try reflashing.

Aphitiel: It does indeed stop when I open the camera, and starts again when I close it. IT stops when I disable WIFI, and restarts when I enable it again - although this takes a second or so.

I guess it probably is the same bug.

Comment 5

4 years ago
I am having the same issue with the v188 base images provided on the MDN page. I can also confirm that it goes away when WIFI is disabled.

Comment 6

4 years ago
Hi,

I flashed my device with v188 base image from MDN. Everything works awesome but when I connect to internet by WiFi and keep the speaker near my ear I hear a tick sound. I hear the same from the ear piece. 

Once Wifi is disabled the sounds goes off.
Flashed 1.88 shalowflashed gaia and b2g 2.1 update ota to 20141029001202

I noticed the 'ticking sound' during a call.

Listening near the speaker I hear the sound also when  I am not calling. The sound is gone when I disable WiFi.
I don't have the issue. Let's all paste our device information and see if we can spot anything:

NOTE: After you add your device info, update your device and see if you still have the issue. Note that you can only get updates if you check for updates or reboot your phone (due to bug 1051083).

Having issue:      No
OS Version:        2.1.0.0-prerelease
Platform version:  34.0
Build ID:          20141029001202
Update channel:    nightly-b2g34
Git commit:        eb0aab0f

On another note, shallow flashing to a different version than 2.0 (the one that comes with the base image) can yield issues since the Gonk bits are not updated when shallow flashing. Full flashing is not available unless you have LDAP credentials and access to the private builds repository.

(In reply to ajb44.geo from comment #4)
> Armen: You're right, it's build 20141013001201
> It was flashed at mozfest with the engineering build. How do I tell which
> base image that was?
> It will be a few days before I can try reflashing.
> 
marcia tells me that the base v180 was used for your phone at the mozfest.

This can also be determined by running this:
 $ adb shell getprop ro.bootloader

The last 4 digits tells you which base image you're running.

For 1.88 it should end like 1880.

Comment 9

4 years ago
Here is my device information,

I flashed with v188 from MDN page.

Having issue - YES
OS Version - 2.0.0.0 prerelease
Platform Version - 32.0
Build ID - 20141016183911
Update Channel - default
Git Commit - 8c5c956e

Can you share me the build image to the version you have ? With current version, when I ask it to look for update - System is already up to date.
(Reporter)

Comment 10

4 years ago
Okay, I'm on 180.  So just to collect all my info in one comment (this is the same phone as in the original report)
Having Issue - YES
OS version: 2.1.0.0-prerelease
platform: 34.0a2
build id: 20141013001201
update channel: default
commit: c97463d6

I just checked for updates, but there were none.
The reason you can't get updates is because you're on the "default" update channel (which is fine).

You both started with two different base images.
One of you is running 2.0 and the other 2.1.

ajb44, how did you get to 2.1?

Did both of you obtain the device at the mozfest?

I'm running low on ideas as to how to narrow this down.
Whiteboard: The ticks stop when in aeroplane mode. → The ticks stop when in aeroplane mode or opening the camera app

Comment 12

4 years ago
I got my device from MozFest. If you can share me the latest build same as yours I can flash and try.
(In reply to Gauthamraj ( RAJ ) from comment #12)
> I got my device from MozFest. If you can share me the latest build same as
> yours I can flash and try.

The instructions and the v188 base image (comes with Gaia 2.0) are listed in here:
https://developer.mozilla.org/en-US/Firefox_OS/Developer_phone_guide/Flame#Updating_your_Flame%27s_software
I can't reproduce the bug using v188 base image and 2.2 with today's OTA update.

Comment 15

4 years ago
Just found v123 on https://developer.mozilla.org/pt-PT/docs/Mozilla/Firefox_OS/Developer_phone_guide/Flame. There, the clicking is gone.

On v188 + Gaia nightly:

Having Issue - YES
OS version: 2.2.0.0-prerelease
platform: 36.0a1
build id: 20141027160203
update channel: nightly
commit: 5d0ffc09

After reflashing v188:

Having Issue - YES
OS version: 2.0.0.0-prerelease
platform: 32.0
build id: 20141016183911
update channel: default
commit: 8c5c956e

After reflashing v123:

Having Issue - NO
OS version: 1.3.0.0-prerelease
platform: 28.0
build id: 20140627162151
update channel: default
commit: 5c43d012

As mentioned in 1073414, the ticking stops after opening the phone and unplugging the camera.

Another thing: With base > 123 I can hear a faint hiss from the rear speaker when near the ear. Anyone else?

Comment 16

4 years ago
if this is Flame-only can you update the title with [Flame] for easy discovery? Thank you!

Comment 17

4 years ago
oops never mind ;)
(Reporter)

Comment 18

4 years ago
I got my device at mozfest too; it was also flashed there at the stall with an engineering build.

aphtiel: I don't think I can hear a hiss.
I hear this too, for me it started when we moved to KK base image (v180)  The ticks are definitely not coming from the speaker, it sounds like some kind of mechanical ticking.  

I don't hear any hiss from the speaker though.
When trying to locate the noise, I'd say that it's emitted either from the camera on the rear or left of it.

Comment 22

4 years ago
I've had this issue too. Ever since I flash the v180 base image, and now with v188.
It comes/goes when wifi is enabled/disabled.

I'm running builds from http://ftp.mozilla.org/pub/mozilla.org/b2g/nightly/latest-mozilla-aurora-flame-kk/
Just reflashed today after a v188 update

OS Version 2.1.0.0-prerelease
platform: 34.0a2
Build id: 20141013000205
Update channel: aurora
Commit: f5d4ff60

I also have a profile that was backed up/restored with scripts from B2G-flash-tool .. not sure if that could have any impact.

Comment 23

4 years ago
Having issue:      Yes
OS Version:        2.0.0.0-prerelease
Platform version:  32.0
Build ID:          20141030000200
Update channel:    nightly-b2g32
Git commit:        7b8df994

I am using base image 188 but I also noticed this issue previously with base image 180. I don't know about previous versions of the base image (did not have the Flame at the time).

Also, I still have the zip archive of base image 180. If someone needs it, I can upload it somewhere.

Comment 24

4 years ago
v188:

Having Issue: YES
OS version: 2.0.0.0-prerelease
platform: 32.0
build id: 20141016183911
update channel: default
commit: 8c5c956e

I also had this problem on v180.

Has anyone worked out where the sound is coming from?
My home WiFi network is pretty quiet; I only hear the tiniest of clicks regularly if I ping the device and hold it next to my ear. And yes, opening the camera did seem to mitigate this.

Having issue: Yes
OS version: 2.2.0.0-prelease
Platform version: 36.0a1
Build identifier: 20141030110022
Git commit: 86b3cdf8

Aside: I've had this sort of problem on an old laptop years ago, specifically any kind of WiFi data transfers resulted in clicking on my headphones. Adding shielding to the internal audio wiring helped a lot.

Comment 26

4 years ago
Hi again,

Since I had this issue with 2.0. I spent the day to learn about shallow flash and successfully flashed my flame to 2.2. Unfortunately, the problem still exists.

Having issue : Yes
OS Version - 2.2.0.0 - prelease
platform - 36.0a1
Build Identifier - 20141030040201
Git Commit -0dfc1996

Thoughts ?

Comment 27

4 years ago
Same problem here. Ticking noises can be heard with wifi on. The same ticking noises can be heard with wifi off, data on, and exchanging data (while geolocalizing, for example). The noise stops on either:

- Opening the camera (back camera only),
- Downloading large files.

The noise definitely comes from the back of the phone, near the camera, not from the speaker.

By removing the back cover and putting the ear very close to the camera, a much fainter ticking can still be heard with wifi on and back camera open (or while downloading large files). No such noise can be heard with wifi off.

Having Issue : Yes
OS Version - 2.0.0.0-prerelease
platform - 32.0
Build Identifier - 20141016183911
Git Commit - 8c5c956e

Comment 28

4 years ago
Andre, this sounds like those annoying sounds your device has when trying to do speech recognition, right?

Comment 29

4 years ago
(In reply to Robert Kaiser (:kairo@mozilla.com) from comment #28)
> Andre, this sounds like those annoying sounds your device has when trying to
> do speech recognition, right?

Yes Robert, you are right.

In my case, after flash with v180, when I open the microphone using gum from c++ gecko layer this ticking noise is soooo loud. Sometimes, after close and open the app again for few times, it stops, but in some cases lasts forever.

After flash to v188 I still hear it, but way less ticks.
Sorry for the spam, but got the issue too.

Having issue - YES
OS Version - 2.0.0.0 prerelease
Platform Version - 32.0
Build ID - 20141016183911
Update Channel - default
Git Commit - 8c5c956e

I had this issue upgrading from v123 to v188.
Same issue as comment 30.
Hi Youlong: pls check this issue as top priority today, I will call you later for discussion. Thank you.
Flags: needinfo?(youlong.jiang)

Comment 33

4 years ago
I flashed a flame running 1.3 directly to v188 and the weird sound did not occur anymore
Hi Youlong: as discussed in phone, we treat this as a potential blocker of v188, so please help investigate and clarify if this is something need to be fixed in kernel or low level code. (or need to be fixed in Gaia/Gekco) Thanks.

Comment 35

4 years ago
(In reply to Wesly Huang from comment #34)
> Hi Youlong: as discussed in phone, we treat this as a potential blocker of
> v188, so please help investigate and clarify if this is something need to be
> fixed in kernel or low level code. (or need to be fixed in Gaia/Gekco)
> Thanks.

hi wesly -

we've check the root cause about this problem is camera driver init issue, we'll fix in next version.

tks.
Flags: needinfo?(youlong.jiang)
Hi Youlong:

As discussed in meeting, please help put more detail about your root cause analysis/fix. Thanks.
Flags: needinfo?(youlong.jiang)

Comment 37

4 years ago
(In reply to Wesly Huang from comment #36)
> Hi Youlong:
> 
> As discussed in meeting, please help put more detail about your root cause
> analysis/fix. Thanks.

hi wesly -

camera driver didn't configure vcm gpio that make it variable. when wifi enable and pull vcm gpio high that lead to vcm leakage and move the resonance. our solution is config gpio low when it not work.

tks.
Flags: needinfo?(youlong.jiang)

Comment 38

4 years ago
In my case in Flame when I play an audio using audio tag and immediately after open the mic to record using gum, the frequency it is incredible high and loud.  

Also, I confirm this is happening in Open C as well, despite with a lower frequency
The noise has stopped after today's update on nightly-b2g32 (build id: 20141121000203). Can anyone else confirm? Looks like this issue has been fixed.

Comment 40

4 years ago
I just updated to build 20141121000203 but the ticking noise is still here with WiFi enabled.
Yes. I can't reproduce this on nightly-b2g32 (2.0.0.0-prerelease), but it is still strongly there on nightly (2.2.0.0-prerelease).

Comment 42

3 years ago
I also have this Problem with  v180 and v188, but fine in v123.

Do we know *what* is making the noise?
If it is some mechanical part like the auto focus this sounds like it could damage the device.

If it's a camera driver issue, this can only be fixed in the base image right?

Comment 43

3 years ago
verify with the latest base image v18B, it's fine
Verified fixed with base image v188, 2.2 and the latest OTA update, changing the status to WFM
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → WORKSFORME

Comment 45

3 years ago
(In reply to Gabriela [:gaby2300] from comment #44)
> Verified fixed with base image v188, 2.2 and the latest OTA update, changing
> the status to WFM

I just did a shallow flash with 2.2 ontop of my base image v188, and still get the ticking noise as soon as wifi is connected. Reopening.

Comment 46

3 years ago
Well, I can't reopen this appearently. Can someone else do it?
(Reporter)

Comment 47

3 years ago
Attempting to repopen, as I filed...
Status: RESOLVED → REOPENED
Resolution: WORKSFORME → ---
(Reporter)

Comment 48

3 years ago
I updated to v188, 2.2 and I also get the ticking still - but there are no updates. However, I am on the production channel. Gabriella, what update channel are you on? Maybe it is only fixed in nightly.

Comment 49

3 years ago
(In reply to ajb44.geo from comment #48)
> Maybe it is only fixed in nightly.

I am on nightly and still having that problem:
Platform Version: 37.0a1
Build ID: 20141211160202
Update Channel: nightly
Git Commit info: 2014-12-11 04:12:40 1a956437

Comment 50

3 years ago
I also have the issue with clicking noise after updating to v188 base image + gaia 2.2 latest master production builds (I had WiFi enabled and connected).

Hardware Revision: qcom
Build Number: 39
Platform Version: 37.0a1
Build Identifier: 20141212160202
Git Commit Info: 2014-12-12 06:55:39 0de95b40

$ adb shell getprop ro.bootloader
L1TC00011880
ni mwu, who will take an initial peek at this.
Flags: needinfo?(mwu)
From comments 35 - 37 an issue with the camera was isolated and was supposed to be fixed. However, the versions that fix was included in were not yet shared. We don't know if a fix was landed, and so we don't know if new reports are regressions, or are from builds where the fix didn't land.
With a just flashed Flame it still ticks endless. I don't open any app but keep it locked with LockScreen, and connect it with my Mac via USB. And, I debug it with app-manager.
Whiteboard: The ticks stop when in aeroplane mode or opening the camera app → [POVB] The ticks stop when in aeroplane mode or opening the camera app

Comment 54

3 years ago
any news on this? When can we expect the next baseimage update?

Comment 55

3 years ago
same as me ...

Comment 56

3 years ago
I haven't been able to reproduce this bug, but the next base image update (v18D) is supposed to fix this.
Flags: needinfo?(mwu)

Comment 57

3 years ago
I confirm this was fixed on speech recognition gecko repo [1] using v18d base image and master b2g.

[1] https://github.com/andrenatal/gecko-dev-speech
(In reply to Andre Natal from comment #57)
> I confirm this was fixed on speech recognition gecko repo [1] using v18d
> base image and master b2g.
> 
> [1] https://github.com/andrenatal/gecko-dev-speech

Where can v18d base image be downloaded ?
With the image I flashed yesterday (2015-02-09) using flash_pvt this is happening again, when the phone is connected to USB and to a power wall charger indistinctly.

Do we need to flash the base image too?

Comment 60

3 years ago
It's been a month now since Michael Wu said (#56) it's supposed to be fixed, but I can't find build v18D anywhere, just users talking about it.
I was expecting to find the build here https://developer.mozilla.org/en-US/Firefox_OS/Phone_guide/Flame/Updating_your_Flame
Am I looking in the wrong place?
What is the status of v18D? Couldn't you release just an update to the buggy driver until v18D is generally available?
I can't use WiFi at all because I don't want to risk breaking my camera shutter or auto-focus (whatever it is) - I suppose it's not made for being activated 6 times a second all day :-)
Without WiFi, Firefox OS is only half as fun as I constantly need to watch my 3g data usage..
Flags: needinfo?(mwu)
(In reply to Paul Schyska from comment #60)
> It's been a month now since Michael Wu said (#56) it's supposed to be fixed,
> but I can't find build v18D anywhere, just users talking about it.
> I was expecting to find the build here
> https://developer.mozilla.org/en-US/Firefox_OS/Phone_guide/Flame/
> Updating_your_Flame
> Am I looking in the wrong place?
> What is the status of v18D? Couldn't you release just an update to the buggy
> driver until v18D is generally available?
> I can't use WiFi at all because I don't want to risk breaking my camera
> shutter or auto-focus (whatever it is) - I suppose it's not made for being
> activated 6 times a second all day :-)
> Without WiFi, Firefox OS is only half as fun as I constantly need to watch
> my 3g data usage..

it's available here, but be careful it's buggy : http://cds.w5v8t3u9.hwcdn.net/v18D_nightly.zip

Comment 62

3 years ago
It was posted on MDN and then pulled, but you can still find it if you check the page history.
Flags: needinfo?(mwu)
The v18D is available publicly https://developer.mozilla.org/en-US/Firefox_OS/Phone_guide/Flame/Updating_your_Flame can we close this bug ?
Flags: needinfo?(dietrich)

Comment 64

3 years ago
For me, the problem is fixed after the update to v18D. I can now use wifi without the ticking noise.

Comment 65

3 years ago
(In reply to Antoine Turmel [:GeekShadow] from comment #63)
> The v18D is available publicly
> https://developer.mozilla.org/en-US/Firefox_OS/Phone_guide/Flame/
> Updating_your_Flame can we close this bug ?

I havn't heard it after flashing 18D
(Reporter)

Comment 66

3 years ago
I also haven't heard it since flashing to 18D. Can close as far as I am concerned.
Status: REOPENED → RESOLVED
Last Resolved: 3 years ago3 years ago
Flags: needinfo?(dietrich)
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.