Remove ancient and unused Perl scripts

RESOLVED FIXED in mozilla36

Status

()

Core
General
RESOLVED FIXED
3 years ago
3 years ago

People

(Reporter: njn, Assigned: njn)

Tracking

unspecified
mozilla36
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(6 attachments, 1 obsolete attachment)

(Assignee)

Description

3 years ago
By my count we currently have 94 Perl scripts in the repo. Some of them are imported third-party code, some of them are still useful, but some of them are unused. This bug is about eliminating the latter category.
(Assignee)

Comment 1

3 years ago
Created attachment 8511769 [details] [diff] [review]
Remove netwerk/test/neckoTiming.pl, which is ancient and unused

neckoTiming.pl was added in 2001 as part of the "Neck [sic?] Page Load Timer".
It hasn't been touched since then, and I suspect it's unused.
Attachment #8511769 - Flags: review?(mcmanus)
(Assignee)

Comment 2

3 years ago
Created attachment 8511770 [details] [diff] [review]
Remove gfx/tests/process-textruns.pl, which is ancient and unused

roc says this is unused.
Attachment #8511770 - Flags: review?(roc)
(Assignee)

Comment 3

3 years ago
Created attachment 8511785 [details] [diff] [review]
Reimplement build/unix/uniq.pl in Python, and remove its unit test

build/unix/uniq.pl is a script that prints its given arguments with duplicates
removed. Almost trivial, but implemented in surprisingly many lines of Perl.
(To be fair, it implements some options that we no longer need.)

This patch:

- Reimplements the script as a Python almost-one-liner.
  
- Removes the test, which IMO is unnecessary for something so simple. (The test
  was also surprisingly many lines.)

- Removes the corresponding test harness, which contained just this one test.

 8 files changed, 12 insertions(+), 385 deletions(-)

Huh.

One thing to note is that uniq.py doesn't preserve the original ordering, and I
think uniq.pl did. But that doesn't seem to matter.
Attachment #8511785 - Flags: review?(gps)

Comment 4

3 years ago
Comment on attachment 8511785 [details] [diff] [review]
Reimplement build/unix/uniq.pl in Python, and remove its unit test

Review of attachment 8511785 [details] [diff] [review]:
-----------------------------------------------------------------

Wow. Just wow.
Attachment #8511785 - Flags: review?(gps) → review+
(Assignee)

Comment 5

3 years ago
Created attachment 8511806 [details] [diff] [review]
Improve the comments in both gen_template.pl scripts
Attachment #8511806 - Flags: review?(bzbarsky)
(Assignee)

Comment 6

3 years ago
Created attachment 8511808 [details] [diff] [review]
Remove make-atom-strings.pl, which is ancient and unused
Attachment #8511808 - Flags: review?(bzbarsky)
(Assignee)

Comment 7

3 years ago
> By my count we currently have 94 Perl scripts in the repo.

Er, make that 97.
Comment on attachment 8511806 [details] [diff] [review]
Improve the comments in both gen_template.pl scripts

r=me
Attachment #8511806 - Flags: review?(bzbarsky) → review+
Comment on attachment 8511808 [details] [diff] [review]
Remove make-atom-strings.pl, which is ancient and unused

r=me
Attachment #8511808 - Flags: review?(bzbarsky) → review+
Attachment #8511770 - Flags: review?(roc) → review+
(Assignee)

Comment 10

3 years ago
Created attachment 8512259 [details] [diff] [review]
Remove analyze-xpcom-log.pl, which is ancient and unused
Attachment #8512259 - Flags: review?(nfroyd)
(Assignee)

Comment 11

3 years ago
Created attachment 8512261 [details] [diff] [review]
Remove config/module2dir.pl, which is ancient and unused
Attachment #8512261 - Flags: review?(mh+mozilla)
(Assignee)

Updated

3 years ago
Depends on: 1089832
(Assignee)

Updated

3 years ago
Depends on: 969985
(Assignee)

Updated

3 years ago
Duplicate of this bug: 1089843
Comment on attachment 8512261 [details] [diff] [review]
Remove config/module2dir.pl, which is ancient and unused

Your patch is empty, and it's also bug 1089855
Attachment #8512261 - Flags: review?(mh+mozilla) → review-
(Assignee)

Updated

3 years ago
Depends on: 1089855
(Assignee)

Updated

3 years ago
Attachment #8512261 - Attachment is obsolete: true
Attachment #8512259 - Flags: review?(nfroyd) → review+
Comment on attachment 8511769 [details] [diff] [review]
Remove netwerk/test/neckoTiming.pl, which is ancient and unused

Review of attachment 8511769 [details] [diff] [review]:
-----------------------------------------------------------------

please also remove PageList.txt which is the script's old input
Attachment #8511769 - Flags: review?(mcmanus) → review+
(Assignee)

Comment 15

3 years ago
Try looks good: https://treeherder.mozilla.org/ui/#/jobs?repo=try&revision=542b497abeba
(Assignee)

Comment 16

3 years ago
https://hg.mozilla.org/integration/mozilla-inbound/rev/64c5c57286bd
https://hg.mozilla.org/integration/mozilla-inbound/rev/82e3c989ec64
https://hg.mozilla.org/integration/mozilla-inbound/rev/693baa2d9ba9
https://hg.mozilla.org/integration/mozilla-inbound/rev/134b583fd7ab
https://hg.mozilla.org/integration/mozilla-inbound/rev/9e670b286999
https://hg.mozilla.org/integration/mozilla-inbound/rev/61c2235ebf16
(Assignee)

Comment 17

3 years ago
I over-counted initially. We're down to 88 now.
https://hg.mozilla.org/mozilla-central/rev/64c5c57286bd
https://hg.mozilla.org/mozilla-central/rev/82e3c989ec64
https://hg.mozilla.org/mozilla-central/rev/693baa2d9ba9
https://hg.mozilla.org/mozilla-central/rev/134b583fd7ab
https://hg.mozilla.org/mozilla-central/rev/9e670b286999
https://hg.mozilla.org/mozilla-central/rev/61c2235ebf16
Status: ASSIGNED → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla36
You need to log in before you can comment on or make changes to this bug.