Closed Bug 1089458 Opened 5 years ago Closed 5 years ago

crash in d2d1.dll@0x847d7

Categories

(Core :: Graphics, defect, critical)

36 Branch
All
Windows NT
defect
Not set
critical

Tracking

()

RESOLVED DUPLICATE of bug 1089454
Tracking Status
firefox36 - fixed

People

(Reporter: jbecerra, Unassigned)

Details

(Keywords: crash, Whiteboard: dupeme)

Crash Data

[Tracking Requested - why for this release]:

This bug was filed from the Socorro interface and is 
report bp-b2788a27-7d0c-4e19-a2b9-d79252141016.
=============================================================

This is #11 in the list of top crashers for Nightly (36). All of these are reported on Windows 8.1. It started spiking around 10/15. There are a couple of comments in the reports and both have to do with updating their graphics card drivers: "GeForce 970 driver update installed", for example.

All of these are on amd64

More reports at: https://crash-stats.mozilla.com/report/list?product=Firefox&signature=d2d1.dll%400x847d7

0 d2d1.dll 	d2d1.dll@0x847d7
Wonder if this is updating the driver while Firefox is running...
If it was during the update, it could be bug 1086614.
Hm, missing symbols for d2d1.dll.

On my machine this shows up as:
d2d1!D2DDeviceContextBase<ID2D1DeviceContext1,ID2D1DeviceContext1,null_type>::FillRectangle+0xa7
xul!mozilla::gfx::DrawTargetD2D1::FillRect+0xc1
(Stack cuts off at FillRect)

The crash is:
00007ff8`efaa47d7 0fb606          movzx   eax,byte ptr [rsi] ds:00000000`00000000=??

I suspect this is the Win64 counterpart to bug 1089461.
I'v seen this crash,crash report is here, this too is on windows 8.1
https://crash-stats.mozilla.com/report/index/b33e87f6-f2fa-40fd-ba0a-6296e2141031
In my eventlog I see a warning that nvlddmkm (a kernel mode driver component of my Nvidia Driver) crashed and was restored.
I remember that I was using a Bing 3d Maps when the screen flickered and the driver crashed.

Upon switching back to Firefox I got this crash.

If this is really related, then I think Firefox should recover gracefully from a failed video device driver.
BTW E10s was enabled.
Note that we just ran another MS symbols update, so those crashes *might* actually appear with a proper function signature starting now.
(In reply to Robert Kaiser (:kairo@mozilla.com) from comment #5)
> Note that we just ran another MS symbols update, so those crashes *might*
> actually appear with a proper function signature starting now.

Yes.
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1089454
You need to log in before you can comment on or make changes to this bug.